Subject: Bug#1000151: certbot.service: please provide some logs in journal

From: Alexandre Rossi <[email-masked]>
Date: Thu, 18 Nov 2021 18:25:19 +0100

Package: python-certbot
Version: 1.18.0-1
Severity: minor
Tags: patch

Dear Maintainer,

certbot.service leaves no info in the journal except for errors.

oct. 26 00:44:01 volyova systemd[1]: Starting Certbot...
oct. 26 00:44:03 volyova systemd[1]: certbot.service: Succeeded.

Certificate not due for renewal is also an interesting info.

nov. 16 00:44:01 volyova systemd[1]: Starting Certbot...
nov. 16 00:44:02 volyova certbot[772070]: Saving debug log to /var/log/letsencrypt/letsencrypt.log
nov. 16 00:44:02 volyova certbot[772070]: - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
nov. 16 00:44:02 volyova certbot[772070]: Processing /etc/letsencrypt/renewal/example.net.conf
nov. 16 00:44:02 volyova certbot[772070]: - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
nov. 16 00:44:02 volyova certbot[772070]: Cert not yet due for renewal
nov. 16 00:44:02 volyova certbot[772070]: - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
nov. 16 00:44:02 volyova certbot[772070]: The following certificates are not due for renewal yet:
nov. 16 00:44:02 volyova certbot[772070]:   /etc/letsencrypt/live/example.net/fullchain.pem expires on 2022-02-06 (skipped)
nov. 16 00:44:02 volyova certbot[772070]: No renewals were attempted.
nov. 16 00:44:02 volyova certbot[772070]: - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

The patch:

--- a/debian/certbot.service
+++ b/debian/certbot.service
@@ -4,5 +4,5 @@ Documentation=file:///usr/share/doc/python-certbot-doc/html/index.html
 Documentation=https://certbot.eff.org/docs
 [Service]
 Type=oneshot
-ExecStart=/usr/bin/certbot -q renew
+ExecStart=/usr/bin/certbot --non-interactive renew
 PrivateTmp=true

Thanks,

Alex

-- System Information:
Debian Release: 11.1
  APT prefers stable-security
  APT policy: (500, 'stable-security'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.10.0-9-amd64 (SMP w/4 CPU threads)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

---

From: Alexandre Rossi <[email-masked]>
Date: Thu, 12 Jan 2023 08:52:46 +0100

Hi,

If I can help providing a build ready to upload for this, do not hesitate to ping me.

Alex