Subject: Bug#1001525: ICC support should not be disabled in mupdf

From: Gregory Heytings <[email-masked]>
Date: Sat, 11 Dec 2021 15:09:57 +0000

Package: mupdf
Version: 1.19.0+ds1-1

Debian has disabled ICC support in mupdf.  Because of this colors are not 
always rendered correctly.  In bug#952724 the "ICC support is not 
available" has been (almost) disabled.  Adding ICC support is easy:

git submodule add git://git.ghostscript.com/thirdparty-lcms2.git 
thirdparty/lcms2

and comment the FZ_ENABLE_ICC=0 and USE_SYSTEM_LCMS2=yes lines in 
debian/rules.

---

From: Bastian Germann <[email-masked]>
Date: Sat, 11 Dec 2021 18:05:01 +0100

On 11.12.21 16:09, Gregory Heytings wrote:
> 
> Package: mupdf
> Version: 1.19.0+ds1-1
> 
> Debian has disabled ICC support in mupdf.  Because of this colors are not always rendered 
> correctly.  In bug#952724 the "ICC support is not available" has been (almost) disabled.  Adding ICC 
> support is easy:
> 
> git submodule add git://git.ghostscript.com/thirdparty-lcms2.git thirdparty/lcms2
> 
> and comment the FZ_ENABLE_ICC=0 and USE_SYSTEM_LCMS2=yes lines in debian/rules.

I will only enable this if Debian's lcms2 version works. I am happy to take patches.

---

From: Gregory Heytings <[email-masked]>
Date: Sat, 11 Dec 2021 17:46:35 +0000

>> Debian has disabled ICC support in mupdf.  Because of this colors are 
>> not always rendered correctly.  In bug#952724 the "ICC support is not 

That's not possible, at least not currently, see https://raw.githubusercontent.com/plangrid/ghostpdl/master/lcms2mt/doc/WhyThisFork.txt .

What is the problem with the above?  The lcms2mt library is built into the 
four mupdf binaries, and each one is about 1.5% larger.