Subject: mupdf: segmentation fault

From: "jindam, vani" <[email-masked]>
Date: Fri, 29 Jul 2022 16:45:01 +0000

Package: mupdf
Version: 1.20.0+ds1-1
Severity: important
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: bookworm/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: armhf (armv8l)

Kernel: Linux 3.18.91-16078765 (SMP w/4 CPU threads; PREEMPT)
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: unable to detect

Versions of packages mupdf depends on:
ii  freeglut3        2.8.1-6
ii  libc6            2.33-8
ii  libfreetype6     2.12.1+dfsg-3
ii  libgl1           1.4.0-1
ii  libgumbo1        0.10.1+dfsg-4
ii  libharfbuzz0b    2.7.4-1+b1
ii  libjbig2dec0     0.19-3
ii  libjpeg62-turbo  1:2.1.2-1
ii  libmujs2         1.2.0-3
ii  libopenjp2-7     2.5.0-1
ii  libssl3          3.0.5-1
ii  libx11-6         2:1.7.5-1
ii  libxext6         2:1.3.4-1
ii  zlib1g           1:1.2.11.dfsg-4

mupdf recommends no packages.

Versions of packages mupdf suggests:
pn  mupdf-tools  <none>

-- no debconf information

---

From: Bastian Germann <[email-masked]>
Date: Sun, 31 Jul 2022 17:13:41 +0200

> Kernel: Linux 3.18.91-16078765 (SMP w/4 CPU threads; PREEMPT)

Can somebody with a reasonably modern kernel version confirm this?

---

From: Сергей Фёдоров <[email-masked]>
Date: Sun, 01 Jan 2023 02:39:32 +0300

Package: mupdf
Version: 1.21.1+ds1-1
Followup-For: Bug #1016285
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

GeForce Graphics Card ASUS EN7300GT SILENT / HTD / 256M

Debian 11.6.0 64 installs:

Source: mesa  24 packets  v.20.3.5-1
Source: libglvnd  13 packets  v.1.3.2-1
Source: 9.0.2-1.1: libglu  2 packets  v.9.0.1-1

With this version of packages, any version of mupdf is compiled from source texts (from git too) and works fine. And the binary package mupdf 1.21.1+dd1-1 is installed and works fine.

But if you install:

Source: mesa  24 packets  22.3.1-1
Source: libglvnd  14 packets  v.1.5.0-1
Source: libglu  2 packets  v.9.0.2-1.1

then when mupdf-gl is started, the message "Error segmentation" is displayed and its execution is terminated. This happens with both the Linux kernel 5.10.20 and 6.0.0.6.

------------------------------------------------------------------------------------------------------------------------
xserver-xorg-video-nouveau     1:1.0.17-1  X.org X-сервер — VideoDriver Nouveau

Source: mesa  24 packets  v.20.3.5-1:
libxatracker-dev
libxatracker2
libd3dadapter9-mesa
libd3dadapter9-mesa-dev
libegl-mesa0
libegl1-mesa
libegl1-mesa-dev
libgbm-dev
libgbm1
libgl1-mesa-dev
libgl1-mesa-dri
libgl1-mesa-glx
libglapi-mesa
libgles2-mesa
libgles2-mesa-dev
libglx-mesa0
libosmesa6
libosmesa6-dev
libwayland-egl1-mesa
mesa-common-dev
mesa-opencl-icd
mesa-va-drivers
mesa-vdpau-drivers
mesa-vulkan-drivers

Source: libglvnd:  14 packets  v.1.3.2-1:
libegl-dev
libegl1
libgl-dev
libgl1
libgles-dev
libgles1
libgles2
libglvnd-core-dev
libglvnd-dev
libglvnd0
libglx-dev
libglx0
libopengl-dev
libopengl0

Source: libglu  2 packets  v.9.0.1-1
libglu1-mesa
libglu1-mesa-dev

------------------------------------------------------------------------------------------------------------------------
xserver-xorg-video-nouveau     1:1.0.17-1  X.org X-сервер — видеодрайвер Nouveau

Source: mesa:  22.3.1-1:
libxatracker-dev
libxatracker2
libd3dadapter9-mesa
libd3dadapter9-mesa-dev
libegl-mesa0
libegl1-mesa
libegl1-mesa-dev
libgbm-dev
libgbm1
libgl1-mesa-dev
libgl1-mesa-dri
libgl1-mesa-glx
libglapi-mesa
libgles2-mesa
libgles2-mesa-dev
libglx-mesa0
libosmesa6
libosmesa6-dev
libwayland-egl1-mesa
mesa-common-dev
mesa-opencl-icd
mesa-va-drivers
mesa-vdpau-drivers
mesa-vulkan-drivers

Source: libglvnd:  14 packets  v.1.5.0-1:
libegl-dev
libegl1
libgl-dev
libgl1
libgles-dev
libgles1
libgles2
libglvnd-core-dev
libglvnd-dev
libglvnd0
libglx-dev
libglx0
libopengl-dev
libopengl0

Source: libglu  2 packets  v.9.0.2-1.1:
libglu1-mesa
libglu1-mesa-dev

------------------------------------------------------------------------------------------------------------------------

-- System Information:
Debian Release: bookworm/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 6.0.0-6-amd64 (SMP w/8 CPU threads; PREEMPT)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages mupdf depends on:
ii  libc6            2.36-7
ii  libfreetype6     2.12.1+dfsg-3
ii  libgl1           1.3.2-1
ii  libglut3.12      3.4.0-1
ii  libgumbo1        0.10.1+dfsg-4
ii  libharfbuzz0b    6.0.0-1
ii  libjbig2dec0     0.19-3
ii  libjpeg62-turbo  1:2.1.2-1+b1
ii  libmujs2         1.3.2-1
ii  libopenjp2-7     2.5.0-1
ii  libssl3          3.0.7-1
ii  libx11-6         2:1.8.3-3
ii  libxext6         2:1.3.4-1+b1
ii  zlib1g           1:1.2.13.dfsg-1

---

From: Bastian Germann <[email-masked]>
Date: Sun, 1 Jan 2023 14:48:19 +0100

I happen to use an nVidia card with nouveau driver as well and have massive problems with OpenGL with all sort of 
application. So this is probably a driver-related issue. You should switch to use the mupdf binary instead.