Subject: Bug#1031171: lintian: error with continuous-integration/salsa on source:libvcflib_1.0.7+dfsg-2

From: Lucas Nussbaum <[email-masked]>
Date: Sun, 12 Feb 2023 19:38:17 +0100

Package: lintian
Version: 2.115.3
Severity: important

Hi,

I noticed that lintian fails when checking that package.

root@ip-10-84-234-37:/tmp# lintian libvcflib_1.0.7+dfsg-2.dsc
running with root privileges is not recommended!
Warning in processable libvcflib_1.0.7+dfsg-2.dsc: YAML::XS::Load Error: The problem:

    did not find expected '-' indicator

was found at document: 1, line: 7, column: 3
while parsing a block collection at line: 3, column: 3
warning: cannot run continuous-integration/salsa check on package source:libvcflib_1.0.7+dfsg-2
skipping check of source:libvcflib_1.0.7+dfsg-2
root@ip-10-84-234-37:/tmp# echo $?
1

Best,

Lucas

---

From: Louis-Philippe Véronneau <[email-masked]>
Date: Mon, 2 Sep 2024 12:40:23 -0400

retitle 1031171 Check/ContinuousIntegration/Salsa.pm crashes on invalid yaml
thanks

This issue is caused by invalid yaml in the debian/salsa-ci.yml file:

=================================================================================
---
include:
   - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/salsa-ci.yml
   - https://salsa.debian.org/salsa-ci-team/pipeline/raw/master/pipeline-jobs.yml

# Does not build on i386
variables:
   SALSA_CI_DISABLE_BUILD_PACKAGE_I386: 1
=================================================================================

That "SALSA_CI..." variable line should star with a - and it does not.

Of course, lintian shouldn't just error and skip the test.

-- 
   ⢀⣴⠾⠻⢶⣦⠀
   ⣾⠁⢠⠒⠀⣿⡁  Louis-Philippe Véronneau
   ⢿⡄⠘⠷⠚⠋   [email-masked] / veronneau.org
   ⠈⠳⣄