Subject: reprotest: make it easier to compare against an existing build (eg from ftp.d.o)

From: Holger Levsen <[email-masked]>
Date: Wed, 12 Apr 2023 21:51:17 +0200

Package: reprotest
Version: 0.7.23
Severity: wishlist

Dear Maintainer,

<vagrantc> i guess reprotest maybe should grow an option to do
            --control-build /path/to/packages/ 
            --vary=build_path=/use/this/build/path ... 
           to make it easier to use reprotest to compare against an existing build
<h01ger>   YES
<vagrantc> e.g. there is no way to disable buidl path variations when comparing
            against an arbitrary build
<h01ger>   i'm reporting this as a bug to the bts, quoting your words here. (ok?)
<vagrantc> reprotest can control it's own builds ... but if i want to use reprotest
           against the archive packages or an sbuild 
           or pbuilder build package ... it will always have a different build path
<vagrantc>  h01ger: sure!
<h01ger> :) thanks

-- 
cheers,
	Holger

 ⢀⣴⠾⠻⢶⣦⠀
 ⣾⠁⢠⠒⠀⣿⡁  holger@(debian|reproducible-builds|layer-acht).org
 ⢿⡄⠘⠷⠚⠋⠀  OpenPGP: B8BF54137B09D35CF026FE9D 091AB856069AAA1C
 ⠈⠳⣄

This too shall pass.

---

From: Vagrant Cascadian <[email-masked]>
Date: Fri, 08 Mar 2024 14:52:58 -0800

>            or pbuilder build package ... it will always have a different build path

Forgot about this bug, but I have since implemented a proof-of-concept
of this:

  https://salsa.debian.org/reproducible-builds/reprotest/-/commits/wip-specify-build-path?ref_type=heads

:)

live well,
  vagrant

---

From: Vagrant Cascadian <[email-masked]>
Date: Thu, 11 Apr 2024 16:15:06 -0700

>   https://salsa.debian.org/reproducible-builds/reprotest/-/commits/wip-specify-build-path?ref_type=heads

And merged in 0.7.27 ... which resolves the one specific issue mentioned
... are there any other must-haves we need to consider this bug closed?

Better documentation of how to actually do this? :)

live well,
  vagrant