Subject: firejail-profiles: SuperTuxKart cannot cope with existing supertuxkart savefile

From: Rishi Cutchin <[email-masked]>
Date: Tue, 18 Apr 2023 18:26:24 -0700

Package: firejail-profiles
Version: 0.9.72-2
Severity: normal
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

Attempting to run 'supertuxkart' with an existing savefile will lead to
the game not launching, with errors related to the rendering engine, creating a new user and launching supertuxkart
does allow it to start, not sure how I would go about working around
this as it appears that supertuxkart has access to everything it should
need.

-- System Information:
Debian Release: 12.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'testing-security'), (50, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 6.1.0-7-amd64 (SMP w/4 CPU threads; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages firejail-profiles depends on:
ii  firejail  0.9.72-2

firejail-profiles recommends no packages.

firejail-profiles suggests no packages.

-- Configuration Files:
/etc/firejail/steam.profile changed [not included]

-- no debconf information

---

From: Reiner Herrmann <[email-masked]>
Date: Mon, 24 Apr 2023 21:51:32 +0200

Hi Rishi,

> this as it appears that supertuxkart has access to everything it should

thanks for the report.
I can't reproduce that right now. I already have a saved supertuxkart
(1.4) game, and run it with firejail:  $ firejail supertuxkart
It launches fine.
Can you please send the output of the command on the terminal?

Kind regards,
  Reiner

---

From: Rishi Cutchin <[email-masked]>
Date: Mon, 24 Apr 2023 15:40:14 -0700

Here is the output of $firejail supertuxkart

Reading profile /etc/firejail/supertuxkart.profile
Reading profile /home/rishi/.config/firejail/supertuxkart.local
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-exec.inc
Reading profile /etc/firejail/disable-interpreters.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/disable-shell.inc
Reading profile /etc/firejail/disable-xdg.inc
Reading profile /etc/firejail/whitelist-common.inc
Reading profile /etc/firejail/whitelist-runuser-common.inc
Reading profile /etc/firejail/whitelist-usr-share-common.inc
Reading profile /etc/firejail/whitelist-var-common.inc
Warning: networking feature is disabled in Firejail configuration file
Parent pid 25087, child pid 25088
Warning: skipping none for private /opt
Private /opt installed in 0.07 ms
Warning: skipping none for private /srv
Private /srv installed in 0.07 ms
1 program installed in 38.66 ms
Warning: An abstract unix socket for session D-BUS might still be 
available. Use --net or remove unix from --protocol set.
Error fcopy: size limit of 500 MB reached
Warning: skipping crypto-policies for private /etc
Warning: skipping drirc for private /etc
Warning: skipping pki for private /etc
Private /etc installed in 18.78 ms
Private /usr/etc installed in 0.00 ms
Warning: NVIDIA card detected, nogroups command ignored
Warning: cleaning all supplementary groups
Warning: NVIDIA card detected, nogroups command ignored
Warning: cleaning all supplementary groups
Warning: NVIDIA card detected, nogroups command ignored
Warning: cleaning all supplementary groups
Child process initialized in 135.37 ms
[info   ] FileManager: Creating directory '/home/rishi/.cache/supertuxkart'.
[info   ] FileManager: Creating directory 
'/home/rishi/.cache/supertuxkart/cached-textures/'.
[verbose  ] main: Error messages and other text output will be logged to 
/home/rishi/.config/supertuxkart/config-0.10/stdout.log.
[info   ] [FileManager]: Data files will be fetched from: 
'/usr/share/games/supertuxkart/data/'
[info   ] [FileManager]: User directory is 
'/home/rishi/.config/supertuxkart/config-0.10/'.
[info   ] [FileManager]: Addons files will be stored in 
'/home/rishi/.local/share/supertuxkart/addons/'.
[info   ] [FileManager]: Screenshots will be stored in 
'/home/rishi/.local/share/supertuxkart/screenshots/'.
[info   ] [FileManager]: User-defined grand prix will be stored in 
'/home/rishi/.local/share/supertuxkart/grandprix/'.
[info   ] [FileManager]: Asset 0 will be loaded from 
'/usr/share/games/supertuxkart/data/challenges/'.
[info   ] [FileManager]: Asset 1 will be loaded from 
'/usr/share/games/supertuxkart/data/gfx/'.
[info   ] [FileManager]: Asset 2 will be loaded from 
'/usr/share/games/supertuxkart/data/grandprix/'.
[info   ] [FileManager]: Asset 3 will be loaded from 
'/usr/share/games/supertuxkart/data/gui/icons/'.
[info   ] [FileManager]: Asset 4 will be loaded from 
'/usr/share/games/supertuxkart/data/gui/screens/'.
[info   ] [FileManager]: Asset 5 will be loaded from 
'/usr/share/games/supertuxkart/data/gui/dialogs/'.
[info   ] [FileManager]: Asset 6 will be loaded from 
'/usr/share/games/supertuxkart/data/replay/'.
[info   ] [FileManager]: Asset 7 will be loaded from 
'/usr/share/games/supertuxkart/data/shaders/'.
[info   ] [FileManager]: Asset 8 will be loaded from 
'/usr/share/games/supertuxkart/data/skins/'.
[info   ] [FileManager]: Asset 9 will be loaded from 
'/usr/share/games/supertuxkart/data/ttf/'.
[info   ] [FileManager]: Asset 10 will be loaded from 
'/usr/share/games/supertuxkart/data/po/'.
[info   ] [FileManager]: Asset 11 will be loaded from 
'/usr/share/games/supertuxkart/data/library/'.
[info   ] [FileManager]: Asset 12 will be loaded from 
'/usr/share/games/supertuxkart/data/models/'.
[info   ] [FileManager]: Asset 13 will be loaded from 
'/usr/share/games/supertuxkart/data/music/'.
[info   ] [FileManager]: Asset 14 will be loaded from 
'/usr/share/games/supertuxkart/data/sfx/'.
[info   ] [FileManager]: Asset 15 will be loaded from 
'/usr/share/games/supertuxkart/data/textures/'.
[info   ] [FileManager]: Asset 16 will be loaded from 
'/usr/share/games/supertuxkart/data/tracks/'.
[verbose  ] translation: Env var LANGUAGE = 'en_US.UTF-8'.
[verbose  ] translation: Language 'English (United States)'.
..:: Antarctica Rendering Engine 2.0 ::..
[info   ] [IrrDriver Logger]: ..:: Antarctica Rendering Engine 2.0 ::..
[info   ] [IrrDriver Logger]: Could not initialize display!
[info   ] [IrrDriver Logger]: ..:: Antarctica Rendering Engine 2.0 ::..
[info   ] [IrrDriver Logger]: Could not initialize display!
[info   ] [IrrDriver Logger]: ..:: Antarctica Rendering Engine 2.0 ::..
[info   ] [IrrDriver Logger]: Could not initialize display!
[info   ] [IrrDriver Logger]: ..:: Antarctica Rendering Engine 2.0 ::..
[info   ] [IrrDriver Logger]: Could not initialize display!
[fatal  ] irr_driver: Couldn't initialise irrlicht device. Quitting.