Subject: Bug#1035857: texlive-fonts-extra: broken font symlinks for junicode

From: Andreas Beckmann <[email-masked]>
Date: Wed, 10 May 2023 11:18:41 +0200

Package: texlive-fonts-extra
Version: 2022.20230122-4
Severity: serious
User: [email-masked]
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package ships (or creates)
broken symlinks:

3m10.3s ERROR: FAIL: Broken symlinks:
  /usr/share/texlive/texmf-dist/fonts/truetype/public/junicode/Junicod -> ../../../../../../fonts/truetype/junicode/Junicode-BoldItalic.ttf (texlive-fonts-extra-links)
  /usr/share/texlive/texmf-dist/fonts/truetype/public/junicode/Junicode-Bold -> ../../../../../../fonts/truetype/junicode/Junicode-Bold.ttf (texlive-fonts-extra-links)
  /usr/share/texlive/texmf-dist/fonts/truetype/public/junicode/Junicode-It -> ../../../../../../fonts/truetype/junicode/Junicode-Italic.ttf (texlive-fonts-extra-links)
  /usr/share/texlive/texmf-dist/fonts/truetype/public/junicode/Junicode.ttf -> ../../../../../../fonts/truetype/junicode/Junicode.ttf (texlive-fonts-extra-links)

fonts-junicode nowadays only ships *.otf, no more *.ttf.

The Junicode link names also look broken to me, like they got truncated
somehow, and missing the file extension.
Especially the first one: "Junicod".

fonts-alegreya-sans will not be in bookworm (and hasn't been in
bullseye), thus
  /usr/share/texlive/texmf-dist/fonts/opentype/huerta/alegreya
also contains broken symlinks.

cheers,

Andreas

---

From: Preuße, Hilmar <[email-masked]>
Date: Wed, 10 May 2023 22:24:57 +0200

On 10.05.2023 11:18, Andreas Beckmann wrote:

Hello,

> fonts-junicode nowadays only ships *.otf, no more *.ttf.
I planned to fix that in the past (move files from t-f-e-links to
t-f-e), see commit 7fc1a4238a23a5bc0a7c76fd6465906d48601a0a .
Unfortunately at the same time I moved that some files into the other
direction, so I had to revert that step in
42a992dff6dd2b54ce0ffc10367a29913e062c0b, else there would be no upgrade
path from bullseye to bookworm. I have to delay the fix to post-bookworm.

> Especially the first one: "Junicod".
Yes, this is definitely a Typo, but correcting them does not solve an issue.

> also contains broken symlinks.
Was introduced in 5a1a62fe981bf67e743592ba689c2f18853a8886.
Unfortunately I noticed to late that fonts-alegreya-sans is RC buggy and
I downgraded the Dep to recommend:
42f75ab3ead843b6b04edc6f4aed7498cb53101f . This could be reverted before
bookworm, I'd need to build a new orig.tar.gz as the font files are
black listed. Is it really that urgent?

Hilmar
--
sigfault

---

From: Andreas Beckmann <[email-masked]>
Date: Wed, 10 May 2023 22:47:04 +0200

> black listed. Is it really that urgent?

You have some nice non-trivial packages here ;-)

If you say the broken symlinks are not really a problem for bookworm 
(and hard to fix), feel free to downgrade the severity and postpone a 
fix for it to trixie.

Andreas

---

From: Preuße, Hilmar <[email-masked]>
Date: Wed, 10 May 2023 23:41:19 +0200

Control: tags -1 + bookworm-ignore

Hi,

> You have some nice non-trivial packages here ;-)
Well, yes.

> (and hard to fix), feel free to downgrade the severity and
>
People trying to use that font, would need to install a package from
unstable. Until now there was no complaint (except you). Best thing we
could do is to fix the issue in fonts-alegreya-sans. I tried so by
reporting to upstream, but currently there is not much move.

> postpone a fix for it to trixie.
>
"trixie"? First release for years, not starting with "b". I started
already confusing the code names. ;-)

H.
--
--
sigfault

---

From: Norbert Preining <[email-masked]>
Date: Thu, 11 May 2023 13:47:03 +0900

> If you say the broken symlinks are not really a problem for bookworm (and

Broken symlinks in the TEXMF dirs are not a problem, since kpathsea will
ignore them.

So the worst thing is that some font is not available, that is hardly a
problem since the fonts are not generally used.

Best

Norbert

--
PREINING Norbert                              https://www.preining.info
Mercari Inc.     +     IFMGA Guide     +     TU Wien     +     TeX Live
GPG: 0x860CDC13   fp: F7D8 A928 26E3 16A1 9FA0 ACF0 6CAC A448 860C DC13

---

From: Preuße, Hilmar <[email-masked]>
Date: Thu, 11 May 2023 23:42:06 +0200

Hi again,

> during a test with piuparts I noticed your package ships (or creates)
OK, had a closer look: the "Debian Fonts Task Force" replaced the
"Junicode 1" by "Junicode 2" although they may behave differently

"Users of the various versions of Junicode 1 need to be aware that
documents originally set in Junicode 1 may reflow when set in Junicode
2. Further, documents that use the OpenType features of Junicode 1
(aside from basics like kerning and standard ligatures) may not be
displayed properly when changed over to Junicode 2."

I guess it would have been better to create fonts-junicode2 and then
slowly phase out fonts-junicode, when v2 left beta stage.

I could simply fix the links and point them to the v2 OTF fonts. This
could be even done now. This would give Debian users the v2 fonts but I
don't know if they are compatible to the Junicode related files in
texlive-fonts-extra. Junicode v2 wasn't even uploaded to CTAN yet. I
guess it is a better idea to stay with Junicode 1 for now and
re-integrate them into tfe after bookworm..

> also contains broken symlinks.
Well, I tend to say "this is not my fault". I may revert my decision
after bookworm.

H.
--
sigfault

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Thu, 12 Oct 2023 09:27:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the texlive-fonts-extra package:

#1035857: texlive-fonts-extra: broken font symlinks for junicode

It has been closed by Debian FTP Masters <[email-masked]> (reply to Hilmar Preusse <[email-masked]>).

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> (reply to Hilmar Preusse <[email-masked]>) by
replying to this email.

-- 
1035857: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1035857
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Bug#1035857: fixed in texlive-extra 2023.20231007-1
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Thu, 12 Oct 2023 09:24:30 +0000

Source: texlive-extra
Source-Version: 2023.20231007-1
Done: Hilmar Preusse <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
texlive-extra, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Hilmar Preusse <[email-masked]> (supplier of updated texlive-extra package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 08 Oct 2023 20:46:15 +0000
Source: texlive-extra
Architecture: source
Version: 2023.20231007-1
Distribution: unstable
Urgency: medium
Maintainer: Debian TeX Task Force <[email-masked]>
Changed-By: Hilmar Preusse <[email-masked]>
Closes: 992269 1035857 1045828 1046800 1051497
Changes:
 texlive-extra (2023.20231007-1) unstable; urgency=medium
 .
   * New upstream snapshot.
     - Contains new version of NewTX (Closes: #1051497).
     - abstract.bst is back in texlive-bibtex-extra (Closes: #992269)
   * Font moves (Closes: #1035857).
     - Reinclude Junicode into texlive-f-extra; remove Dep on
       fonts-junicode. This package does not ship the expected ttf
       files any more.
     - Reinclude Alegreya into texlive-f-extra; remove Dep on
       fonts-alegreya-sans. This package is RC-buggy and does not
       migrate to testing.
   * Blacklist parts of the pax lib, rather link these files from the
     appropriate Debian packages and delete the links later. This makes
     the build repeatable (Closes: #1045828)
   * Remove *jar and *class files generated during pax build.
     (Closes: #1046800).
Checksums-Sha1:
 3272ee038bca0c4fc478f8f39bad8cd91eeb5bc2 3995 texlive-extra_2023.20231007-1.dsc
 3f4061464b1e216a67bcadcaf9a4415216a34596 19060 texlive-extra_2023.20231007.orig-tex4ht.tar.xz
 a3079ad986dd2acb1ccebd875ee203584a6cd59e 2373892704 texlive-extra_2023.20231007.orig.tar.xz
 e0aa1a50b84acdc47a425d45d34bd386645c901c 195068 texlive-extra_2023.20231007-1.debian.tar.xz
 f63b24bd958e768cae3ce833aa6a392b3cb3f8fc 6008 texlive-extra_2023.20231007-1_source.buildinfo
Checksums-Sha256:
 d12fbf2f5313718653e52075360355b6ad430273d5deb9b0bda430c79679b402 3995 texlive-extra_2023.20231007-1.dsc
 13b930cd335fb7aefe3b04a3cf6b722589b6df653498ca8816000b4092351647 19060 texlive-extra_2023.20231007.orig-tex4ht.tar.xz
 ff53498301839705879ae200e0b63d9e6759efd2d33a28cb593cf122a899419d 2373892704 texlive-extra_2023.20231007.orig.tar.xz
 5bf5b8ecf2fa3e5a86190bcfee4d669cc66ccde8736b4fd3a75c48c3b1a2d8ea 195068 texlive-extra_2023.20231007-1.debian.tar.xz
 47a4cb0e14569b99337309f361ec191a1cc478309861fbeac4d66bce5aaa2edd 6008 texlive-extra_2023.20231007-1_source.buildinfo
Files:
 e8affe2196e8ae98a6403c0bd251b946 3995 tex optional texlive-extra_2023.20231007-1.dsc
 06a2d42a824bbde3db999ffeb98b0ed1 19060 tex optional texlive-extra_2023.20231007.orig-tex4ht.tar.xz
 253a347579c084efc677a2906203569f 2373892704 tex optional texlive-extra_2023.20231007.orig.tar.xz
 1571cb4f8216bd969fd5e434cf194a27 195068 tex optional texlive-extra_2023.20231007-1.debian.tar.xz
 7f7d9d3bb2abb74abb35cb28624ce7d0 6008 tex optional texlive-extra_2023.20231007-1_source.buildinfo

Subject: texlive-fonts-extra: broken font symlinks for junicode
From: Andreas Beckmann <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Wed, 10 May 2023 11:18:41 +0200

Hi,

cheers,

Andreas