Subject: pwsafe: empty window after internal timeout or screen blank

From: Giuseppe Sacco <[email-masked]>
Date: Wed, 31 May 2023 09:48:45 +0200

Package: passwordsafe
Version: 1.16.0+dfsg-4
Severity: normal

Dear Maintainer,
after running pwsafe, it select the default keystore, prompts for the
password and displays the keystore content in the GUI. After some time the
window automatically disappear but I may get it back using Alt-Tab key.
Once the window is shown again, it is empty: it does not list the keystore
content and it does not prompt for the keystore password either. Here, if I
open the File menu and select the 'Unlock Safe' menu item, I see the
keystore content correctly.

I did not find any configuration option that could prevent the password
prompt when getting back the pswafe window. Is this an error?

Thank you,
Giuseppe

-- System Information:
Debian Release: 12.0
  APT prefers testing-security
  APT policy: (500, 'testing-security'), (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 6.1.0-9-amd64 (SMP w/4 CPU threads; PREEMPT)
Locale: LANG=it_IT.utf8, LC_CTYPE=it_IT.utf8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages passwordsafe depends on:
ii  libc6                2.36-9
ii  libgcc-s1            12.2.0-14
ii  libmagic1            1:5.44-3
ii  libqrencode4         4.1.1-1
ii  libstdc++6           12.2.0-14
ii  libuuid1             2.38.1-5+b1
ii  libwxbase3.2-1       3.2.2+dfsg-2
ii  libwxgtk3.2-1        3.2.2+dfsg-2
ii  libx11-6             2:1.8.4-2
ii  libxerces-c3.2       3.2.4+debian-1
ii  libxtst6             2:1.2.3-1.1
ii  libykpers-1-1        1.20.0-3
ii  passwordsafe-common  1.16.0+dfsg-4

Versions of packages passwordsafe recommends:
pn  xvkbd  <none>

passwordsafe suggests no packages.

-- no debconf information

---

From: Bill Blough <[email-masked]>
Date: Wed, 31 May 2023 09:13:49 -0400

Hi,

If I understand your report correctly, this sounds like expected
behavior - the program will lock itself in order to protect your
passwords.

You can change this behavior by going to Manage->Options->Security and
then toggling the settings that relate to "Lock password database".

Please let me know if this doesn't address your issue.  Thanks.

-- 
GPG: 5CDD 0C9C F446 BC1B 2509  8791 1762 E022 7034 CF84

---

From: Giuseppe Sacco <[email-masked]>
Date: Wed, 31 May 2023 15:34:06 +0200

Hello Bill,
thank you for your quick reply.

> behavior - the program will lock itself in order to protect your
[...]

I am sorry I did not explain it correctly. The database is locked, and this
is the behaviour I want, so I am happy with that. The problem is that when
I get back to pwsafe window while the database is locked, I am not prompted
for the password until I select Unlock from the menu.

Prior to switching gnome from X11 to Wayland, and with the same version on
a different machine, the prompt is automatic: when I put the focus to
pwsafe window while the database is locked, a new window appear asking for
the database password.

Bye,
Giuseppe

---

From: Bill Blough <[email-masked]>
Date: Fri, 2 Jun 2023 09:36:22 -0400

Ah, I see.  Thanks for the clarification.

Yes, that sounds like a bug to me.

I'll test with the upstream version and see if the problem exists there
(I assume it will - I don't think any of our packaging would cause
this), and then forward upstream.

Thanks for your report!