Subject: RFP: scip -- linear and nonlinear mixed integer optimization suite

From: David Bremner <[email-masked]>
Date: Thu, 29 Jun 2023 16:49:57 +0200

Package: wnpp
Severity: wishlist
X-Debbugs-Cc: [email-masked], [email-masked]

* Package name    : scip
  Version         : 8.0.3
  Upstream Contact: [email-masked] (Mailing list)
* URL             : https://www.scipopt.org/
* License         : Apache 2.0
  Programming Lang: C, C++
  Description     : linear and nonlinear mixed integer optimization suite

Upstream writes:

    SCIP is currently one of the fastest non-commercial solvers for mixed
    integer programming (MIP) and mixed integer nonlinear programming
    (MINLP). It is also a framework for constraint integer programming and
    branch-cut-and-price. It allows for total control of the solution
    process and the access of detailed information down to the guts of the
    solver.

SCIP was recently relicensed as free software (Apache 2.0) so it makes sense to include it in Debian.

---

From: David Bremner <[email-masked]>
Date: Sat, 22 Jul 2023 14:48:34 -0300

"Debian Bug Tracking System" <[email-masked]> writes:

> Thank you for filing a new Bug report with Debian.
>
> You can follow progress on this Bug here: 1039923: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1039923.

I started some packages for my own use at

  https://salsa.debian.org/bremner/scipoptsuite

The packaging is currently not suitable for upload (aka RC buggy), but
it does solve a few of the initial technical problems.

---

From: "Torrance, Douglas" <[email-masked]>
Date: Thu, 20 Feb 2025 16:48:11 +0000

Control: retitle -1 ITP: scip -- linear and nonlinear mixed integer optimization suite
Control: owner -1 !

> SCIP was recently relicensed as free software (Apache 2.0) so it makes sense to include it in Debian.

I plan on packaging SCIP for Debian under the auspices of the Debian Math Team.