Subject: GuVCView does record no video

From: Debian <[email-masked]>
Date: Sun, 30 Jul 2023 17:40:44 +0200

Package: guvcview
Version: 2.0.8-2
Severity: normal

In previous releases of Debian GuVCView was always a good tool for easy 
video recording with an webcam.

In Debian 12 everything works except the recording of a video.
The recorded file only contains the sound and no video!
Every option has been tried out and always there is only the sound recorded.

What is going wrong?

-- System Information:
Debian Release: 12.0
  APT prefers stable-security
  APT policy: (500, 'stable-security'), (500, 'proposed-updates'), (500, 
'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 6.1.0-10-amd64 (SMP w/4 CPU threads; PREEMPT)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE 
not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

---

From: Phil Wyett <[email-masked]>
Date: Wed, 25 Sep 2024 17:14:21 +0100

Hi,

Many thanks for reporting your issue. Apologies that nobody to date has taken
the time to triage this bug.

Are you still experiencing the issue?

If you run 'guvcview' from a terminal, what output is being generated?

Regards

Phil

-- 

"I play the game for the game’s own sake"

Arthur Conan Doyle - The Adventure of the Bruce-Partington Plans

--

Buy Me A Coffee: https://buymeacoffee.com/kathenasorg

Internet Relay Chat (IRC): kathenas

Matrix: #kathenas:matrix.org

Website: https://kathenas.org

Instagram: https://instagram.com/kathenasorg/

Threads: https://www.threads.net/@kathenasorg

--

---

From: karsten <[email-masked]>
Date: Wed, 25 Sep 2024 19:17:04 +0200

Sorry for the last HTML-Email - please delete it.

Thanks for the feedback.

> Are you still experiencing the issue?

Tested now and it is possible to record a video.
But it is on Debian 11 with this packages, because Debian 12 is running 
not stable on this PC.

ii  guvcview                                          2.0.6+debian-1+b2 
                          amd64        GTK+ base UVC Viewer
ii  libguvcview-2.0-2:amd64                           2.0.6+debian-1+b2 
                          amd64        GTK+ base UVC Viewer - runtime

> If you run 'guvcview' from a terminal, what output is being generated?

I will try it again and boot Debian 12 now.

Booted now Debian 12 on the same PC and tested again.
There is a small file recorded with only sound and no video.
The console output is attached.

Regards
karsten

---

From: karsten <[email-masked]>
Date: Wed, 25 Sep 2024 19:08:51 +0200

Hi,

thanks for the feedback.

Regards
karsten