Subject: texlive-latex-extra-doc: moderncv.tex fails to build

From: Nick Hastings <[email-masked]>
Date: Tue, 08 Aug 2023 10:14:56 +0900

Package: texlive-latex-extra-doc
Version: 2022.20230122-4
Severity: normal
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

I have been unable to build a document using moderncv.cls. It seems
that either the documentation of the immplementaion of moderncv.cls
has a problem. The /usr/share/doc/texlive-doc/latex/moderncv/README.md
indicates that the example should be compiled with: `latexmk -pdf ./template.tex`
Following this documentation:

mkdir ~/tmp
cd tmp
zcat /usr/share/doc/texlive-doc/latex/moderncv/template.tex.gz > template.tex
cp /usr/share/doc/texlive-doc/latex/moderncv/picture.jpg .
latexmk -pdf template.tex 2>&1 | tee build.log

This results in the build hanging and the error:

.
.
.
*geometry* driver: auto-detecting
*geometry* detected driver: pdftex
(/usr/share/texmf/tex/latex/lm/ot1lmr.fd)
(/usr/share/texlive/texmf-dist/tex/latex/microtype/mt-cmr.cfg)
(/usr/share/texmf/tex/latex/lm/omllmm.fd)
(/usr/share/texmf/tex/latex/lm/omslmsy.fd)
(/usr/share/texmf/tex/latex/lm/omxlmex.fd)
Underfull \hbox (badness 10000) in paragraph at lines 93--93

! Missing number, treated as zero.
<to be read again> 
                   }
l.95 \section{Education}

The build.log and template.log are attached.

Regards,

Nick.

-- System Information:
Debian Release: 12.1
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 6.1.0-10-amd64 (SMP w/16 CPU threads; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), LANGUAGE=en_AU:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages texlive-latex-extra-doc depends on:
ii  tex-common    6.18
ii  texlive-base  2022.20230122-3

texlive-latex-extra-doc recommends no packages.

texlive-latex-extra-doc suggests no packages.

Versions of packages tex-common depends on:
ii  ucf  3.0043+nmu1

Versions of packages tex-common suggests:
ii  debhelper  13.11.4

Versions of packages texlive-latex-extra-doc is related to:
ii  tex-common        6.18
ii  texlive-binaries  2022.20220321.62855-5.1+deb12u1

-- no debconf information

---

From: Nick Hastings <[email-masked]>
Date: Tue, 8 Aug 2023 11:17:11 +0900

Hi,

sorry the bug subject line is wrong/bad. Better would be something
like: "template.tex for moderncv.cls fails to build".

Regards,

Nick.