Subject: libcoin80t64: Freecad still crashes with v4.0.3+ds-2

From: Michele Cane <[email-masked]>
Date: Sun, 09 Mar 2025 19:35:39 +0100

Package: libcoin80t64
Version: 4.0.3+ds-2
Followup-For: Bug #1050302

Dear Maintainer,

stil getting teh same error when opening a file with latest version

freecad: ./src/glue/gl.cpp:2249: const cc_glglue* cc_glglue_instance(int): Assertion `current_ctx && "Must have a current GL context when instantiating cc_glglue!! (Note: if you are using an old Mesa GL version, set the environment variable COIN_GL_NO_CURRENT_CONTEXT_CHECK to get around what may be a Mesa bug.)"' failed.

Cheers

Mike

-- System Information:
Debian Release: trixie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 6.12.17-amd64 (SMP w/8 CPU threads; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libcoin80t64 depends on:
ii  libc6       2.41-3
ii  libexpat1   2.6.4-1
ii  libgcc-s1   14.2.0-17
ii  libglx0     1.7.0-1+b2
ii  libopengl0  1.7.0-1+b2
ii  libstdc++6  14.2.0-17
ii  libx11-6    2:1.8.10-2

libcoin80t64 recommends no packages.

Versions of packages libcoin80t64 suggests:
ii  libbz2-1.0     1.0.8-6
ii  libfreetype6   2.13.3+dfsg-1
pn  libopenal0a    <none>
pn  libsimage-dev  <none>
ii  zlib1g         1:1.3.dfsg+really1.3.1-1+b1

-- no debconf information

---

From: Tobias Frost <[email-masked]>
Date: Sun, 23 Mar 2025 17:55:48 +0100

Control: reopen -1 
Control: found -1 4.0.3+ds-2

Can confirm, freecad is still crashing with: 

freecad: ./src/glue/gl.cpp:2249: const cc_glglue*
cc_glglue_instance(int): Assertion `current_ctx && "Must have a current
GL context when instantiating cc_glglue!! (Note: if you are using an
old Mesa GL version, set the environment variable
COIN_GL_NO_CURRENT_CONTEXT_CHECK to get around what may be a Mesa
bug.)"' failed.
Aborted

--
tobi