Subject: libcoin80c v4.0.0+ds-5 makes Freecad crash

From: mattux <[email-masked]>
Date: Tue, 22 Aug 2023 20:08:37 +0200

Package: libcoin80c
Version: 4.0.0+ds-5
Severity: important

Dear Maintainer,

This is my first bug report and I hope I'm filling it correctly.

I'm a french debian testing user (I sticked to bookworm till last week) and I'm
facing a problem using FreeCAD which seems related to the libcoin80c package.

When opening a file in FreeCAD, the software crashes with an error message :
freecad: ./src/glue/gl.cpp:2354: const cc_glglue* cc_glglue_instance(int):
Assertion `current_ctx && "Must have a current GL context when instantiating
cc_glglue!! (Note: if you are using an old Mesa GL version, set the environment
variable COIN_GL_NO_CURRENT_CONTEXT_CHECK to get around what may be a Mesa
bug.)"' failed.

I used the "COIN_GL_NO_CURRENT_CONTEXT_CHECK=1 freecad" command as advertised,
and the software didn't crash.
I reverted back to v4.0.0+ds-3 from stable and it didn't crash too.
So I'm keeping v4.0.0+ds-3 pinned to have a working software without having to
use the command line.

I'm not very regular in reading my emails but I will try answering to your
questions dilligently.
Thanks.

-- System Information:
Debian Release: trixie/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'testing'), (500, 'stable'), (100, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 6.4.0-2-amd64 (SMP w/8 CPU threads; PREEMPT)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libcoin80c depends on:
ii  libc6       2.37-7
ii  libexpat1   2.5.0-2
ii  libgcc-s1   13.2.0-2
ii  libglx0     1.6.0-1
ii  libopengl0  1.6.0-1
ii  libstdc++6  13.2.0-2

libcoin80c recommends no packages.

Versions of packages libcoin80c suggests:
ii  libbz2-1.0     1.0.8-5+b1
ii  libfreetype6   2.13.0+dfsg-1
pn  libopenal0a    <none>
pn  libsimage-dev  <none>
ii  zlib1g         1:1.2.13.dfsg-1

-- no debconf information

---

From: Tobias Frost <[email-masked]>
Date: Sat, 09 Dec 2023 16:54:21 +0100

Documenting a (works for me(tm)) workaround:

Starting freecad with 

freecad -- -platform xcb

avoids the crash.

(It could be that this is a Wayland-only issue, but I cant test that
right now)