Subject: Add support for timestamps with nanoseconds [patch]

From: markus <[email-masked]>
Date: Thu, 5 Oct 2023 21:51:40 +0200

Package: dump
Version: 0.4b47-4

Hello,

here is a patch to add support for timestamps with nanoseconds for dump and restore.

For this struct dinode in compat/include/bsdcompat.h is extended with nanoseconds timedata.

As a consequence dumpfiles (or -tapes) from previous versions of dump are not compatible with the new version of restore.

In order to prevent a version mismatch it would be desireable to have a version information at the beginning of dumpfiles. I did not manage to find the code locations where dump begins to write resp. where restore begins to read. Maybe someone else copes with this.

Markus

---

From: Alexander Zangerl <[email-masked]>
Date: Fri, 06 Oct 2023 17:28:48 +0200

severity 1053535 wishlist
tags 1053535 + moreinfo
thanks

On Thu, 05 Oct 2023 21:51:40 +0200, markus writes:
>here is a patch to add support for timestamps with nanoseconds for dump
>and restore
...
>As a consequence dumpfiles (or -tapes) from previous versions
>of dump are not compatible with the new version of restore.

i'm not at all convinced that this is a useful change, in particular
in a backup/restore tool.

please provide more information as to what benefits this change is
expected to provide, and how those benefits are supposed to outweight
the massive downside of complete incompatibility with existing backups.

regards
az

-- 
Alexander Zangerl + GPG Key 2FCCF66BB963BD5F + https://snafu.priv.at/
"Mary had a little key,/She kept it in escrow/And everything that Mary
sent/The Feds were sure to know." -- Sam Simpson