Subject: libpam-zfs: fails to unload and unmount homedir on exit from graphical session

From: наб <[email-masked]>
Date: Thu, 11 Jan 2024 21:06:21 +0100

Package: libpam-zfs
Version: 2.2.2-3
Severity: normal

Dear Maintainer,

After logging out (as testuser), /home/testuser was still mounted.
Before logging in, it was unloaded and unmounted.

Journal says
  Jan 11 20:59:41 chrust systemd[1]: Started session-33.scope - Session 33 of User testuser.
  Jan 11 20:59:55 chrust lightdm[13290]: pam_unix(lightdm:session): session closed for user testuser
  Jan 11 20:59:55 chrust lightdm[13290]: pam_zfs_key(lightdm:session): zfs_unmount failed with: -1
  Jan 11 21:00:01 chrust lightdm[13484]: pam_zfs_key(lightdm:auth): pbkdf failed
  Jan 11 21:00:12 chrust (sd-pam)[13299]: pam_unix(systemd-user:session): session closed for user testuser

I'm in as default a configuration as I could be (sans setting homes=chrust-zoot/home),
using lightdm as the greeter and i3 as the WM. None of testuser's processes persisted.

Best,
наб

-- System Information:
Debian Release: trixie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 6.6.9-amd64 (SMP w/2 CPU threads; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libpam-zfs depends on:
ii  libc6            2.37-13
ii  libnvpair3linux  2.2.2-3
ii  libpam-runtime   1.5.2-9.1
ii  libpam0g         1.5.2-9.1+b1
ii  libssl3          3.1.4-2
ii  libzfs4linux     2.2.2-3

libpam-zfs recommends no packages.

libpam-zfs suggests no packages.

-- no debconf information

---

From: 陈 晟祺 <[email-masked]>
Date: Fri, 12 Jan 2024 02:50:06 +0000

Hi,

Thanks for reporting.

> 2024年1月12日 04:06，наб <[email-masked]> 写道：
> 
> Package: libpam-zfs
> Version: 2.2.2-3
> Severity: normal
> 
> Dear Maintainer,
> 

-1 is EPERM. So I suspect this is the same problem as #1028613.
Maybe you can check that out and, if indeed, merge the two bugs?

Thanks,
Shengqi Chen

---

From: наб <[email-masked]>
Date: Fri, 12 Jan 2024 18:23:52 +0100

forcemerge 1028613 1060461
thanks

yes that's it, didn't come up in reportbug search for me