Subject: Bug#1062029: broker: NMU diff for 64-bit time_t transition

From: Steve Langasek <[email-masked]>
Date: Wed, 31 Jan 2024 03:06:40 +0000

Source: broker
Version: 1.4.0+ds1-1
Severity: serious
Tags: patch pending
Justification: library ABI skew on upgrade
User: [email-masked]
Usertags: time-t

Dear maintainer,

As part of the 64-bit time_t transition required to support 32-bit
architectures in 2038 and beyond
(https://wiki.debian.org/ReleaseGoals/64bit-time), we have identified
broker as a source package shipping runtime libraries whose ABI
either is affected by the change in size of time_t, or could not be
analyzed via abi-compliance-checker (and therefore to be on the safe
side we assume is affected).

To ensure that inconsistent combinations of libraries with their
reverse-dependencies are never installed together, it is necessary to
have a library transition, which is most easily done by renaming the
runtime library package.

Since turning on 64-bit time_t is being handled centrally through a change
to the default dpkg-buildflags (https://bugs.debian.org/1037136), it is
important that libraries affected by this ABI change all be uploaded close
together in time.  Therefore I have prepared a 0-day NMU for broker
which will initially be uploaded to experimental if possible, then to
unstable after packages have cleared binary NEW.

Please find the patch for this NMU attached.

If you have any concerns about this patch, please reach out ASAP.  Although
this package will be uploaded to experimental immediately, there will be a
period of several days before we begin uploads to unstable; so if information
becomes available that your package should not be included in the transition,
there is time for us to amend the planned uploads.

-- System Information:
Debian Release: trixie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 6.5.0-14-generic (SMP w/12 CPU threads; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
diff -Nru broker-1.4.0+ds1/debian/changelog broker-1.4.0+ds1/debian/changelog
--- broker-1.4.0+ds1/debian/changelog	2020-12-25 22:16:06.000000000 +0000
+++ broker-1.4.0+ds1/debian/changelog	2024-01-31 02:33:22.000000000 +0000
@@ -1,3 +1,10 @@
+broker (1.4.0+ds1-1.1) experimental; urgency=medium
+
+  * Non-maintainer upload.
+  * Rename libraries for 64-bit time_t transition.
+
+ -- Steve Langasek <[email-masked]>  Wed, 31 Jan 2024 02:33:22 +0000
+
 broker (1.4.0+ds1-1) unstable; urgency=medium
 
   * New upstream version 1.4.0+ds1
diff -Nru broker-1.4.0+ds1/debian/control broker-1.4.0+ds1/debian/control
--- broker-1.4.0+ds1/debian/control	2020-12-25 22:13:12.000000000 +0000
+++ broker-1.4.0+ds1/debian/control	2024-01-31 02:33:22.000000000 +0000
@@ -21,7 +21,7 @@
 Section: libdevel
 Architecture: any
 Multi-Arch: same
-Depends: libbroker2 (= ${binary:Version}), ${misc:Depends}
+Depends: libbroker2t64 (= ${binary:Version}), ${misc:Depends}
 Description: Bro's messaging library - development files
  The Broker library implements Bro's high-level communication
  patterns:
@@ -32,7 +32,10 @@
  .
  This package contains header files.
 
-Package: libbroker2
+Package: libbroker2t64
+Provides: ${t64:Provides}
+Replaces: libbroker2
+Breaks: libbroker2 (<< ${source:Version})
 Architecture: any
 Multi-Arch: same
 Depends: ${shlibs:Depends}, ${misc:Depends}
diff -Nru broker-1.4.0+ds1/debian/libbroker2.install broker-1.4.0+ds1/debian/libbroker2.install
--- broker-1.4.0+ds1/debian/libbroker2.install	2020-12-25 22:13:12.000000000 +0000
+++ broker-1.4.0+ds1/debian/libbroker2.install	1970-01-01 00:00:00.000000000 +0000
@@ -1 +0,0 @@
-usr/lib/*-*/lib*.so.*
diff -Nru broker-1.4.0+ds1/debian/libbroker2t64.install broker-1.4.0+ds1/debian/libbroker2t64.install
--- broker-1.4.0+ds1/debian/libbroker2t64.install	1970-01-01 00:00:00.000000000 +0000
+++ broker-1.4.0+ds1/debian/libbroker2t64.install	2020-12-25 22:13:12.000000000 +0000
@@ -0,0 +1 @@
+usr/lib/*-*/lib*.so.*
diff -Nru broker-1.4.0+ds1/debian/libbroker2t64.lintian-overrides broker-1.4.0+ds1/debian/libbroker2t64.lintian-overrides
--- broker-1.4.0+ds1/debian/libbroker2t64.lintian-overrides	1970-01-01 00:00:00.000000000 +0000
+++ broker-1.4.0+ds1/debian/libbroker2t64.lintian-overrides	2024-01-31 02:33:22.000000000 +0000
@@ -0,0 +1 @@
+libbroker2t64: package-name-doesnt-match-sonames libbroker2

---

From: Steve Langasek <[email-masked]>
Date: Tue, 30 Jan 2024 19:18:10 -0800

Of course, broker also FTBFS due to bug #1037597 (which I knew before this
bug was filed, but, well, the scripts for this mass bug filing aren't that
flexible at the moment), so nothing is actually being uploaded.

If and when someone fixes broker, this patch should also be included -
presuming that dpkg is uploaded with the 64-bit time_t change beforehand,
which seems likely.

-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                   https://www.debian.org/
[email-masked]                                     [email-masked]