Subject: simple-cdd: Linux Kernel of generated ISO (.udeb) and Kernel to be installed (.deb) don't match

From: Marcel Bosling <[email-masked]>
Date: Wed, 31 Jan 2024 17:02:50 +0100

Package: simple-cdd
Version: 0.6.9
Severity: important
X-Debbugs-Cc: [email-masked]

When building on/for Debian 12, the kernel to start d-i is kernel-image-6.1.0-16-amd64-di_6.1.67-1_amd64.udeb
but linux-image-6.1.0-17-amd64_6.1.69-1_amd64.deb (from security) is the installation candidate resulting in d-i not being able
to find a proper kernel during installation.

Funnily kernel-image-6.1.0-17-amd64-di_6.1.69-1_amd64.udeb exists in

http://security.debian.org/debian-security/pool/updates/main/l/linux-signed-amd64/kernel-image-6.1.0-17-amd64-di_6.1.69-1_amd64.udeb

but is not considered while creating the image.

-- System Information:
Debian Release: 12.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 6.1.0-17-amd64 (SMP w/4 CPU threads; PREEMPT)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages simple-cdd depends on:
ii  dctrl-tools         2.24-3+b1
ii  debian-cd           3.2.1
ii  lsb-release         12.0-1
ii  python3             3.11.2-1+b1
ii  python3-simple-cdd  0.6.9
ii  reprepro            5.3.1-1+deb12u1
ii  rsync               3.2.7-1
ii  wget                1.21.3-1+b2

Versions of packages simple-cdd recommends:
ii  dose-distcheck  7.0.0-1+b2

Versions of packages simple-cdd suggests:
pn  qemu-system | qemu-kvm  <none>

-- no debconf information

---

From: Anselm Lingnau <[email-masked]>
Date: Mon, 20 Jan 2025 16:50:15 +0100

I'm seeing the same issue as Sietze, except that now the kernel version in 
`install.amd/vmlinuz` is 6.1.0-29-amd64 and the one in the package pool on the 
ISO is 6.1.0-30-amd64.

It is worth noting that the `install.amd/vmlinuz` file comes from `dists/
bookworm/main/installer-amd64/current/images/cdrom`, not any `.udeb` file. 
This suggests to me that the FTP archive is out of date with respect to 
simple-cdd, debian-cd, and/or the Debian installer, but I'm unsure where to 
report this.

I don't find the workaround of hard-coding a specific set of kernel module 
packages in `NAME.downloads` or the `kernel_packages` variable acceptable 
because it isn't future-proof.

Anselm
-- 
Anselm Lingnau, Mainz, Germany ............................ [email-masked]
A consultant is someone who takes your watch away to tell you what time it is.
                                                             -- Ed Finkelstein

---

From: xiao sheng wen(肖盛文) <[email-masked]>
Date: Tue, 21 Jan 2025 11:29:22 +0800

Hi,

> `install.amd/vmlinuz` is 6.1.0-29-amd64 and the one in the package pool on the 
In Debian 12.9.0 point release, the kernel version is 6.1.0-29-amd64,
the d-i kernel version also is the same 6.1.0-29-amd64.

But just after 12.9.0 release, there is a SUA[1] for kernel package,
the Version is 6.1.124-1 linux-image-6.1.0-30. This new kernel also
has d-i .udeb packages together.

The SUA kernel is location in bookworm-updates.

The simple-cdd default use bookworm-updates, but `install.amd/vmlinuz` is
not update to new kernel version, so it's mismatch.

> because it isn't future-proof.
I find a way:

Let simply-cdd not use bookworm-updates(stable-updates) when build, just set:

updates_mirror=""

variable in build.conf.

Regard,

[1] https://lists.debian.org/debian-stable-announce/2025/01/msg00001.html

-- 
肖盛文 xiao sheng wen -- Debian Developer(atzlinux)
Debian QA page: https://qa.debian.org/developer.php?login=atzlinux%40debian.org
Debian salsa: https://salsa.debian.org/atzlinux-guest
GnuPG Public Key: 0x00186602339240CB