Subject: Bug#1063645: markdown: missing required debian/rules targets build-arch and/or build-indep

From: Guillem Jover <[email-masked]>
Date: Sat, 10 Feb 2024 13:20:51 +0100

Source: markdown
Version: 1.0.1-12
Severity: serious
Justification: Debian Policy section 4.9
Tags: sid trixie
User: [email-masked]
Usertags: missing-build-arch-indep

Dear maintainer,

Your package does not include build-arch and/or build-indep targets in
debian/rules. This is required by Debian Policy section 4.9, since 2012.
https://www.debian.org/doc/debian-policy/ch-source.html#main-building-script-debian-rules

Please note that this is also a sign that the packaging of this software
could benefit from a refresh. For example, packages using 'dh' cannot be
affected by this issue.

This mass bug filing was discussed on debian-devel@ in
<https://lists.debian.org/debian-devel/2021/11/msg00052.html>.
(The severity of this bug at the time of the mass bug filing was set to
'important', and bumped to 'serious' after a month, but given that quite
some time has passed, I'm just setting it directly to 'serious' now, as
I'm planning to remove the fallback workaround for these targets in the
next dpkg upload.)

Thanks,
Guillem

---

From: Bastian Germann <[email-masked]>
Date: Sat, 8 Jun 2024 19:10:28 +0200

If you think about fixing this to keep a reverse dependency in Debian:
Please consider porting the reverse dep to some other markdown implementation that is still maintained.

---

From: Johannes Schauer Marin Rodrigues <[email-masked]>
Date: Mon, 10 Jun 2024 06:59:03 +0200

> If you think about fixing this to keep a reverse dependency in Debian:

That's me.

> that is still maintained.

Do you have recommendations? I just need a drop-in replacement for markdown
into stdin, html on stdout. Nothing fancy.

---

From: Bastian Germann <[email-masked]>
Date: Mon, 10 Jun 2024 09:30:20 +0200

> into stdin, html on stdout. Nothing fancy.

I would suggest discount or python3-markdown.

---

From: Johannes Schauer Marin Rodrigues <[email-masked]>
Date: Mon, 10 Jun 2024 13:04:03 +0200

Quoting Bastian Germann (2024-06-10 09:30:20)
> I would suggest discount or python3-markdown.

Brilliant! That tip was gold! All I did was this to fix the issue in my
package:

--- a/debian/control
+++ b/debian/control
@@ -37,7 +37,7 @@ Build-Depends-Arch:
  graphviz                        <!nocheck>,
  black                           <!nocheck>,
 Build-Depends-Indep:
- markdown <!nodoc>,
+ discount <!nodoc>,
  graphviz <!nodoc>,
 Vcs-Browser: https://salsa.debian.org/debian/botch
 Vcs-Git: https://salsa.debian.org/debian/botch.git

Much easier than fixing d/rules of src:markdown. ;)

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 17 Jun 2024 11:51:05 +0000

This is an automatic notification regarding your Bug report
which was filed against the src:markdown package:

#1063645: markdown: missing required debian/rules targets build-arch and/or build-indep

It has been closed by Victor Seva <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Victor Seva <[email-masked]> by
replying to this email.

-- 
1063645: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1063645
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: (No Subject)
From: Victor Seva <[email-masked]>
To: [email-masked]
Date: Mon, 17 Jun 2024 11:50:04 +0000

fixed 1063645 11.5.1.25-1

Format: 1.8
Date: Thu, 13 Jun 2024 14:52:33 +0200
Source: rtpengine
Architecture: source
Version: 11.5.1.25-1
Distribution: unstable
Urgency: medium
Maintainer: Debian VoIP Team <[email-masked]>
Changed-By: Victor Seva <[email-masked]>
Closes: 1073102
Changes:
  rtpengine (11.5.1.25-1) unstable; urgency=medium
  .
    * New upstream version 11.5.1.25
    * switch from markdown to discount (Closes: #1073102)
Checksums-Sha1:
  b5552d6dbee2eabff5328525ce9d4efbca073d1d 3028 rtpengine_11.5.1.25-1.dsc
  89ea2a17b1a8dd369c288d7794270602d355d021 6491224 
rtpengine_11.5.1.25.orig.tar.gz
  dc927227958c50146803be64adff80f6e50c13c7 9500 
rtpengine_11.5.1.25-1.debian.tar.xz
  6c28be746d54d717a773766eaccdf02b2a8ff451 18071 
rtpengine_11.5.1.25-1_amd64.buildinfo
Checksums-Sha256:
  e1aac581f447ed0f5ef792859f96198357fd417298c4c2bc95c2efbbc9de0b2a 3028 
rtpengine_11.5.1.25-1.dsc
  2cb61769a3e18904f657b9778b8ac3e6fe799dee452eced842cbec1b866c4820 
6491224 rtpengine_11.5.1.25.orig.tar.gz
  cfb5204f890e0ff1d913b5e971f7d024a31a19af26903b609e7e2d851cd5c062 9500 
rtpengine_11.5.1.25-1.debian.tar.xz
  8ebc2759551961d7233cd672565f5b70b60c365c924032834d74695b31decfff 18071 
rtpengine_11.5.1.25-1_amd64.buildinfo
Files:
  daae0a6924c5d04ebd578506790b562e 3028 net optional 
rtpengine_11.5.1.25-1.dsc
  986b20636c9c38ec5730b030ef5afff6 6491224 net optional 
rtpengine_11.5.1.25.orig.tar.gz
  c5021325e477864cd01e408328941dd8 9500 net optional 
rtpengine_11.5.1.25-1.debian.tar.xz
  f009bdab95a256d674957700e44c15f5 18071 net optional 
rtpengine_11.5.1.25-1_amd64.buildinfo

-- 
-----------------------------------------------------------------
|   ,''`.                                             Victor Seva |
|  : :' :                      [email-masked] |
|  `. `'  PGP: 8F19 CADC D42A 42D4 5563  730C 51A0 9B18 CF5A 5068 |
|    `-                                          Debian Developer |
  -----------------------------------------------------------------

Subject: markdown: missing required debian/rules targets build-arch and/or build-indep
From: Guillem Jover <[email-masked]>
To: [email-masked]
Date: Sat, 10 Feb 2024 13:20:51 +0100

Source: markdown
Version: 1.0.1-12
Severity: serious

Dear maintainer,

Thanks,
Guillem

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Tue, 13 Aug 2024 21:54:03 +0000

It has been closed by Debian FTP Masters <[email-masked]> (reply to Andrea Pappacoda <[email-masked]>).

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> (reply to Andrea Pappacoda <[email-masked]>) by
replying to this email.

Subject: Bug#1063645: fixed in markdown 1.0.1-13
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Tue, 13 Aug 2024 21:52:11 +0000

Source: markdown
Source-Version: 1.0.1-13
Done: Andrea Pappacoda <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
markdown, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Andrea Pappacoda <[email-masked]> (supplier of updated markdown package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Tue, 13 Aug 2024 22:54:35 +0200
Source: markdown
Architecture: source
Version: 1.0.1-13
Distribution: unstable
Urgency: medium
Maintainer: Andrea Pappacoda <[email-masked]>
Changed-By: Andrea Pappacoda <[email-masked]>
Closes: 466330 1063645 1072958
Changes:
 markdown (1.0.1-13) unstable; urgency=medium
 .
   * d/control: adopt package (Closes: #466330, #1072958)
   * d/control: add Vcs fields
   * d: convert packaging to debhelper (Closes: #1063645)
   * d/copyright: convert to DEP-5 format
   * d/patches: split debian.patch in several patches.
     Also document their history with DEP-3 tags.
   * d/u/metadata: add upstream metadata
   * d/watch: add basic watch file
Checksums-Sha1:
 c76c3a98de54def713582776bb3116156f05b31a 1866 markdown_1.0.1-13.dsc
 87b3631cb8a22abad82777de59e14e28d3945b0e 5236 markdown_1.0.1-13.debian.tar.xz
 8337e1050f7b314ad35f5bcf103229a486919975 6034 markdown_1.0.1-13_amd64.buildinfo
Checksums-Sha256:
 48c88471132cbb01d4cc500d212427ba3f0e306039bad08cbd28f168d952b0f9 1866 markdown_1.0.1-13.dsc
 60e2a5e1e5e2c1b67c58b5b1c5e8d75809c48625408dd08ee306c32f8031c9d5 5236 markdown_1.0.1-13.debian.tar.xz
 761c59df876fd35875f61ea974b09a8368958056b3318e0b83494faf19c8aff8 6034 markdown_1.0.1-13_amd64.buildinfo
Files:
 a557332acca02737070ce3abc46ee80a 1866 web optional markdown_1.0.1-13.dsc
 0bb39293a21ab71c4fbf8a273ccabec2 5236 web optional markdown_1.0.1-13.debian.tar.xz
 aa7b1af5aa2f6fdd1d05754553beada7 6034 web optional markdown_1.0.1-13_amd64.buildinfo

Source: markdown
Version: 1.0.1-12
Severity: serious

Dear maintainer,

Thanks,
Guillem