Subject: vim: Annoying visual bell in insert mode when pageing after upgrade to trixie

From: Helge Kreutzmann <[email-masked]>
Date: Sun, 23 Jun 2024 08:37:59 +0000

Package: vim
Version: 2:9.1.0496-1
Severity: minor

Up until bookworm no visual bell was shown in vim on the console
with my configuration. Now in insert mode (only), when paging an annoying visual
bell is shown.

This is *not* occuring with --clean but from the Debian changes I
could not derive which settings fault it is. 

(And I have no idea how to search in the docs for it).

As this is a (minor) regression, I'm reporting this. And if you have
any suggestion how to find out which setting this causes (except for
bisecting) I would be happy :-))

-- Package-specific info:

--- real paths of main Vim binaries ---
/usr/bin/vi is /usr/bin/vim.gtk3
/usr/bin/vim is /usr/bin/vim.gtk3
/usr/bin/gvim is /usr/bin/vim.gtk3

-- System Information:
Debian Release: trixie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 6.9.2 (SMP w/12 CPU threads; PREEMPT)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to de_DE.UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages vim depends on:
ii  libacl1      2.3.2-2
ii  libc6        2.38-13
ii  libgpm2      1.20.7-11
ii  libselinux1  3.5-2+b2
ii  libsodium23  1.0.18-1+b1
ii  libtinfo6    6.5-2
ii  vim-common   2:9.1.0496-1
ii  vim-runtime  2:9.1.0496-1

vim recommends no packages.

Versions of packages vim suggests:
pn  ctags        <none>
ii  vim-doc      2:9.1.0496-1
ii  vim-scripts  20210124.2

-- no debconf information

-- 
      Dr. Helge Kreutzmann                     [email-masked]
           Dipl.-Phys.                   http://www.helgefjell.de/debian.php
        64bit GNU powered                     gpg signed mail preferred
           Help keep free software "libre": http://www.ffii.de/

---

From: James McCoy <[email-masked]>
Date: Sun, 23 Jun 2024 11:19:33 -0400

> could not derive which settings fault it is. 

I would suggest first comparing the output of ":set" with "vim --clean"
and "vim". That should help narrow down which options differ from the
defaults and may affect this behavior.

> bisecting) I would be happy :-))

You could bisect your config by placing the "finish" command in your
vimrc at various points to see what introduces the behavior.

Cheers,
-- 
James
GPG Key: 4096R/91BF BF4D 6956 BD5D F7B7  2D23 DFE6 91AE 331B A3DB

---

From: Helge Kreutzmann <[email-masked]>
Date: Sat, 3 Aug 2024 14:36:16 +0000

> defaults and may affect this behavior.

Thanks.

vim --clean
  background=dark     helplang=de         incsearch         nolangremap           mouse=nvi           ruler               scrolloff=5         ttimeout            viminfofile=NONE
  display=truncate    history=200         langnoremap       noloadplugins         nrformats=bin,hex   scroll=37           showcmd             ttimeoutlen=100     wildmenu
  backspace=indent,eol,start
  fileencodings=ucs-bom,utf-8,default,latin1

vim:
  autoindent          backspace=indent    helplang=de         incsearch           ruler               shiftround          shortmess=nxtToOS   smartcase           smarttab            visualbell          wildmenu
  background=dark   nofoldenable          ignorecase          laststatus=2        scroll=36           shiftwidth=4        showmatch           smartindent         softtabstop=4       wildignore=*.swp
  cinoptions=t0,(0,u0
  cpoptions=aABceFsJ
  fileencodings=ucs-bom,utf-8,default,latin1
  formatoptions=tcq2l
  formatprg=fmt -cu -w70
  listchars=eol:$,tab:>-,trail:_
  printoptions=paper:a4
  statusline=%<%f%y%m%r%=%l,%c%V %P
  suffixes=.bak,~,.swp,.o,.info,.aux,.log,.dvi,.bbl,.blg,.brf,.cb,.ind,.idx,.ilg,.inx,.out,.toc
  viminfo='1000,f1,"500,:50,@10,/100

> vimrc at various points to see what introduces the behavior.

Thanks, this made it easy.

It is the option "visualbell" which causes this behaviour. Until 
bookworm paging worked in in insert mode with this option but without
visual bell, now it does.

Is this a delibarate feature change?

Greetings

           Helge