Subject: Bug#1074924: dump1090-mutability: ftbfs with GCC-14

From: Matthias Klose <[email-masked]>
Date: Wed, 03 Jul 2024 12:25:33 +0000

Package: src:dump1090-mutability
Version: 1.15~20180310.4a16df3+dfsg-8.1
Severity: important
Tags: sid trixie
User: [email-masked]
Usertags: ftbfs-gcc-14

[This bug is targeted to the upcoming trixie release]

Please keep this issue open in the bug tracker for the package it
was filed for.  If a fix in another package is required, please
file a bug for the other package (or clone), and add a block in this
package. Please keep the issue open until the package can be built in
a follow-up test rebuild.

The package fails to build in a test rebuild on at least amd64 with
gcc-14/g++-14, but succeeds to build with gcc-13/g++-13. The
severity of this report will be raised before the trixie release.

The full build log can be found at:
http://qa-logs.debian.net/2024/07/01/dump1090-mutability_1.15~20180310.4a16df3+dfsg-8.1_unstable_gccexp.log
The last lines of the build log are at the end of this report.

To build with GCC 14, either set CC=gcc-14 CXX=g++-14 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t=experimental install g++ 

Common build failures are new warnings resulting in build failures with
-Werror turned on, or new/dropped symbols in Debian symbols files.
For other C/C++ related build failures see the porting guide at
http://gcc.gnu.org/gcc-14/porting_to.html

[...]
dpkg-buildpackage
-----------------

Command: dpkg-buildpackage --sanitize-env -us -uc -b -rfakeroot
dpkg-buildpackage: info: source package dump1090-mutability
dpkg-buildpackage: info: source version 1.15~20180310.4a16df3+dfsg-8.1
dpkg-buildpackage: info: source distribution unstable
dpkg-buildpackage: info: source changed by Bastian Germann <[email-masked]>
 dpkg-source --before-build .
dpkg-buildpackage: info: host architecture amd64
 debian/rules clean
dh clean --with apache2
   dh_auto_clean
	make -j8 clean
make[1]: Entering directory '/<<PKGBUILDDIR>>'
rm -f *.o compat/clock_gettime/*.o compat/clock_nanosleep/*.o dump1090 view1090 faup1090 cprtests crctests
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
   dh_clean
	rm -f debian/debhelper-build-stamp
	rm -rf debian/.debhelper/
	rm -f -- debian/dump1090-mutability.substvars debian/files
	rm -fr -- debian/dump1090-mutability/ debian/tmp/
	find .  \( \( \
		\( -path .\*/.git -o -path .\*/.svn -o -path .\*/.bzr -o -path .\*/.hg -o -path .\*/CVS -o -path .\*/.pc -o -path .\*/_darcs \) -prune -o -type f -a \
	        \( -name '#*#' -o -name '.*~' -o -name '*~' -o -name DEADJOE \
		 -o -name '*.orig' -o -name '*.rej' -o -name '*.bak' \
		 -o -name '.*.orig' -o -name .*.rej -o -name '.SUMS' \
		 -o -name TAGS -o \( -path '*/.deps/*' -a -name '*.P' \) \
		\) -exec rm -f {} + \) -o \
		\( -type d -a \( -name autom4te.cache -o -name __pycache__ \) -prune -exec rm -rf {} + \) \)
 debian/rules binary
dh binary --with apache2
   dh_update_autotools_config
   dh_autoreconf
   dh_auto_configure
   debian/rules override_dh_auto_build
make[1]: Entering directory '/<<PKGBUILDDIR>>'
dh_auto_build -- 'EXTRACFLAGS=-DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\"'
	make -j8 "INSTALL=install --strip-program=true" "EXTRACFLAGS=-DHTMLPATH=\\\"/usr/share/dump1090-mutability/html\\\" -DMODES_DUMP1090_VARIANT=\\\"EB_SOURCE\\\""
make[2]: Entering directory '/<<PKGBUILDDIR>>'
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE `pkg-config --cflags libusb-1.0 librtlsdr` -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c dump1090.c -o dump1090.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c anet.c -o anet.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c interactive.c -o interactive.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c mode_ac.c -o mode_ac.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c mode_s.c -o mode_s.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c net_io.c -o net_io.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c crc.c -o crc.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c demod_2400.c -o demod_2400.o
net_io.c: In function ‘serviceInit’:
net_io.c:94:34: error: ‘calloc’ sizes specified with ‘sizeof’ in the earlier argument and not in the later argument [-Werror=calloc-transposed-args]
   94 |     if (!(service = calloc(sizeof(*service), 1))) {
      |                                  ^
net_io.c:94:34: note: earlier argument should specify number of elements, later size of each element
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c stats.c -o stats.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c cpr.c -o cpr.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c icao_filter.c -o icao_filter.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c track.c -o track.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c util.c -o util.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c convert.c -o convert.o
gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"EB_VERSION\" -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -O2 -g -Wall -Werror -W -Wno-unknown-warning-option -Wno-format-truncation -std=c11 -D_DEFAULT_SOURCE -DHTMLPATH=\"/usr/share/dump1090-mutability/html\" -DMODES_DUMP1090_VARIANT=\"EB_SOURCE\" -c view1090.c -o view1090.o
At top level:
cc1: note: unrecognized command-line option ‘-Wno-unknown-warning-option’ may have been intended to silence earlier diagnostics
cc1: all warnings being treated as errors
make[2]: *** [Makefile:50: net_io.o] Error 1
make[2]: Leaving directory '/<<PKGBUILDDIR>>'
dh_auto_build: error: make -j8 "INSTALL=install --strip-program=true" "EXTRACFLAGS=-DHTMLPATH=\\\"/usr/share/dump1090-mutability/html\\\" -DMODES_DUMP1090_VARIANT=\\\"EB_SOURCE\\\"" returned exit code 2
make[1]: *** [debian/rules:18: override_dh_auto_build] Error 25
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
make: *** [debian/rules:15: binary] Error 2
dpkg-buildpackage: error: debian/rules binary subprocess returned exit status 2

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 03 Jul 2024 12:29:11 +0000

Thank you for filing a new Bug report with Debian.

You can follow progress on this Bug here: 1074924: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1074924.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 Debian Hamradio Maintainers <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1074924: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1074924
Debian Bug Tracking System
Contact [email-masked] with problems