Subject: Bug#1075651: xbattbar: ftbfs with GCC-14

From: Matthias Klose <[email-masked]>
Date: Wed, 03 Jul 2024 12:48:27 +0000

Package: src:xbattbar
Version: 1.4.9-2
Severity: important
Tags: sid trixie
User: [email-masked]
Usertags: ftbfs-gcc-14

[This bug is targeted to the upcoming trixie release]

Please keep this issue open in the bug tracker for the package it
was filed for.  If a fix in another package is required, please
file a bug for the other package (or clone), and add a block in this
package. Please keep the issue open until the package can be built in
a follow-up test rebuild.

The package fails to build in a test rebuild on at least amd64 with
gcc-14/g++-14, but succeeds to build with gcc-13/g++-13. The
severity of this report will be raised before the trixie release.

The full build log can be found at:
http://qa-logs.debian.net/2024/07/01/xbattbar_1.4.9-2_unstable_gccexp.log
The last lines of the build log are at the end of this report.

To build with GCC 14, either set CC=gcc-14 CXX=g++-14 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t=experimental install g++ 

Common build failures are new warnings resulting in build failures with
-Werror turned on, or new/dropped symbols in Debian symbols files.
For other C/C++ related build failures see the porting guide at
http://gcc.gnu.org/gcc-14/porting_to.html

[...]
=eDCs
-----END PGP SIGNATURE-----

gpgv: Signature made Wed Jan  1 07:53:12 2020 UTC
gpgv:                using RSA key 71EDACFC68010DD91AD19B868D1F969A08EEA756
gpgv: Can't check signature: No public key
dpkg-source: warning: cannot verify inline signature for ./xbattbar_1.4.9-2.dsc: no acceptable signature found
dpkg-source: info: extracting xbattbar in /<<PKGBUILDDIR>>
dpkg-source: info: unpacking xbattbar_1.4.9.orig.tar.gz
dpkg-source: info: unpacking xbattbar_1.4.9-2.debian.tar.xz

Check disk space
----------------

Sufficient free space for build

User Environment
----------------

APT_CONFIG=/var/lib/sbuild/apt.conf
HOME=/sbuild-nonexistent
LANG=C.UTF-8
LC_ALL=C.UTF-8
LOGNAME=user42
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
SCHROOT_ALIAS_NAME=unstable
SCHROOT_CHROOT_NAME=sid-amd64-sbuild
SCHROOT_COMMAND=env
SCHROOT_GID=1001
SCHROOT_GROUP=user42
SCHROOT_SESSION_ID=sid-amd64-sbuild-dd4ccb51-8ddf-43ab-b672-ebc99e4aeb0d
SCHROOT_UID=1001
SCHROOT_USER=user42
SHELL=/bin/sh
USER=user42

dpkg-buildpackage
-----------------

Command: dpkg-buildpackage --sanitize-env -us -uc -b -rfakeroot
dpkg-buildpackage: info: source package xbattbar
dpkg-buildpackage: info: source version 1.4.9-2
dpkg-buildpackage: info: source distribution unstable
dpkg-buildpackage: info: source changed by Dmitry E. Oboukhov <[email-masked]>
 dpkg-source --before-build .
dpkg-buildpackage: info: host architecture amd64
 fakeroot debian/rules clean
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
/usr/bin/make clean
make[1]: Entering directory '/<<PKGBUILDDIR>>'
rm -fr obj
rm -f xbattbar xbattbar-check-apm
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
dh_clean
 debian/rules build
dh_testdir
/usr/bin/make
make[1]: Entering directory '/<<PKGBUILDDIR>>'
mkdir obj
touch obj/stamp
gcc -MMD -o obj/xbattbar.o -c xbattbar.c -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2
xbattbar.c:235:1: error: return type defaults to ‘int’ [-Wimplicit-int]
  235 | main(int argc, char **argv)
      | ^~~~
make[1]: *** [Makefile:17: obj/xbattbar.o] Error 1
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
make: *** [debian/rules:8: build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 03 Jul 2024 12:58:25 +0000

Thank you for filing a new Bug report with Debian.

You can follow progress on this Bug here: 1075651: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1075651.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 Dmitry E. Oboukhov <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1075651: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1075651
Debian Bug Tracking System
Contact [email-masked] with problems