Subject: Bug#1083584: pyspread: (build-)depends on deprecated module python3-pkg-resources

From: Matthias Klose <[email-masked]>
Date: Fri, 04 Oct 2024 09:45:32 +0000

Package: src:pyspread
Version: 2.2.3-1
Severity: normal
Tags: sid trixie
User: [email-masked]
Usertags: pkg-resources-deprecation

[This bug is targeted to the upcoming trixie release]

The package build-depends or depends on python3-pkg-resources, which is
deprecated upstream. Details can be found at

    https://setuptools.pypa.io/en/latest/pkg_resources.html

Use of pkg_resources is deprecated in favor of importlib.resources,
importlib.metadata and their backports (importlib_resources, importlib_metadata).
Some useful APIs are also provided by packaging (e.g. requirements and version
parsing). Users should refrain from new usage of pkg_resources and should work
to port to importlib-based solutions.

Python 3.12 in unstable provides both importlib_resources and
importlib_metadata, so no additional dependencies on those packages are needed.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Fri, 04 Oct 2024 09:48:35 +0000

Thank you for filing a new Bug report with Debian.

You can follow progress on this Bug here: 1083584: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1083584.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 Andreas Noteng <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1083584: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1083584
Debian Bug Tracking System
Contact [email-masked] with problems