Subject: Bug#1083911: tryton-modules-purchase-requisition: (build-)depends on deprecated module python3-pkg-resources

From: Matthias Klose <[email-masked]>
Date: Fri, 04 Oct 2024 09:51:11 +0000

Package: src:tryton-modules-purchase-requisition
Version: 6.0.2-1
Severity: normal
Tags: sid trixie
User: [email-masked]
Usertags: pkg-resources-deprecation

[This bug is targeted to the upcoming trixie release]

The package build-depends or depends on python3-pkg-resources, which is
deprecated upstream. Details can be found at

    https://setuptools.pypa.io/en/latest/pkg_resources.html

Use of pkg_resources is deprecated in favor of importlib.resources,
importlib.metadata and their backports (importlib_resources, importlib_metadata).
Some useful APIs are also provided by packaging (e.g. requirements and version
parsing). Users should refrain from new usage of pkg_resources and should work
to port to importlib-based solutions.

Python 3.12 in unstable provides both importlib_resources and
importlib_metadata, so no additional dependencies on those packages are needed.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Fri, 04 Oct 2024 09:52:37 +0000

Thank you for filing a new Bug report with Debian.

You can follow progress on this Bug here: 1083911: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1083911.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 Debian Tryton Maintainers <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1083911: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1083911
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Mathias Behrle <[email-masked]>
Date: Fri, 11 Oct 2024 05:17:03 +0000

Control: tag -1 pending

Hello,

Bug #1083911 in tryton-modules-purchase-requisition reported by you has been fixed in the
Git repository and is awaiting an upload. You can see the commit
message below and you can check the diff of the fix at:

https://salsa.debian.org/tryton-team/tryton-modules-purchase-requisition/-/commit/99cbd91ed2fc05f3a5e188fabbf12aabf1a06753

------------------------------------------------------------------------
Remove deprecated python3-pkg-resources from (Build)Depends (and wrap-and-sort -a) (Closes: #1083911).
------------------------------------------------------------------------

(this message was generated automatically)
-- 
Greetings

https://bugs.debian.org/1083911

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Fri, 18 Oct 2024 15:39:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the src:tryton-modules-purchase-requisition package:

#1083911: tryton-modules-purchase-requisition: (build-)depends on deprecated module python3-pkg-resources

It has been closed by Debian FTP Masters <[email-masked]> (reply to Mathias Behrle <[email-masked]>).

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> (reply to Mathias Behrle <[email-masked]>) by
replying to this email.

Subject: Bug#1083911: fixed in tryton-modules-purchase-requisition 6.0.3-1
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Fri, 18 Oct 2024 15:36:11 +0000

Source: tryton-modules-purchase-requisition
Source-Version: 6.0.3-1
Done: Mathias Behrle <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
tryton-modules-purchase-requisition, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mathias Behrle <[email-masked]> (supplier of updated tryton-modules-purchase-requisition package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Thu, 17 Oct 2024 14:17:12 +0200
Source: tryton-modules-purchase-requisition
Architecture: source
Version: 6.0.3-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Tryton Maintainers <[email-masked]>
Changed-By: Mathias Behrle <[email-masked]>
Closes: 1083911
Changes:
 tryton-modules-purchase-requisition (6.0.3-1) unstable; urgency=medium
 .
   * Bump the Standards-Version to 4.7.0, no changes needed.
   * Remove deprecated python3-pkg-resources from (Build)Depends (and wrap-
     and-sort -a) (Closes: #1083911).
   * Merging upstream version 6.0.3.
   * Updating copyright file.
Checksums-Sha1:
 d7f8ccf5965ba70ddcd186b39d90c0c326576dfc 2373 tryton-modules-purchase-requisition_6.0.3-1.dsc
 9b1fb1d553f8336604e2b007aa3a86f79bc4e4f7 39357 tryton-modules-purchase-requisition_6.0.3.orig.tar.gz
 161a78129d720f1465b0bd65981f840826c243bd 12464 tryton-modules-purchase-requisition_6.0.3-1.debian.tar.xz
 0081a1c8defab12d593a8d395a9e27adff2aceb3 8473 tryton-modules-purchase-requisition_6.0.3-1_amd64.buildinfo
Checksums-Sha256:
 84b1255611ebc26d4acf721597adbf198f2191c84eaf3f7a0097a87495af0bc7 2373 tryton-modules-purchase-requisition_6.0.3-1.dsc
 0b99abc1c0dc1cf4b5824d8fba21cab7df48c8d5c5a38815146d8d84dd8ca679 39357 tryton-modules-purchase-requisition_6.0.3.orig.tar.gz
 5bc6e8c16d219f9698d5723dd1d45c745159fd7657fe8953fc4dcffe28fa1fb5 12464 tryton-modules-purchase-requisition_6.0.3-1.debian.tar.xz
 e3cd953330dfc289d87ddd02f05d8c99f470afc54201069c9b9014bb37249f05 8473 tryton-modules-purchase-requisition_6.0.3-1_amd64.buildinfo
Files:
 ae855bb76f5dec6c52c318dd7fa7115e 2373 python optional tryton-modules-purchase-requisition_6.0.3-1.dsc
 3e26c848cfea3e8695081241149aa4f1 39357 python optional tryton-modules-purchase-requisition_6.0.3.orig.tar.gz
 446113481a29d2ac8ab84a4436735e98 12464 python optional tryton-modules-purchase-requisition_6.0.3-1.debian.tar.xz
 458988abea4d2d507f2211f60ee8c319 8473 python optional tryton-modules-purchase-requisition_6.0.3-1_amd64.buildinfo

Subject: tryton-modules-purchase-requisition: (build-)depends on deprecated module python3-pkg-resources
From: Matthias Klose <[email-masked]>
To: [email-masked]
Date: Fri, 04 Oct 2024 09:51:11 +0000