Subject: Bug#1087313: Firefox killing process

From: [email-masked]
Date: Mon, 11 Nov 2024 02:48:14 +0100

Package: firefox
Version: 69.0-1
Severity: important

Hello,

I have noticed that after resuming the system from suspend, some
processes on my machine crash. After investigating that, I found, by 
running plasmashell
under gdb, it is actually killed with a SIGTERM, and who is the sender
of the signal?

[firefox.killing (text/plain, inline)]

ben@debian:/mnt/extras/src$ gdb plasmashell
GNU gdb (Debian 8.3-1) 8.3
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later 
<http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
     <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from plasmashell...
(No debugging symbols found in plasmashell)
  ...
(gdb) run
Starting program: /usr/bin/plasmashell
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0xb172db40 (LWP 28895)]
[New Thread 0xb07bbb40 (LWP 28896)]
[New Thread 0xaf3f4b40 (LWP 28897)]
Aborting shell load: The activity manager daemon (kactivitymanagerd) is 
not running.
If this Plasma has been installed into a custom prefix, verify that its 
D-Bus services dir is known to the system for the daemon to be 
activatable.
org.kde.plasmaquick: Applet preload policy set to 1
Trying to use rootObject before initialization is completed, whilst 
using setInitializationDelayed. Forcing completion
[Detaching after fork from child process 28898]
file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/main.qml:62:28: 
Unable to assign [undefined] to int
file:///usr/share/plasma/plasmoids/org.kde.desktopcontainment/contents/ui/main.qml:53:27: 
Unable to assign [undefined] to int
Empty filename passed to function
Empty filename passed to function
trying to show an empty dialog
[New Thread 0xa92c6b40 (LWP 28899)]
[New Thread 0xa819eb40 (LWP 28900)]
[Detaching after fork from child process 28901]
[New Thread 0xa3b8eb40 (LWP 28902)]
[Thread 0xa3b8eb40 (LWP 28902) exited]
[New Thread 0xa3b8eb40 (LWP 28903)]
[Thread 0xa3b8eb40 (LWP 28903) exited]
Trying to use rootObject before initialization is completed, whilst 
using setInitializationDelayed. Forcing completion
qml: onLoaded
qml: bindSignals ICalManager_QMLTYPE_189(0x1048f40)
qml: bindSignals DebugCalendarManager_QMLTYPE_187(0x1044060)
qml: bindSignals GoogleCalendarManager_QMLTYPE_186(0x103ffd0)
qml: bindSignals PlasmaCalendarManager_QMLTYPE_185(0x103ada0)
Could not create Plasma Calendar Plugin:  
"/usr/lib/x86_64-linux-gnu/qt5/plugins/plasmacalendarplugins/holidaysevents.so"
"The shared library was not found."
Loading Calendar plugin HolidaysEventsPlugin(0x10069d0)
qml: bindSignals ICalManager_QMLTYPE_189(0x100a5d0)
qml: bindSignals DebugCalendarManager_QMLTYPE_187(0x106d390)
qml: bindSignals GoogleCalendarManager_QMLTYPE_186(0x109d200)
qml: bindSignals PlasmaCalendarManager_QMLTYPE_185(0x106e470)
Could not create Plasma Calendar Plugin:  
"/usr/lib/x86_64-linux-gnu/qt5/plugins/plasmacalendarplugins/holidaysevents.so"
"The shared library was not found."
2
Trying to use rootObject before initialization is completed, whilst 
using setInitializationDelayed. Forcing completion
[Detaching after fork from child process 28904]
qml: disabling redshift
[Detaching after fork from child process 28905]
qml: renderModeString:
qml: disabling redshift
Connecting to deprecated signal 
QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/PulseAudio.qml:22:1: 
module "org.kde.plasma.private.volume" is not installed
trying to show an empty dialog
trying to show an empty dialog
trying to show an empty dialog
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
trying to show an empty dialog
Trying to use rootObject before initialization is completed, whilst 
using setInitializationDelayed. Forcing completion
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
Both point size and pixel size set. Using pixel size.
trying to show an empty dialog
org.kde.plasmaquick: New Applet  "SpouĹĄtÄ aplikacĂ" with a weight of 
100
org.kde.plasmaquick: New Applet  "Event Calendar" with a weight of 0
org.kde.plasmaquick: New Applet  "Redshift Control" with a weight of 0
org.kde.plasmaquick: New Applet  "Osoba" with a weight of 0
Plasma Shell startup completed
org.kde.plasmaquick: New Applet  "DigitĂĄlnĂ hodiny" with a weight of 0
trying to show an empty dialog
qml: clearing connected sources, stop source was: killall redshift; 
redshift -x
qml: enabling redshift with command: redshift -t 6500:4000 -b 1:1 -g 
1:1:1 -r
[Detaching after fork from child process 28918]
org.kde.plasmaquick: New Applet  "OznamovĂĄnĂ" with a weight of 0
org.kde.plasmaquick: New Applet  "SchrĂĄnka" with a weight of 5
org.kde.plasmaquick: New Applet  "UpozornÄĂ na zaĹĂzenĂ" with a 
weight of 0
org.kde.plasmaquick: Delayed preload of  "SpouĹĄtÄ aplikacĂ" after 0 
seconds
Empty filename passed to function
KAStatsFavoritesModel::setFavorites is ignored
KActivities: Database connection:  
"kactivities_db_resources_2982318784_readonly"
     query_only:          QVariant(qlonglong, 1)
     journal_mode:        QVariant(QString, "wal")
     wal_autocheckpoint:  QVariant(qlonglong, 100)
     synchronous:         QVariant(qlonglong, 0)
Closing SQL connection:  "kactivities_db_resources_2982318784_readonly"
trying to show an empty dialog
org.kde.plasmaquick: Applet "SpouĹĄtÄ aplikacĂ" loaded after 242 msec
Process "LANG=C redshift -t 6500:4000 -b 1:1 -g 1:1:1 -r -p" already 
running. Pid: 28905
[New Thread 0xa3b8eb40 (LWP 28923)]
  ...
org.kde.plasmaquick: Applet "SpouĹĄtÄ aplikacĂ" loaded after 2 msec
org.kde.plasmaquick: Increasing score for "SpouĹĄtÄ aplikacĂ" to 100
[GFX1-]: Killing GPU process due to IPC reply timeout
[Parent 10546, Gecko_IOThread] WARNING: pipe error (132): Spojení 
zrušeno druhou stranou: file 
/build/firefox-qM07WG/firefox-69.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, 
line 358
[GFX1-]: Receive IPC close with reason=AbnormalShutdown

###!!! [Parent][MessageChannel] Error: 
(msgtype=0x4D001A,name=PGPU::Msg_ShutdownVR) Channel error: cannot 
send/recv

Thread 2 "QXcbEventReader" received signal SIGTERM, Terminated.
[Switching to Thread 0xb172db40 (LWP 28895)]
0xb7fd5881 in __kernel_vsyscall ()
(gdb) qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 
55728, resource id: 188743687, major code: 15 (QueryTree), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 55759, 
resource id: 69206019, major code: 15 (QueryTree), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 55789, 
resource id: 69206549, major code: 15 (QueryTree), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 55818, 
resource id: 69206063, major code: 15 (QueryTree), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 55846, 
resource id: 69206075, major code: 15 (QueryTree), minor code: 0
OpenGL vendor string:                   NVIDIA Corporation
OpenGL renderer string:                 GeForce GTS 450/PCIe/SSE2/3DNOW!
OpenGL version string:                  3.1.0 NVIDIA 390.129
OpenGL shading language version string: 1.40 NVIDIA via Cg compiler
Driver:                                 NVIDIA
Driver version:                         390.129
GPU class:                              GF100
OpenGL version:                         3.1
GLSL version:                           1.40
X server version:                       1.20.4
Linux kernel version:                   5.1
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
BlurConfig::instance called after the first use - ignoring
DesktopGridConfig::instance called after the first use - ignoring
KscreenConfig::instance called after the first use - ignoring
PresentWindowsConfig::instance called after the first use - ignoring
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 57030, 
resource id: 69206020, major code: 18 (ChangeProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 57035, 
resource id: 69206021, major code: 18 (ChangeProperty), minor code: 0
SlideConfig::instance called after the first use - ignoring
SlidingPopupsConfig::instance called after the first use - ignoring
ZoomConfig::instance called after the first use - ignoring
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 58745, 
resource id: 243269658, major code: 18 (ChangeProperty), minor code: 0
(gdb) threads
Undefined command: "threads".  Try "help".
(gdb) thread
[Current thread is 2 (Thread 0xb172db40 (LWP 28895))]
(gdb) bt
#0  0xb7fd5881 in __kernel_vsyscall ()
#1  0xb54c8b6b in __GI___poll (timeout=-1, nfds=1, fds=0xb172d14c) at 
../sysdeps/unix/sysv/linux/poll.c:29
#2  0xb54c8b6b in __GI___poll (fds=0xb172d14c, nfds=1, timeout=-1) at 
../sysdeps/unix/sysv/linux/poll.c:26
#3  0xb7b6bd9d in  () at /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb7b6df53 in xcb_wait_for_event () at 
/usr/lib/i386-linux-gnu/libxcb.so.1
#5  0xb18716a3 in  () at /usr/lib/i386-linux-gnu/libQt5XcbQpa.so.5
#6  0xb58446b6 in  () at /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb4caffd2 in start_thread (arg=<optimized out>) at 
pthread_create.c:486
#8  0xb54d36d6 in clone () at 
../sysdeps/unix/sysv/linux/i386/clone.S:108
(gdb) qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 
60970, resource id: 25695180, major code: 20 (GetProperty), minor code: 
0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 60972, 
resource id: 25695180, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 60973, 
resource id: 25695180, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 60975, 
resource id: 25695180, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 60976, 
resource id: 25695180, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 61197, 
resource id: 25698435, major code: 3 (GetWindowAttributes), minor code: 
0
qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 61198, 
resource id: 25698435, major code: 14 (GetGeometry), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6986, 
resource id: 25698867, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6988, 
resource id: 25698867, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6991, 
resource id: 25698867, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6993, 
resource id: 25698867, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 6994, 
resource id: 25698867, major code: 20 (GetProperty), minor code: 0
p $_siginfo
$1 = {
   si_signo = 15,
   si_errno = 0,
   si_code = 0,
   _sifields = {
     _pad = {10546, 1000, 0 <repeats 27 times>},
     _kill = {
       si_pid = 10546,
       si_uid = 1000
     },
     _timer = {
       si_tid = 10546,
       si_overrun = 1000,
       si_sigval = {
         sival_int = 0,
         sival_ptr = 0x0
       }
     },
     _rt = {
       si_pid = 10546,
       si_uid = 1000,
       si_sigval = {
         sival_int = 0,
         sival_ptr = 0x0
       }
     },
     _sigchld = {
       si_pid = 10546,
       si_uid = 1000,
       si_status = 0,
       si_utime = 0,
       si_stime = 0
     },
     _sigfault = {
       si_addr = 0x2932,
       _addr_lsb = 1000,
       _addr_bnd = {
         _lower = 0x0,
         _upper = 0x0
       }
     },
     _sigpoll = {
       si_band = 10546,
       si_fd = 1000
     }
   }
}

[Message part 3 (text/plain, inline)]

As you can see, the signal is originated by pid 10546, which was also
the Parent process of firefox. (firefox could have been started from
plasma on this occasion, I'm not sure)

I don't really like firefox closing itself on resume either, but I can
live with that. After all, without it firefox only displays black
windows and crashes - interestingly chromium also shows garbled display
after resume, but then redisplays everything and all is well. However,
firefox is in no business to kill other processes on the
machine. Therefore I think severity important is warranted.

Regards
     Jiri Palecek

-- Package-specific info:

[Message part 4 (text/plain, attachment)]

[Message part 5 (text/plain, inline)]

-- System Information:
Debian Release: 10.0
   APT prefers testing
   APT policy: (990, 'testing'), (500, 'unstable-debug'), (500, 
'testing-debug'), (500, 'unstable'), (1, 'experimental-debug'), (1, 
'experimental')
Architecture: i386 (i686)
Foreign Architectures: amd64

Kernel: Linux 5.1.0-rc4-bughunt+ (SMP w/2 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_WARN, 
TAINT_OOT_MODULE
Locale: LANG=cs_CZ, LC_CTYPE=cs_CZ (charmap=ISO-8859-2), LANGUAGE=cs_CZ 
(charmap=ISO-8859-2)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages firefox depends on:
ii  debianutils               4.8.6
ii  fontconfig                2.13.1-2+b1
ii  libasound2                1.1.8-1
ii  libatk1.0-0               2.32.0-2
ii  libc6                     2.28-10
ii  libcairo-gobject2         1.16.0-4
ii  libcairo2                 1.16.0-4
ii  libdbus-1-3               1.12.16-1
ii  libdbus-glib-1-2          0.110-4
ii  libevent-2.1-6            2.1.8-stable-4
ii  libffi6                   3.2.1-9
ii  libfontconfig1            2.13.1-2+b1
ii  libfreetype6              2.9.1-4
ii  libgcc1                   1:9.2.1-4
ii  libgdk-pixbuf2.0-0        2.38.1+dfsg-1
ii  libglib2.0-0              2.60.6-2
ii  libgtk-3-0                3.24.10-1
ii  libnspr4                  2:4.21-1
ii  libnss3                   2:3.45-1
ii  libpango-1.0-0            1.42.4-7
ii  libsqlite3-0              3.29.0-2
ii  libstartup-notification0  0.12-5
ii  libstdc++6                9.2.1-4
ii  libx11-6                  2:1.6.7-1
ii  libx11-xcb1               2:1.6.7-1
ii  libxcb-shm0               1.13.1-2
ii  libxcb1                   1.13.1-1
ii  libxcomposite1            1:0.4.4-2
ii  libxdamage1               1:1.1.5-1
ii  libxext6                  2:1.3.3-1+b2
ii  libxfixes3                1:5.0.3-1
ii  libxrender1               1:0.9.10-1
ii  libxt6                    1:1.1.5-1+b3
ii  procps                    2:3.3.15-2+b1
ii  zlib1g                    1:1.2.11.dfsg-1+b1

Versions of packages firefox recommends:
ii  libavcodec58  10:4.2-dmo5

Versions of packages firefox suggests:
ii  fonts-lmodern          2.004.5-5
ii  fonts-stix [otf-stix]  1.1.1-3
ii  libcanberra0           0.30-6
ii  libgssapi-krb5-2       1.17-5
ii  libgtk2.0-0            2.24.32-3
pn  pulseaudio             <none>

-- no debconf information

---

From: Sylvestre Ledru <[email-masked]>
Date: Thu, 14 Nov 2024 11:00:56 +0100

Hello
You are really running 69.0-1?

Thanks,
Sylvestre