Subject: unoconv: odt2sxw does not work: Error Area:Io Class:Parameter Code:26

From: Vincent Lefevre <[email-masked]>
Date: Tue, 12 Nov 2024 10:26:58 +0100

Package: unoconv
Version: 0.7-2
Severity: important

odt2sxw does not work. I get the following error, which seems to
occur on any .odt file, such as the simple one attached (I created
a new document, wrote "test", and saved):

qaa:~> odt2sxw test.odt
/bin/odt2sxw:778: DeprecationWarning: distutils Version classes are deprecated. Use packaging.version instead.
  if product.ooName not in ('LibreOffice', 'LOdev') or LooseVersion(product.ooSetupVersion) <= LooseVersion('3.3'):
Traceback (most recent call last):
  File "/bin/odt2sxw", line 1037, in convert
    document.storeToURL(outputurl, tuple(outputprops) )
uno.com.sun.star.io.IOException: SfxBaseModel::impl_store <file:///home/vinc17/test.sxw> failed: 0x81a(Error Area:Io Class:Parameter Code:26)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/bin/odt2sxw", line 1282, in <module>
    main()
  File "/bin/odt2sxw", line 1198, in main
    convertor.convert(inputfn)
  File "/bin/odt2sxw", line 1039, in convert
    raise UnoException("Unable to store document to %s (ErrCode %d)\n\nProperties: %s" % (outputurl, e.ErrCode, outputprops), None)
                                                                                                     ^^^^^^^^^
  File "/usr/lib/python3/dist-packages/uno.py", line 507, in _uno_struct__getattr__
    return getattr(self.__dict__["value"], name)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
AttributeError: ErrCode

-- System Information:
Debian Release: trixie/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable-debug'), (500, 'proposed-updates-debug'), (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 6.7.12-amd64 (SMP w/16 CPU threads; PREEMPT)
Kernel taint flags: TAINT_WARN
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages unoconv depends on:
ii  python3      3.12.6-1
ii  python3-uno  4:24.8.2-2

Versions of packages unoconv recommends:
ii  libreoffice-calc     4:24.8.2-2
ii  libreoffice-draw     4:24.8.2-2
ii  libreoffice-impress  4:24.8.2-2
ii  libreoffice-writer   4:24.8.2-2

unoconv suggests no packages.

-- no debconf information

-- 
Vincent Lefèvre <[email-masked]> - Web: <https://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <https://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / AriC project (LIP, ENS-Lyon)

---

From: Vincent Lefevre <[email-masked]>
Date: Tue, 12 Nov 2024 17:04:17 +0100

Control: retitle -1 unoconv: odt2sdw and odt2sxw do not work: Error Area:Io Class:Parameter Code:26 / soffice.bin process left behind

>     return getattr(self.__dict__["value"], name)

Same error with odt2sdw.

Moreover a soffice.bin process is left behind:

vlefevre    5923       1 33 17:03 pts/12   00:00:01 /usr/lib/libreoffice/program/soffice.bin --headless --invisible --nocrashreport --nodefault --nofirststartwizard --nologo --norestore --accept=socket,host=127.0.0.1,port=2002,tcpNoDelay=1;urp;StarOffice.ComponentContext

And the consequence is that libreoffice no longer works!
(Running libreoffice has no effect.)