Subject: kwin-wayland: Plasma crashes if 100-200 windows are opened on Wayland (upstream has fix, please backport it to bookworm)

From: Askar Safin <[email-masked]>
Date: Mon, 06 Jan 2025 21:27:25 +0300

Package: kwin-wayland
Version: 4:5.27.5-3
Severity: important
Tags: patch
X-Debbugs-Cc: [email-masked]

TL;DR: this bug is fixed upstream, and it makes kwin-wayland unusable for me, so, please,
backport upstream fix to bookworm.

Hi. Plasma crashes if 100-200 windows are opened on Wayland. Steps to reproduce:

- You should have Debian Bookworm x86_64 installed. With KDE Wayland
- Start KDE Wayland session
- Open 100-200 windows, for example, Konsole windows (note that on my system Konsole
windows have relatively long title, for example, "40 user@comp: ~ ~ bash — Konsole")
- Plasma will crash

The bug is already reported and fixed upstream: https://bugs.kde.org/show_bug.cgi?id=479492 .

Please, backport the fix to debian bookworm. This bug makes KDE Wayland unusable for
me, and it is one of the reasons I still stay on X11. I usually have a lot of windows opened.

I marked the bug as "important", because I think it severly affects usability of the KDE Wayland session.

Reproducibility: always (i. e. Plasma crashes EVERY TIME, when I open "too many" windows)

-- System Information:
Debian Release: 12.8
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 6.1.0-28-amd64 (SMP w/32 CPU threads; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages kwin-wayland depends on:
ii  kwayland-integration              5.27.5-2
ii  kwin-common                       4:5.27.5-3
ii  libc6                             2.36-9+deb12u9
ii  libcap2-bin                       1:2.66-4
ii  libepoxy0                         1.5.10-1
ii  libfontconfig1                    2.14.1-4
ii  libfreetype6                      2.12.1+dfsg-5+deb12u3
ii  libkdecorations2-5v5              4:5.27.5-2
ii  libkf5configcore5                 5.103.0-2
ii  libkf5configgui5                  5.103.0-2
ii  libkf5configwidgets5              5.103.0-1
ii  libkf5coreaddons5                 5.103.0-1
ii  libkf5crash5                      5.103.0-1
ii  libkf5dbusaddons5                 5.103.0-1
ii  libkf5globalaccel-bin             5.103.0-1
ii  libkf5globalaccel5                5.103.0-1
ii  libkf5globalaccelprivate5         5.103.0-1
ii  libkf5i18n5                       5.103.0-1
ii  libkf5idletime5                   5.103.0-2
ii  libkf5notifications5              5.103.0-1
ii  libkf5plasma5                     5.103.0-1+deb12u1
ii  libkf5service-bin                 5.103.0-1
ii  libkf5service5                    5.103.0-1
ii  libkf5windowsystem5               5.103.0-1
ii  libkwineffects14                  4:5.27.5-3
ii  libkwinglutils14                  4:5.27.5-3
ii  libpipewire-0.3-0                 0.3.65-3+deb12u1
ii  libqaccessibilityclient-qt5-0     0.4.1-1+b1
ii  libqt5core5a [qtbase-abi-5-15-8]  5.15.8+dfsg-11+deb12u2
ii  libqt5dbus5                       5.15.8+dfsg-11+deb12u2
ii  libqt5gui5                        5.15.8+dfsg-11+deb12u2
ii  libqt5network5                    5.15.8+dfsg-11+deb12u2
ii  libqt5qml5                        5.15.8+dfsg-3
ii  libqt5quick5                      5.15.8+dfsg-3
ii  libqt5widgets5                    5.15.8+dfsg-11+deb12u2
ii  libstdc++6                        12.2.0-14
ii  libxcb-randr0                     1.15-1
ii  libxcb-xfixes0                    1.15-1
ii  libxcb1                           1.15-1
ii  xwayland                          2:22.1.9-1

kwin-wayland recommends no packages.

kwin-wayland suggests no packages.

-- no debconf information

---

From: Askar Safin <[email-masked]>
Date: Tue, 7 Jan 2025 20:17:49 +0300

I just reproduced the bug on totally fresh bookworm install

-- 
Askar Safin

---

From: Askar Safin <[email-masked]>
Date: Wed, 8 Jan 2025 21:07:16 +0300

It seems the bug was never fixed upstream in KWin 5.x. Fix was
deployed to KWin 6.x only. If you want, I can try to backport the fix
to bookworm's KWin 5.x and test the fix on my computer. I didn't do
this yet, because I'm not sure whether anybody actually reads all
these bug reports. So, if you actually read these reports and you want
me to try to write and test the fix, then, please, just tell me to do
so, and I will happily do it. I have time until 22 Jan 2025, then I
will move to other things.

-- 
Askar Safin