Subject: autopkgtests: Uses deprecated debhelper compat levels in its autopkgtests

From: Niels Thykier <[email-masked]>
Date: Fri, 17 Jan 2025 15:48:42 +0100

Package: autopkgtests
Severity: minor
X-Debbugs-Cc: [email-masked]

Hi,

While investigating a test failure in autopkgtests' autopkgtests, I 
noted a warning from `debhelper` that the package uses compat 9, which 
as been deprecated.

Please go through tests and bump to a more modern compat level where 
possible. Both stable and oldstable has `debhelper/13+` with 
oldoldstable having `debhelper/12+`

> 945s 03:22:00 O: ======================================================================
> 945s 03:22:00 O: FAIL: test_timeout_long_build_fail (__main__.NullRunner.test_timeout_long_build_fail)
> 945s 03:22:00 O: long-running build times out
> 945s 03:22:00 O: ----------------------------------------------------------------------
> 945s 03:22:00 O: Traceback (most recent call last):
> 945s 03:22:00 O:   File "/tmp/autopkgtest-lxc.w4xwvm3w/downtmp/build.QrG/src/./tests/autopkgtest", line 1339, in test_timeout_long_build_fail
> 945s 03:22:00 O:     self.assertIn('dh binary', err)
> 945s 03:22:00 O: AssertionError: 'dh binary' not found in 'autopkgtest [03:17:47]: starting date and time: 2025-01-17 03:17:47+0000\nautopkgtest [03:17:47]: version 5.43\nautopkgtest [03:17:47]: host ci-017-3b434831; command line: /usr/bin/autopkgtest --timeout-test=1 --timeout-build=6 -B /tmp/autopkgtest.test.ieksfy5q/testpkg -- null\nautopkgtest [03:17:48]: testbed dpkg architecture: riscv64\nautopkgtest [03:17:48]: testbed apt version: 2.9.21\nautopkgtest [03:17:48]: @@@@@@@@@@@@@@@@@@@@ test bed setup\nautopkgtest [03:17:48]: testbed release detected to be: None\nautopkgtest [03:17:48]: testbed running kernel: Linux 6.12.6-riscv64 #1 SMP Debian 6.12.6-1 (2024-12-21)\nautopkgtest [03:17:48]: @@@@@@@@@@@@@@@@@@@@ unbuilt-tree /tmp/autopkgtest.test.ieksfy5q/testpkg\nautopkgtest [03:17:49]: testing package testpkg version 1\nautopkgtest [03:17:49]: build needed for tests\ndpkg-buildpackage: info: source package testpkg\ndpkg-buildpackage: info: source version 1\ndpkg-buildpackage: info: source distribution UNRELEASED\ndpkg-buildpackage: info: source changed by Martin Pitt <[email-masked]>\n dpkg-source --before-build .\ndpkg-buildpackage: info: host architecture riscv64\n fakeroot debian/rules clean\ndh clean\ndh: warning: Compatibility levels before 10 are deprecated (level 9 in use)\n   dh_auto_clean\ndh_auto_clean: warning: Compatibility levels before 10 are deprecated (level 9 in use)\n\tmake -j1 distclean\nmake[1]: Entering directory \'/tmp/autopkgtest.ba3FEo/build.glO/real-tree\'\nrm -f test_built\nmake[1]: Leaving directory \'/tmp/autopkgtest.ba3FEo/build.glO/real-tree\'\n   dh_clean\ndh_clean: warning: Compatibility levels before 10 are deprecated (level 9 in use)\n debian/rules build\ndh build\ndh: warning: Compatibility levels before 10 are deprecated (level 9 in use)\n   dh_update_autotools_config\n   dh_auto_configure\ndh_auto_configure: warning: Compatibility levels before 10 are deprecated (level 9 in use)\n   dh_auto_build\ndh_auto_build: warning: Compatibility levels before 10 are deprecated (level 9 in use)\n\tmake -j1\nmake[1]: Entering directory \'/tmp/autopkgtest.ba3FEo/build.glO/real-tree\'\nsleep 4\nmake[1]: *** [Makefile:2: build] Terminated\nmake: *** [debian/rules:3: build] Terminated\nautopkgtest [03:18:02]: ERROR: testbed failure: timed out on command "sh -ec exec 3>&1 >&2; cd /tmp/autopkgtest.ba3FEo/build.glO/real-tree; DEB_BUILD_OPTIONS="nocheck noautodbgsym noddebs $DEB_BUILD_OPTIONS" DEB_BUILD_PROFILES="noudeb nocheck parallel=4 $DEB_BUILD_PROFILES" dpkg-buildpackage -us -uc -b; dpkg-source --before-build ." (kind: build)\n'
> 945s 03:22:00 O: 
> 945s 03:22:00 O: ----------------------------------------------------------------------
> 945s 03:22:00 O: Ran 700 tests in 716.260s

Best regards,
Niels

---

From: Niels Thykier <[email-masked]>
Date: Fri, 17 Jan 2025 15:52:58 +0100

Control: reassign -1 autopkgtest

Hi,

Botched the submission. Quoting in full for the maintainer.