Subject: ocamlformat: ftbfs with GCC-15

From: Matthias Klose <[email-masked]>
Date: Mon, 17 Feb 2025 17:40:56 +0000

Package: src:ocamlformat
Version: 0.27.0-1
Severity: important
Tags: sid forky
User: [email-masked]
Usertags: ftbfs-gcc-15

[This bug is NOT targeted to the upcoming trixie release]

Please keep this issue open in the bug tracker for the package it
was filed for.  If a fix in another package is required, please
file a bug for the other package (or clone), and add a block in this
package. Please keep the issue open until the package can be built in
a follow-up test rebuild.

The package fails to build in a test rebuild on at least amd64 with
gcc-15/g++-15, but succeeds to build with gcc-14/g++-14. The
severity of this report will be raised before the forky release.

The full build log can be found at:
http://qa-logs.debian.net/2025/02/16/amd64exp/ocamlformat_0.27.0-1_unstable_gccexp.log.gz
The last lines of the build log are at the end of this report.

To build with GCC 15, either set CC=gcc-15 CXX=g++-15 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t=experimental install g++ 

GCC 15 now defaults to the C23/C++23 standards, exposing many FTBFS.
Other Common build failures are new warnings resulting in build failures
with -Werror turned on, or new/dropped symbols in Debian symbols files.
For other C/C++ related build failures see the porting guide at
http://gcc.gnu.org/gcc-15/porting_to.html

[...]
    package: bash
    version: 5.3~beta1-1
    architecture: amd64
    essential: true
   -
    package: base-passwd
    version: 3.6.6
    architecture: amd64
    essential: true
   -
    package: base-files
    version: 13.6
    architecture: amd64
    essential: true
   -
    package: autotools-dev
    version: 20220109.1
    architecture: all
   -
    package: autopoint
    version: 0.23.1-1
    architecture: all
   -
    package: automake
    version: 1:1.17-3
    architecture: all
   -
    package: autoconf
    version: 2.72-3
    architecture: all
 
background-packages: 76372
foreground-packages: 1
total-packages: 76373
broken-packages: 0

+------------------------------------------------------------------------------+
| Cleanup                                      Sun, 16 Feb 2025 03:05:34 +0000 |
+------------------------------------------------------------------------------+

Purging /build/reproducible-path
Not cleaning session: cloned chroot in use
E: Package build dependencies not satisfied; skipping

+------------------------------------------------------------------------------+
| Summary                                      Sun, 16 Feb 2025 03:05:35 +0000 |
+------------------------------------------------------------------------------+

Build Architecture: amd64
Build Type: binary
Build-Space: n/a
Build-Time: 0
Distribution: unstable
Fail-Stage: install-deps
Host Architecture: amd64
Install-Time: 0
Job: ocamlformat_0.27.0-1
Machine Architecture: amd64
Package: ocamlformat
Package-Time: 0
Source-Version: 0.27.0-1
Space: n/a
Status: given-back
Version: 0.27.0-1
--------------------------------------------------------------------------------
Finished at 2025-02-16T03:04:48Z
Build needed 00:00:00, no disk space
E: Package build dependencies not satisfied; skipping
DC-Status: Failed 48.134577306s
DC-Time-Estimation: 48.134577306 versus expected 129 (r/m: 1.6799861392762265 ; m: 48.134577306)

---

From: Stéphane Glondu <[email-masked]>
Date: Thu, 20 Feb 2025 10:31:57 +0100

Dear Matthias,

> The last lines of the build log are at the end of this report.

I don't understand why this is a problem in ocamlformat. I would rather 
say something is wrong in your rebuilding infrastructure.

"Failures" in installing build-dependencies should not have been reported.

Cheers,

-- 
Stéphane