Subject: Bug#1097543: papi: ftbfs with GCC-15

From: Matthias Klose <[email-masked]>
Date: Mon, 17 Feb 2025 17:42:25 +0000

Package: src:papi
Version: 7.1.0-5
Severity: important
Tags: sid forky
User: [email-masked]
Usertags: ftbfs-gcc-15

[This bug is NOT targeted to the upcoming trixie release]

Please keep this issue open in the bug tracker for the package it
was filed for.  If a fix in another package is required, please
file a bug for the other package (or clone), and add a block in this
package. Please keep the issue open until the package can be built in
a follow-up test rebuild.

The package fails to build in a test rebuild on at least amd64 with
gcc-15/g++-15, but succeeds to build with gcc-14/g++-14. The
severity of this report will be raised before the forky release.

The full build log can be found at:
http://qa-logs.debian.net/2025/02/16/amd64exp/papi_7.1.0-5_unstable_gccexp.log.gz
The last lines of the build log are at the end of this report.

To build with GCC 15, either set CC=gcc-15 CXX=g++-15 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t=experimental install g++ 

GCC 15 now defaults to the C23/C++23 standards, exposing many FTBFS.
Other Common build failures are new warnings resulting in build failures
with -Werror turned on, or new/dropped symbols in Debian symbols files.
For other C/C++ related build failures see the porting guide at
http://gcc.gnu.org/gcc-15/porting_to.html

[...]
Host CPU component  : perf_event
Installation DESTDIR: 
make CC=cc -C sde_lib dynamic
Installation PREFIX : /usr
make -C testlib
Installation EPREFIX: /usr
cc -E -Wdate-time -D_FORTIFY_SOURCE=2 -I/usr/include -DFORTRANCAPS papi_fwrappers.c > upper_PAPI_FWRAPPERS.c
cc -E -Wdate-time -D_FORTIFY_SOURCE=2 -I/usr/include -DFORTRANUNDERSCORE papi_fwrappers.c > papi_fwrappers_.c
make[2]: Entering directory '/build/reproducible-path/papi-7.1.0/src/testlib'
cc -I. -I.. -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/papi-7.1.0=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wdate-time -D_FORTIFY_SOURCE=2  -DHAVE_ROCM_SMI -DPAPI_NUM_COMP=5 -O1  -c test_utils.c
Installation INCDIR : /usr/include
make[2]: Entering directory '/build/reproducible-path/papi-7.1.0/src/sde_lib'
Installation LIBDIR : /usr/lib/x86_64-linux-gnu
Installation BINDIR : /usr/bin
Installation MANDIR : /usr/share/man
Installation DOCDIR : /usr/share/doc/papi
Installation DATADIR: /usr/share/papi

cc -E -Wdate-time -D_FORTIFY_SOURCE=2 -I/usr/include -DFORTRANDOUBLEUNDERSCORE papi_fwrappers.c > papi_fwrappers__.c
gfortran -I. -I.. -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/papi-7.1.0=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wdate-time -D_FORTIFY_SOURCE=2   -g -O2 -ffile-prefix-map=/build/reproducible-path/papi-7.1.0=. -fstack-protector-strong -fstack-clash-protection -fcf-protection -Dlinux -ffixed-line-length-132  -c ftests_util.F
f951: Warning: ‘-Werror=’ argument ‘-Werror=implicit-function-declaration’ is not valid for Fortran
f951: Warning: command-line option ‘-Wformat=1’ is valid for C/C++/ObjC/ObjC++ but not for Fortran
f951: Warning: ‘-Werror=’ argument ‘-Werror=format-security’ is not valid for Fortran
high-level/papi_hl.c:409:12: error: conflicting types for ‘_internal_hl_read_user_events’; have ‘int(const char *)’
  409 | static int _internal_hl_read_user_events(const char *user_events)
      |            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
high-level/papi_hl.c:170:12: note: previous declaration of ‘_internal_hl_read_user_events’ with type ‘int(void)’
  170 | static int _internal_hl_read_user_events();
      |            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
make[1]: *** [Makefile.inc:115: papi_hl.o] Error 1
make[1]: *** Waiting for unfinished jobs....
cc -I. -I.. -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/papi-7.1.0=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wdate-time -D_FORTIFY_SOURCE=2  -DHAVE_ROCM_SMI -DPAPI_NUM_COMP=5 -O1 -O0 -c do_loops.c
cc -I. -I.. -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/papi-7.1.0=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wdate-time -D_FORTIFY_SOURCE=2  -DHAVE_ROCM_SMI -DPAPI_NUM_COMP=5 -O1  -c clockcore.c
ar  rv libtestlib.a test_utils.o ftests_util.o
ar: creating libtestlib.a
a - test_utils.o
a - ftests_util.o
make[2]: Leaving directory '/build/reproducible-path/papi-7.1.0/src/testlib'
rm -f *_d.o
make[2]: Leaving directory '/build/reproducible-path/papi-7.1.0/src/sde_lib'
ln -sf sde_lib/libsde.so.1.0 libsde.so
make CC=cc -C sde_lib static
make[2]: Entering directory '/build/reproducible-path/papi-7.1.0/src/sde_lib'
ar rs libsde.a sde_lib_s.o sde_lib_datastructures_s.o sde_lib_misc_s.o sde_lib_ti_s.o
ar: creating libsde.a
rm -f *_s.o
make[2]: Leaving directory '/build/reproducible-path/papi-7.1.0/src/sde_lib'
ln -sf sde_lib/libsde.a libsde.a
make[1]: Leaving directory '/build/reproducible-path/papi-7.1.0/src'
dh_auto_build: error: cd src && make -j8 returned exit code 2
make: *** [debian/rules:35: binary] Error 25
dpkg-buildpackage: error: debian/rules binary subprocess returned exit status 2

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 17 Feb 2025 17:43:59 +0000

Thank you for filing a new Bug report with Debian.

You can follow progress on this Bug here: 1097543: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1097543.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 Debian HPC Team <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1097543: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1097543
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Wed, 26 Mar 2025 21:54:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the src:papi package:

#1097543: papi: ftbfs with GCC-15

It has been closed by Debian FTP Masters <[email-masked]> (reply to Andreas Beckmann <[email-masked]>).

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> (reply to Andreas Beckmann <[email-masked]>) by
replying to this email.

Subject: Bug#1097543: fixed in papi 7.2.0~b2-1
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Wed, 26 Mar 2025 21:50:57 +0000

Source: papi
Source-Version: 7.2.0~b2-1
Done: Andreas Beckmann <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
papi, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Andreas Beckmann <[email-masked]> (supplier of updated papi package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Wed, 26 Mar 2025 22:19:47 +0100
Source: papi
Architecture: source
Version: 7.2.0~b2-1
Distribution: experimental
Urgency: medium
Maintainer: Debian HPC Team <[email-masked]>
Changed-By: Andreas Beckmann <[email-masked]>
Closes: 1097543
Changes:
 papi (7.2.0~b2-1) experimental; urgency=medium
 .
   * New upstream beta.
   * Refresh patches.
   * Bump libpfm4-dev B-D to >= 4.13.0+git83.
   * Fix FTBFS with GCC 15.  (Closes: #1097543)
   * Bump Standards-Version to 4.7.2. No changes needed.
Checksums-Sha1:
 58a3d8cd01c0d8df2461a857418d012fa819adb9 2392 papi_7.2.0~b2-1.dsc
 51652163685df1c014b5f567e24de97e344d0791 4216860 papi_7.2.0~b2.orig.tar.gz
 c72efd7fc2c7553ff289d4cb89b9e1d032fd5afd 24780 papi_7.2.0~b2-1.debian.tar.xz
 b9f1561921996073de061a1a4976ef8e272404c4 8366 papi_7.2.0~b2-1_source.buildinfo
Checksums-Sha256:
 19045f28320dcaa97058b62a1595da5e1abd10c90f68f2dc17786a6ee16c79ef 2392 papi_7.2.0~b2-1.dsc
 0d2a2a08c0ec2a5ccf2a7854c068ced96569fffc7d6a126f58ede0a0fd6426bf 4216860 papi_7.2.0~b2.orig.tar.gz
 ffcb20ae3e7e8538ccac77d7d78746e0aa4fe588de2474a34e3caab02f934430 24780 papi_7.2.0~b2-1.debian.tar.xz
 9a2b50236fba0101ec6469651eba1ed374fdc848ba09c51e2baf4aec27c3fca5 8366 papi_7.2.0~b2-1_source.buildinfo
Files:
 beecc503b6f6d5ae27a30908bb91446d 2392 devel optional papi_7.2.0~b2-1.dsc
 074e0e7053389708d2898bd684fe49d7 4216860 devel optional papi_7.2.0~b2.orig.tar.gz
 db6912465a19880af454b2fd61c34068 24780 devel optional papi_7.2.0~b2-1.debian.tar.xz
 ba68ed2330c53bdddcf629e66c07925b 8366 devel optional papi_7.2.0~b2-1_source.buildinfo

Subject: papi: ftbfs with GCC-15
From: Matthias Klose <[email-masked]>
To: [email-masked]
Date: Mon, 17 Feb 2025 17:42:25 +0000

Package: src:papi
Version: 7.1.0-5
Severity: important
Tags: sid forky

[...]