Subject: Bug#1097654: proftpd-dfsg: ftbfs with GCC-15

From: Matthias Klose <[email-masked]>
Date: Mon, 17 Feb 2025 17:46:03 +0000

Package: src:proftpd-dfsg
Version: 1.3.8.c+dfsg-1
Severity: important
Tags: sid forky
User: [email-masked]
Usertags: ftbfs-gcc-15

[This bug is NOT targeted to the upcoming trixie release]

Please keep this issue open in the bug tracker for the package it
was filed for.  If a fix in another package is required, please
file a bug for the other package (or clone), and add a block in this
package. Please keep the issue open until the package can be built in
a follow-up test rebuild.

The package fails to build in a test rebuild on at least amd64 with
gcc-15/g++-15, but succeeds to build with gcc-14/g++-14. The
severity of this report will be raised before the forky release.

The full build log can be found at:
http://qa-logs.debian.net/2025/02/16/amd64exp/proftpd-dfsg_1.3.8.c+dfsg-1_unstable_gccexp.log.gz
The last lines of the build log are at the end of this report.

To build with GCC 15, either set CC=gcc-15 CXX=g++-15 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t=experimental install g++ 

GCC 15 now defaults to the C23/C++23 standards, exposing many FTBFS.
Other Common build failures are new warnings resulting in build failures
with -Werror turned on, or new/dropped symbols in Debian symbols files.
For other C/C++ related build failures see the porting guide at
http://gcc.gnu.org/gcc-15/porting_to.html

[...]
fi
if [ -f "./zh_CN.po" -a ! -f zh_CN.mo ]; then \
	 msgfmt -o zh_CN.mo "./zh_CN.po"; \
fi
libtool: compile:  gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H -DLINUX -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c pr-syslog.c -o pr-syslog.o
/bin/bash ../libtool --mode=compile --tag=CC gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -static -c pwgrent.c
if [ -f "./zh_TW.po" -a ! -f zh_TW.mo ]; then \
	 msgfmt -o zh_TW.mo "./zh_TW.po"; \
fi
make[3]: Leaving directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/locale'
libtool: compile:  gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H -DLINUX -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c pwgrent.c -o pwgrent.o
/bin/bash ../libtool --mode=compile --tag=CC gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -static -c hanson-tpl.c
libtool: compile:  gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H -DLINUX -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c hanson-tpl.c -o hanson-tpl.o
/bin/bash ../libtool --mode=compile --tag=CC gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -static -c ccan-json.c
libtool: compile:  gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H -DLINUX -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c ccan-json.c -o ccan-json.o
/bin/bash ../libtool --mode=compile --tag=CC gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -static -c openbsd-blowfish.c
libtool: compile:  gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H -DLINUX -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c openbsd-blowfish.c -o openbsd-blowfish.o
/bin/bash ../libtool --mode=compile --tag=CC gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -static -c openbsd-bcrypt.c
cd libltdl/ && make
libtool: compile:  gcc -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_CONFIG_H -DLINUX -I.. -I../include -I../include -I/usr/include/mariadb/mysql -I/usr/include/mariadb -I/usr/include/postgresql -I/usr/include/mariadb -I/usr/include/mariadb/mysql -I/usr/include/postgresql -Wdate-time -D_FORTIFY_SOURCE=2 -g2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -Wall -fno-omit-frame-pointer -fno-strict-aliasing -Werror=implicit-function-declaration -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c openbsd-bcrypt.c -o openbsd-bcrypt.o
ar rc prbase.a pr_fnmatch.o sstrncpy.o strsep.o vsnprintf.o glibc-glob.o glibc-hstrerror.o glibc-mkstemp.o pr-syslog.o pwgrent.o hanson-tpl.o ccan-json.o openbsd-blowfish.o openbsd-bcrypt.o
make[4]: Entering directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib/libltdl'
make  all-am
make[5]: Entering directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib/libltdl'
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o dlopen.lo `test -f 'loaders/dlopen.c' || echo './'`loaders/dlopen.c
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdlc -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o libltdlc_la-preopen.lo `test -f 'loaders/preopen.c' || echo './'`loaders/preopen.c
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdlc -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o libltdlc_la-lt__alloc.lo `test -f 'lt__alloc.c' || echo './'`lt__alloc.c
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdlc -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o libltdlc_la-lt_dlloader.lo `test -f 'lt_dlloader.c' || echo './'`lt_dlloader.c
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdlc -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o libltdlc_la-lt_error.lo `test -f 'lt_error.c' || echo './'`lt_error.c
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdlc -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o libltdlc_la-ltdl.lo `test -f 'ltdl.c' || echo './'`ltdl.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c lt__alloc.c  -fPIC -DPIC -o .libs/libltdlc_la-lt__alloc.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c lt_error.c  -fPIC -DPIC -o .libs/libltdlc_la-lt_error.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c loaders/preopen.c  -fPIC -DPIC -o .libs/libltdlc_la-preopen.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c loaders/dlopen.c  -fPIC -DPIC -o .libs/dlopen.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c ltdl.c  -fPIC -DPIC -o .libs/libltdlc_la-ltdl.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c lt_dlloader.c  -fPIC -DPIC -o .libs/libltdlc_la-lt_dlloader.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c lt__alloc.c -o libltdlc_la-lt__alloc.o >/dev/null 2>&1
libtool: compile:  gcc -DHAVE_CONFIG_H -I. "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c loaders/dlopen.c -o dlopen.o >/dev/null 2>&1
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c lt_error.c -o libltdlc_la-lt_error.o >/dev/null 2>&1
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c lt_dlloader.c -o libltdlc_la-lt_dlloader.o >/dev/null 2>&1
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c loaders/preopen.c -o libltdlc_la-preopen.o >/dev/null 2>&1
/bin/bash ./libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  -DLTDLOPEN=libltdlc -DLT_CONFIG_H='<config.h>' -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -o libltdlc_la-slist.lo `test -f 'slist.c' || echo './'`slist.c
/bin/bash ./libtool --tag=CC   --mode=link gcc  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -module -avoid-version -Wl,-z,relro -Wl,-z,now -o dlopen.la  dlopen.lo  
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c slist.c  -fPIC -DPIC -o .libs/libltdlc_la-slist.o
libtool: link: ar cru .libs/dlopen.a .libs/dlopen.o 
ar: `u' modifier ignored since `D' is the default (see `U')
libtool: link: ranlib .libs/dlopen.a
libtool: link: ( cd ".libs" && rm -f "dlopen.la" && ln -s "../dlopen.la" "dlopen.la" )
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c slist.c -o libltdlc_la-slist.o >/dev/null 2>&1
ranlib prbase.a
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -DLTDLOPEN=libltdlc "-DLT_CONFIG_H=<config.h>" -DLTDL -I. -I. -Ilibltdl -I./libltdl -I./libltdl -Wdate-time -D_FORTIFY_SOURCE=2 -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c ltdl.c -o libltdlc_la-ltdl.o >/dev/null 2>&1
/bin/bash ./libtool --tag=CC   --mode=link gcc  -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -no-undefined -dlpreopen dlopen.la  -Wl,-z,relro -Wl,-z,now -o libltdlc.la  libltdlc_la-preopen.lo libltdlc_la-lt__alloc.lo libltdlc_la-lt_dlloader.lo libltdlc_la-lt_error.lo libltdlc_la-ltdl.lo libltdlc_la-slist.lo  
libtool: link: rm -f .libs/libltdlc.nm .libs/libltdlc.nmS .libs/libltdlc.nmT
libtool: link: (cd .libs && gcc -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -fcf-protection -c -fno-builtin  -fPIC -DPIC "libltdlcS.c")
libtool: link: rm -f ".libs/libltdlcS.c" ".libs/libltdlc.nm" ".libs/libltdlc.nmS" ".libs/libltdlc.nmT"
libtool: link: (cd .libs/libltdlc.lax/dlopen.a && ar x "/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib/libltdl/./.libs/dlopen.a")
libtool: link: ar cru .libs/libltdlc.a .libs/libltdlc_la-preopen.o .libs/libltdlc_la-lt__alloc.o .libs/libltdlc_la-lt_dlloader.o .libs/libltdlc_la-lt_error.o .libs/libltdlc_la-ltdl.o .libs/libltdlc_la-slist.o .libs/libltdlcS.o  .libs/libltdlc.lax/dlopen.a/dlopen.o 
ar: `u' modifier ignored since `D' is the default (see `U')
libtool: link: ranlib .libs/libltdlc.a
libtool: link: rm -fr .libs/libltdlc.lax
libtool: link: ( cd ".libs" && rm -f "libltdlc.la" && ln -s "../libltdlc.la" "libltdlc.la" )
make[5]: Leaving directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib/libltdl'
make[4]: Leaving directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib/libltdl'
make[3]: Leaving directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg/lib'
make[2]: Leaving directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg'
dh_auto_build: error: make -j8 returned exit code 2
make[1]: *** [debian/rules:74: override_dh_auto_build] Error 25
make[1]: Leaving directory '/build/reproducible-path/proftpd-dfsg-1.3.8.c+dfsg'
make: *** [debian/rules:63: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 17 Feb 2025 17:48:48 +0000

Thank you for filing a new Bug report with Debian.

You can follow progress on this Bug here: 1097654: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1097654.

This is an automatically generated reply to let you know your message
has been received.

Your message has been forwarded to the package maintainers (but not
other interested parties, as you requested) for their attention; they
will reply in due course.

Your message has been sent to the package maintainer(s):
 ProFTPD Maintainance Team <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1097654: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1097654
Debian Bug Tracking System
Contact [email-masked] with problems

---

From: Hilmar Preusse <[email-masked]>
Date: Tue, 18 Feb 2025 09:40:44 +0100

Control: tags -1 + fixed-upstream

On 17.02.25 Matthias Klose ([email-masked]) wrote:

Hello,

> severity of this report will be raised before the forky release.

The issue is solved in the upcoming proftp 1.3.9. Tagging.

H.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Tue, 18 Feb 2025 08:45:03 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Sun, 16 Mar 2025 11:39:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the src:proftpd-dfsg package:

#1097654: proftpd-dfsg: ftbfs with GCC-15

It has been closed by Debian FTP Masters <[email-masked]> (reply to Hilmar Preuße <[email-masked]>).

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Debian FTP Masters <[email-masked]> (reply to Hilmar Preuße <[email-masked]>) by
replying to this email.

Subject: Bug#1097654: fixed in proftpd-dfsg 1.3.9~dfsg-1
From: Debian FTP Masters <[email-masked]>
To: [email-masked]
Date: Sun, 16 Mar 2025 11:35:44 +0000

Source: proftpd-dfsg
Source-Version: 1.3.9~dfsg-1
Done: Hilmar Preuße <[email-masked]>

We believe that the bug you reported is fixed in the latest version of
proftpd-dfsg, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Hilmar Preuße <[email-masked]> (supplier of updated proftpd-dfsg package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 16 Mar 2025 12:19:02 +0100
Source: proftpd-dfsg
Architecture: source
Version: 1.3.9~dfsg-1
Distribution: experimental
Urgency: medium
Maintainer: ProFTPD Maintainance Team <[email-masked]>
Changed-By: Hilmar Preuße <[email-masked]>
Closes: 1097654
Changes:
 proftpd-dfsg (1.3.9~dfsg-1) experimental; urgency=medium
 .
   * New upstream version.
     - Refresh / Disable patches.
     - Do not install docs, which do not exist any more.
     - Can be built using gcc-15 (Closes: #1097654).
   * Add openssl-provider-fips to B-D.
Checksums-Sha1:
 4e18c1189ad159bfc732643b6ef4f38b746775ce 3380 proftpd-dfsg_1.3.9~dfsg-1.dsc
 3de5054d07351c306407257352357443ea1f4198 19530464 proftpd-dfsg_1.3.9~dfsg.orig.tar.gz
 1d5cd61dcd9d6ebec7fe3a30f1f34e368c9427d5 79648 proftpd-dfsg_1.3.9~dfsg-1.debian.tar.xz
 115dd114dd83ff2e1cedd6efbcba3c19f6756bc1 5929 proftpd-dfsg_1.3.9~dfsg-1_source.buildinfo
Checksums-Sha256:
 3423f2f07fb603a9580447bd39a75ced4a92d7892b4492a01ab5ca5ce1a1ca9f 3380 proftpd-dfsg_1.3.9~dfsg-1.dsc
 639427cb4566e1d337b6a406cdb8c555c81277a53b019c58b847a75a602e19d3 19530464 proftpd-dfsg_1.3.9~dfsg.orig.tar.gz
 4eb06efb1677bd9be6b14ddff7638efdfd6e5a91b74cc5d5eb6932a6c30d5c2c 79648 proftpd-dfsg_1.3.9~dfsg-1.debian.tar.xz
 a2094640f551f76bb2be6c6d237a959dc4e444ba2c5e26cde7f4c910c08a2ae1 5929 proftpd-dfsg_1.3.9~dfsg-1_source.buildinfo
Files:
 b9a8981a385c74b0a19097d1e1cba1ea 3380 net optional proftpd-dfsg_1.3.9~dfsg-1.dsc
 b0e2d3c9b32415368afda705a9997724 19530464 net optional proftpd-dfsg_1.3.9~dfsg.orig.tar.gz
 8a0e4c26753fa42700344a18d6690277 79648 net optional proftpd-dfsg_1.3.9~dfsg-1.debian.tar.xz
 32e09155d1c15ce2e16431df35c098e1 5929 net optional proftpd-dfsg_1.3.9~dfsg-1_source.buildinfo

Subject: proftpd-dfsg: ftbfs with GCC-15
From: Matthias Klose <[email-masked]>
To: [email-masked]
Date: Mon, 17 Feb 2025 17:46:03 +0000

[...]
fi