Subject: docbook-dsssl: Graphic by entity reference?

From: Ian Zimmerman <[email-masked]>
Date: 02 Apr 2003 18:39:46 -0800

Package: docbook-dsssl
Version: 1.77-cvs.2003.02.06

This seems to be broken currently.

Here's my document:

Make up any valid little bit of TeX to go to spliteq.tex, process with
the jadetex backend.  It works.

Now change this

<graphic fileref="spliteq.tex" format="tex">

into this

<graphic entityref="spliteq">

and watch it crash and burn.

-- 
"This is the patent age of new inventions
For killing bodies, and for saving souls,
All propagated with the best intentions." 
George Gordon, lord Byron

---

From: Ian Zimmerman <[email-masked]>
Date: 02 Apr 2003 20:20:05 -0800

And here's a patch:

*** /usr/share/sgml/docbook/stylesheet/dsssl/modular/print/dbgraph.dsl	Thu Feb  6 15:57:02 2003
--- /home/itz/dbgraph.dsl	Wed Apr  2 20:17:14 2003
***************
*** 58,67 ****
  	(if (equal? format (normalize "linespecific"))
  	    (if fileref
  		(include-file fileref)
! 		(include-file (entity-generated-system-id entityref)))
  	    (if fileref
  		($graphic$ fileref display format scale align)
! 		($graphic$ (entity-generated-system-id entityref)
  			   display format scale align)))
  	(empty-sosofo))))
  
--- 58,67 ----
  	(if (equal? format (normalize "linespecific"))
  	    (if fileref
  		(include-file fileref)
! 		(include-file (entity-system-id entityref)))
  	    (if fileref
  		($graphic$ fileref display format scale align)
! 		($graphic$ (entity-system-id entityref)
  			   display format scale align)))
  	(empty-sosofo))))

(I have not yet checked if there's a similar problem with the
SGML/HTML backend.)