Subject: Re: Bug#553354: diff: shouldn't be marked as essential ...

From: Daniel Hartwig <[email-masked]>
Date: Fri, 16 Dec 2011 19:30:54 +0800

forcemerge 216768 553354
affects 216768 + aptitude
thanks

`aptitude show' and `aptitude search ~e' both determine essential by:

  pkg->Flags & pkgCache::Flag::Essential

These flags are shared by *all* versions of a package.  If one version
is marked essential in it's control file, then all are considered
essential by apt and aptitude.

In the case of this bug, `diff' was essential in lenny but not in
squeeze (now a transitional package).

This is actually a long-standing issue in apt; merged.

---

From: Daniel Hartwig <[email-masked]>
Date: Fri, 16 Dec 2011 19:37:25 +0800

reassign 553354 apt
forcemerge 216768 553354

---

From: Daniel Hartwig <[email-masked]>
Date: Fri, 16 Dec 2011 19:42:17 +0800

tags 216768 - unreproducible