Subject: Bug#243908: marked as done (',' in write() obscures 'Illegal invocation' reporting.)

From: [email-masked] (Debian Bug Tracking System)

Your message dated Fri, 16 Apr 2004 13:17:21 -0400
with message-id <[email-masked]>
and subject line Bug#243908: fixed in mailman 2.1.4-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 15 Apr 2004 14:04:23 +0000

---

From: martin f krafft <[email-masked]>
Date: Thu, 15 Apr 2004 16:03:56 +0200

Package: mailman
Version: 2.1.4-3
Severity: normal

For simple lists, postfix-to-mailman.py works out of the box.
However, I with nested lists, the scripts seems to fail at the very
bottom. Postfix will defer the message with the following reason:

  temporary failure. Command output: exceptions.TypeError function
  takes exactly 1 argument (2 given) Line 147

Thus, for now, I have to switch back to using the alias method.

Thanks for fixing this.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (600, 'testing'), (98, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.3-1-k7-smp
Locale: LANG=en_GB.ISO-8859-15, LC_CTYPE=de_DE.ISO-8859-15

Versions of packages mailman depends on:
ii  apache [httpd]              1.3.29.0.2-4 Versatile, high-performance HTTP s
ii  cron                        3.0pl1-72    management of regular background p
ii  debconf                     1.4.21       Debian configuration management sy
ii  libc6                       2.3.2.ds1-11 GNU C Library: Shared libraries an
ii  logrotate                   3.5.9-8      Log rotation utility
ii  postfix [mail-transport-age 2.0.19-1     A high-performance mail transport
ii  pwgen                       2.03-1       Automatic Password generation
ii  python                      2.3.3-7      An interactive high-level object-o
ii  ucf                         1.00         Update Configuration File: preserv

-- 
Please do not CC me when replying to lists; I read them!
 
 .''`.     martin f. krafft <[email-masked]>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
 
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!

---

From: Siggy Brentrup <[email-masked]>
Date: Fri, 16 Apr 2004 13:17:21 -0400

Source: mailman
Source-Version: 2.1.4-4

We believe that the bug you reported is fixed in the latest version of
mailman, which is due to be installed in the Debian FTP archive:

mailman_2.1.4-4.diff.gz
  to pool/main/m/mailman/mailman_2.1.4-4.diff.gz
mailman_2.1.4-4.dsc
  to pool/main/m/mailman/mailman_2.1.4-4.dsc
mailman_2.1.4-4_i386.deb
  to pool/main/m/mailman/mailman_2.1.4-4_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Siggy Brentrup <[email-masked]> (supplier of updated mailman package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.7
Date: Fri, 16 Apr 2004 18:40:38 +0200
Source: mailman
Binary: mailman
Architecture: source i386
Version: 2.1.4-4
Distribution: unstable
Urgency: medium
Maintainer: Tollef Fog Heen <[email-masked]>
Changed-By: Siggy Brentrup <[email-masked]>
Description: 
 mailman    - Powerful, web-based mailing list manager
Closes: 224319 235667 235835 242945 243209 243908
Changes: 
 mailman (2.1.4-4) unstable; urgency=medium
 .
   * Urgency medium because RC bugs are fixed.
   * Fix README.Debian concerning URLs (bsb, closes: #235835).
   * Add fix for missing installation of Danish templates (by GCS)
   * config: don't try to list_lists when upgrading from pre 2.1
     (bsb, closes: #242945).
   * Fix Woody FTBFS, reported and solution provided by Andreas Barth
     <[email-masked]>, (by GCS, closes: #243209).
   * Ask for the language used by Mailman from the enabled languages
     (by GCS, closes: #224319).
   * postfix-to-mailman.py: Fix ',' obscuring illegal invocations, reported
     by martin f krafft <[email-masked]> (bsb, closes: #243908)
   * Update SpamAssassin handler to the most recent version can be found,
     and document it in README.Debian (by GCS, closes: #235667).
Files: 
 fabb8fa91fcc84130e1d050a1b5a34a0 639 mail optional mailman_2.1.4-4.dsc
 4287aac715872ae64ceaf1296799bb9c 56714 mail optional mailman_2.1.4-4.diff.gz
 7a851b85a104ee9d7cacd05767b1cd51 6293426 mail optional mailman_2.1.4-4_i386.deb