Subject: muttprint: Fail to print due to a uninitialized value

From: Vincent Fourmond <[email-masked]>
Date: Tue, 20 Apr 2004 10:47:13 +0200

Package: muttprint
Version: 0.72-3
Severity: normal

  The printing if the mails fails due to a die on line 1730 (logging) obviously due to an 
unitialized variable (the name of the log file). I don't know if it could come from the fact 
that I'm printing from within pine.

  Thanks for considering this report

	Vincent Fourmond

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.0
Locale: LANG=C, LC_CTYPE=C

Versions of packages muttprint depends on:
ii  debconf [debconf-2.0]         1.4.22     Debian configuration management sy
ii  perl                          5.8.3-3    Larry Wall's Practical Extraction 
ii  tetex-extra                   2.0.2-6    Additional library files of teTeX

-- debconf information excluded

---

From: Bernhard Walle <[email-masked]>
Date: Tue, 20 Apr 2004 21:22:47 +0200

Hello,

>   Thanks for considering this report

try following: 

Create a file "test.mail":

,----[ test.mail ]-
| From test
| From: Test <[email-masked]>
| To: Test2 <[email-masked]>
| Subject: Subject
| 
| Test
| 
`----

Try 
        
  $ muttprint -f test.mail

Regards,
Bernhard

---

From: Vincent Fourmond <[email-masked]>
Date: Wed, 21 Apr 2004 09:10:09 +0200 (CEST)

Hello

> > that I'm printing from within pine.

  The funny thing is that it actually does work today, after the second
reinstall (because as I needed to print something yesterday, I downgraded
back to 0.71 - and I switched back today to 0.72). Could this be a
packaging-related problem ?

  The line that was incriminated was line 1730:

open (LFILE, ">>$Temp{logf}") or die "Could not open $Temp{logf}";

  And the reason was that $Temp{logf} was empty (message was "Could not
open "). Now I don't understand why today it's working back again. To be
truthfull, as $Temp{logf} seems to be properly initialized, I'm really
puzzled.

  Well, no trouble, if you ever find something one day about this, let me
know, if you don't, that doesn't really matter, since now I can use it
again. By the way, let me thank you, I find this muttprint really great !

	Vincent Fourmond