Subject: Bug#250751: marked as done (GLib-GObject-WARNING **: g_object_set_valist: construct property "sm-connect" for object `GnomeProgram' can't be set)

From: [email-masked] (Debian Bug Tracking System)

Your message dated Tue, 01 Jun 2004 14:18:53 +0200
with message-id <1086092333.27689.0.camel@localhost>
and subject line Went away
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 24 May 2004 18:53:09 +0000

---

From: Thomas Hood <[email-masked]>
Date: Mon, 24 May 2004 20:53:01 +0200

Package: debconf
Version: 1.4.25
Severity: normal

When I install packages or run dpkg-reconfigure I get messages like these:

GLib-GObject-WARNING **: g_object_set_valist: construct property "sm-connect" for object `GnomeProgram' can't be set after construction at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 47.

I just tried dpkg-reconfiguring a package.  After getting this message
(twice, with different line numbers) I _do_ get a GNOME debconf window
which seems to function correctly, so this may not be a serious problem.

I'm not sure that this is debconf's fault.  Please reassign if necessary.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (800, 'testing'), (700, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.4.25
Locale: LANG=en_IE@euro, LC_CTYPE=en_IE@euro

Versions of packages debconf depends on:
ii  debconf-i18n                  1.4.25     full internationalization support 
ii  perl-base                     5.8.3-3    The Pathologically Eclectic Rubbis

-- debconf information:
* debconf/priority: low
* debconf/frontend: Gnome

---------------------------------------
Received: (at 250751-done) by bugs.debian.org; 1 Jun 2004 12:19:04 +0000

---

From: Thomas Hood <[email-masked]>
Date: Tue, 01 Jun 2004 14:18:53 +0200

This problem went away after I upgraded some GNOME packages.
--
Thomas