Subject: Add a modality to check for a package dir _before_ doing the build

From: Enrico Zini <[email-masked]>
Date: Mon, 02 Aug 2004 01:57:12 +0200

Package: lintian
Version: 1.23.2
Severity: wishlist

Hello,

It would be nice to be able to run lintian on a package directory before
running debuild, to be able to catch various trivial things such as CVS
or .svn directories left around, debian versions when no matching
.orig.tar.gz is present in the upper directory and so on.

A possibility of spotting them before the build would be very valuable
to avoid spending long time waiting for the build to discover that a
.svn dir has left around or that I forgot to generate the .orig.tar.gz
and restart the build again.

Bye,

Enrico

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.6.7-1-686-smp
Locale: LANG=it_IT@euro, LC_CTYPE=it_IT@euro

Versions of packages lintian depends on:
ii  binutils                      2.15-1     The GNU assembler, linker and bina
ii  diffstat                      1.34-1     produces graph of changes introduc
ii  file                          4.10-3     Determines file type using "magic"
ii  gettext                       0.14.1-5   GNU Internationalization utilities
ii  man-db                        2.4.2-19   The on-line manual pager
ii  perl [libdigest-md5-perl]     5.8.4-2    Larry Wall's Practical Extraction 

-- no debconf information

---

From: Frank Lichtenheld <[email-masked]>
Date: Mon, 2 Aug 2004 02:25:36 +0200

> and restart the build again.

You should be able to emulate this behaviour by only running
dpkg-source -b and then calling lintian on the resulting source
package.

Interesting idea, though. Let's see what we can do :)

Gruesse,
-- 
Frank Lichtenheld <[email-masked]>
www: http://www.djpig.de/