Subject: i386 serial console installation report

From: [email-masked] (Geert Stappers)
Date: Fri, 1 Oct 2004 22:27:53 +0200

Package: installation-reports
Version: ~/joeyh/dailybuild/i386/netboot/ 30 september 2004
Severity: wishlist

Hello,

A netboot install on a i386 with serial console went mostly fine.

Here is my feedback:

* Had to use the newt frontend, but that is not funny on serial line.
Please include cdebconf-text-udeb, to make DEBIAN_FRONTEND=text possible.

* to get a nice behaving base-config [1]
You have to install the libterm-readline-gnu-perl package
in the target chroot and `dpkg-reconfigure debconf` to set readline.
Do that in a shell before reboot into second stage.[2]

* No kernel messages and no grub menu is shown on the serial console.
With this patch on /boot/grub/menu.lst it does.
diff -u -r2.0 menu.lst
--- menu.lst    2004/10/01 19:07:54     2.0
+++ menu.lst    2004/10/01 19:12:45
@@ -17,7 +17,7 @@
 timeout                5

 # Pretty colours
-color cyan/blue white/blue
+#color cyan/blue white/blue

 ## password ['--md5'] passwd
 # If used in the first section of a menu file, disable all interactive editing
@@ -84,18 +84,21 @@
 ##      howmany=7
 # howmany=all

+serial --unit=0 --speed=9600 --word=8 --parity=no --stop=1
+terminal --timeout=5 serial console
+
 ## ## End Default Options ##

 title          Debian GNU/Linux, kernel 2.4.27-1-686
 root           (hd0,0)
-kernel         /boot/vmlinuz-2.4.27-1-686 root=/dev/hda1 ro
+kernel         /boot/vmlinuz-2.4.27-1-686 root=/dev/hda1 ro console=ttyS0,9600n8
 initrd         /boot/initrd.img-2.4.27-1-686
 savedefault
 boot

 title          Debian GNU/Linux, kernel 2.4.27-1-686 (recovery mode)
 root           (hd0,0)
-kernel         /boot/vmlinuz-2.4.27-1-686 root=/dev/hda1 ro single
+kernel         /boot/vmlinuz-2.4.27-1-686 root=/dev/hda1 ro single console=ttyS0,9600n8
 initrd         /boot/initrd.img-2.4.27-1-686
 savedefault
 boot

Geert Stappers

[1] it doesn't shown the default in the menus, neither selections.
[2] no need to implement this in the program source code.

---

From: Joey Hess <[email-masked]>
Date: Fri, 1 Oct 2004 18:23:11 -0400

> Please include cdebconf-text-udeb, to make DEBIAN_FRONTEND=text possible.

I'd considered adding this anyway before for i386, so I have.

> [1] it doesn't shown the default in the menus, neither selections.

The default behavior of debconf here is not ideal, but unfortunatly cannot be
easily improved with perl's built in read line library:

  * readline and teletype frontends do not display default in brackets,
    and do not special case empty string as the default. It's more important
    that the user be able to enter an empty string reliably. Default values
    are still provided if Term::Readline::Gnu is installed. Closes: #183970

So basically, there _is_ no default with the configuration you set up.

> With this patch on /boot/grub/menu.lst it does.

I suppose I'll reassign this report to grub-installer, though we already have
#224641. What we really need is a tested grub-installer patch..

-- 
see shy jo

---

From: [email-masked] (Geert Stappers)
Date: Sat, 2 Oct 2004 09:30:59 +0200

> I'd considered adding this anyway before for i386, so I have.
Nice! TNX

> So basically, there _is_ no default with the configuration you set up.

I have the feeling that we are talking about different things.

With "it doesn't shown the default in the menus, neither selections."
I mean base-config, with newt frontend on a serial console,
doesn't show what will happen when 'enter' is pressed.

Clearification:
 Partman leaves the cursor at the no, pressing 'tab' puts cursor at the yes

 "system clock GMT" yes no        but no cursor nor other mark,
 pressing 'tab' redraws the screen, but no "you choose this sign"

> #224641. What we really need is a tested grub-installer patch..

Acknowledge.

Cheers
Geert Stappers

---

From: Joey Hess <[email-masked]>
Date: Sat, 2 Oct 2004 11:59:04 -0400

> doesn't show what will happen when 'enter' is pressed.

There is no default. If you press enter it will redisplay the prompt.

>  pressing 'tab' redraws the screen, but no "you choose this sign"

Sorry, I have no idea what you're talking about? Partman? Clock
settings? Apparently whiptail? Does not match rest of report.

-- 
see shy jo

---

From: [email-masked] (Geert Stappers)
Date: Fri, 8 Oct 2004 11:33:27 +0200

> > I have the feeling that we are talking about different things.
still have ...

> > I mean base-config, with newt frontend on a serial console,
                             ^^^^
> settings? Apparently whiptail? Does not match rest of report.

 http://www.stappers.nl/gst/screenshots/d-i/yesorno.png

has what I see: No cursor no other mark show the default.

Geert Stappers