Subject: Bug#289892: amavisd-new: Actually, use this logrotate config instead

From: Micah Anderson <[email-masked]>
Date: Tue, 11 Jan 2005 09:21:26 -0800

Package: amavisd-new
Version: 20030616p10-5
Followup-For: Bug #289892

This one is better in my opinion:

/var/log/amavis.log {
        rotate 3
        compress
        create 600 amavis amavis
        missingok
        copytruncate
        notifempty
}

Thanks!
Micah
												
-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.7
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages amavisd-new depends on:
ii  adduser                       3.59       Add and remove users and groups
ii  file                          4.12-1     Determines file type using "magic"
ii  libarchive-tar-perl           1.22-1     Archive::Tar - manipulate tar file
ii  libarchive-zip-perl           1.14-1     Module for manipulation of ZIP arc
ii  libcompress-zlib-perl         1.33-3     Perl module for creation and manip
ii  libconvert-tnef-perl          0.17-4     Perl module to read TNEF files
ii  libconvert-uulib-perl         1.0.3-2    Perl interface to the uulib librar
pn  libdigest-md5-perl                       Not found.
ii  libmailtools-perl             1.62-1     Manipulate email in perl programs
pn  libmime-base64-perl                      Not found.
ii  libmime-perl                  5.415-1    Perl5 modules for MIME-compliant m
ii  libnet-perl                   1:1.19-1   Implementation of Internet protoco
ii  libnet-server-perl            0.87-2     An extensible, general perl server
ii  libunix-syslog-perl           0.100-4    Perl interface to the UNIX syslog(
ii  perl [libtime-hires-perl]     5.8.4-5    Larry Wall's Practical Extraction 
ii  perl-modules [libnet-perl]    5.8.4-5    Core Perl modules

-- no debconf information

---

From: Brian May <[email-masked]>
Date: Wed, 19 Jan 2005 09:12:44 +1100

severity 258387 wishlist
merge 258387 289892
thanks

Hello,

As explained in bug 289892, (see <URL:http://bugs.debian.org/289892>),
amavisd-new doesn't create a amavis.log file in the default debian
installation, and rotating a file that doesn't exist seems silly.

If you disagree please let me know why.

Thanks.
-- 
Brian May <[email-masked]>