Subject: dump: please add -quiet option

From: A Mennucc <[email-masked]>
Date: Wed, 19 Oct 2005 10:12:52 +0200

Package: dump
Version: 0.4b37-1
Severity: wishlist

hi

I run (through cron.daily) a nightly backup of this form
  dump -0 /home -f - | ssh remotehost "dd of=homebackup"

Each day I receive a long email with all details of what dump did;
I would appreciate if there was a wait to quiet dump 

I am not willing to do 
  dump -0 /home -f - 2> /dev/null | ssh remotehost "dd of=homebackup"
because I would then not receive errors (if any) in dumping the fs

The best would be a -quiet option so that
  dump -0 /home -f -  -quiet | ssh remotehost "dd of=homebackup"
would silently do its job and only report errors (if any)

thanks

a.

-- System Information:
Debian Release: 3.1
Architecture: i386 (i686)
Kernel: Linux 2.6.12-1-k7
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages dump depends on:
ii  debconf                     1.4.30.13    Debian configuration management sy
ii  e2fslibs                    1.37-2sarge1 ext2 filesystem libraries
ii  libblkid1                   1.37-2sarge1 block device id library
ii  libc6                       2.3.5-6      GNU C Library: Shared libraries an
ii  libcomerr2                  1.37-2sarge1 common error description library
ii  libncurses5                 5.4-4        Shared libraries for terminal hand
ii  libreadline4                4.3-11       GNU readline and history libraries
ii  libuuid1                    1.37-2sarge1 universally unique id library
ii  tar                         1.14-2       GNU tar

-- debconf information excluded

-- 
Andrea Mennucc
 "Ukn ow,Ifina llyfixe dmysp acebar.ohwh atthef"

---

From: Bdale Garbee <[email-masked]>
Date: Wed, 19 Oct 2005 07:33:18 -0600

> I would appreciate if there was a wait to quiet dump 

The approach taken by most backup systems (like amanda, bacula, etc)
that wrap invocations of dump, tar, etc., is to redirect stdout/stderr
to a log file, and then post-process the log file.

Bdale

---

From: [email-masked] (A Mennucc)
Date: Wed, 19 Oct 2005 16:21:25 +0200

> to a log file, and then post-process the log file.

yes, I thought of it, I will probably change my code to 
  dump -f -  2> dumplog | ssh backuphost 'dd of=backup'
  egrep -v 'blah|blah' dumplog
 
Still a -quiet option would be much nicer... 
indeed,  in the above approach, if I run my script interactively,
I will not see error messages  until dump is done 

unfortunately shell code does not admit "double pipes", that is , 
some magic code looking like
   dump -f -   \
    1>|  { ssh backuphost 'dd of=backup' ; }
    2>|  { egrep -v 'blah|blah'  ; } 
where two pipes are opened at the same time, for fd 1 and fd 2
(that would be cool... I will open a wishlist on bash  :-)

a.

ps: I use my backup system on 6 different PCs, that is why I am annoyed
 by the emails... I am now annoyed by the dump blah blah, and 
 I do not read the emails, so I may skip some other important cron messages

ps2: you may wonder why I do not use amanda/bakula/etc :
 I started writing my backup scripts some years ago, then they improved
 in the years, and they do the job very well for me

---

From: wieseltux23 <[email-masked]>
Date: Thu, 20 Oct 2005 17:15:42 +0200

> in the years, and they do the job very well for me
TRY IT!! https://www.scientificlinux.org/