Subject: mp3blaster: segfaults with aoss after pausing

From: Alexander Heinlein <[email-masked]>
Date: Thu, 12 Oct 2006 10:16:51 +0200

Package: mp3blaster
Version: 1:3.2.3-1
Severity: normal

Hi. When using mp3blaster with alsa-oss, it segfaults after pausing the
current song.

Maybe this is in relation with #220633 or #321443.

Alexander Heinlein

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (700, 'unstable'), (650, 'testing'), (600, 'stable'), (400, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)

Versions of packages mp3blaster depends on:
ii  libc6                        2.3.6.ds1-6 GNU C Library: Shared libraries
ii  libgcc1                      1:4.1.1-16  GCC support library
ii  libncurses5                  5.5-4       Shared libraries for terminal hand
ii  libsidplay1                  1.36.59-4   SID (MOS 6581) emulation library
ii  libstdc++6                   4.1.1-16    The GNU Standard C++ Library v3
ii  libvorbis0a                  1.1.2-1     The Vorbis General Audio Compressi
ii  libvorbisfile3               1.1.2-1     The Vorbis General Audio Compressi

mp3blaster recommends no packages.

-- debconf-show failed

---

From: Gerfried Fuchs <[email-masked]>
Date: Wed, 1 Aug 2007 16:35:26 +0200

severity 392551 important
thanks

> Hi. When using mp3blaster with alsa-oss, it segfaults after pausing the

 I can pretty well reproduce this and was about to file a bugreport
 about it.  I'm using powerpc, so it can't really be arch specific.

> Maybe this is in relation with #220633 or #321443.

 The latter sounds like, the former is something different.  I can
reproduce it with doing this:

 $> aoss mp3blaster
 <F1>
 <enter on any mp3>
 5
 Segfault

 Please notice that it doesn't happen to me when I am pausing an ogg
file, this seems to be only related to mp3 files for me (tried about 10
different ogg and mp3 files).  Furthermore, when I tried to strace for
the problem and added the -f switch for following forks, the Segfault
went away.

 I really would like to see this problem fixed, it's quite an annoyance.

 So long,
Rhonda