Subject: linux-image-2.6.24-1-686: Same crash with same network hard disk probably, in 2.6.24

From: Olivier Berger <[email-masked]>
Date: Sun, 13 Apr 2008 16:01:12 +0200

Package: linux-image-2.6.24-1-686
Version: 2.6.24-5
Followup-For: Bug #463402

FYI, I experience similar Oops :
BUG: unable to handle kernel NULL pointer dereference at virtual address
00000010
printing eip: f105d21c *pde = 00000000 
Oops: 0002 [#1] SMP 
Modules linked in: nls_iso8859_1 cifs binfmt_misc radeon drm nfsd auth_rpcgss exportfs ppdev lp ac battery microcode nfs lockd nfs_acl sunrpc ipv6 rfcomm l2cap bluetooth reiserfs dm_crypt fuse smsc47m1 eeprom firewire_sbp2 loop bt878 tuner tea5767 tda8290 tuner_simple mt20xx tea5761 tvaudio msp3400 bttv parport_pc parport firmware_class ir_common psmouse compat_ioctl32 i2c_algo_bit serio_raw pcspkr videobuf_dma_sg videobuf_core btcx_risc rtc tveeprom videodev v4l2_common v4l1_compat snd_bt87x snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_pcm snd_mixer_oss usblp snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device container snd soundcore snd_page_alloc button i2c_sis96x i2c_core shpchp pci_hotplug sis_agp agpgart evdev usbhid hid ext3 jbd mbcache dm_mirror dm_snapshot dm_mod sg sr_mod cdrom sd_mod sis5513 generic ide_core floppy ehci_hcd firewire_ohci ohci_hcd pata_sis ata_generic firewire_core crc_itu_t tulip usbcore libata scsi_mod thermal processor fan

Pid: 4759, comm: mount.cifs Not tainted (2.6.24-1-686 #1)
EIP: 0060:[<f105d21c>] EFLAGS: 00010246 CPU: 0
EIP is at cifs_strfromUCS_le+0x50/0x5f [cifs]
EAX: 00000010 EBX: 00000000 ECX: 00000000 EDX: e6d4432e
ESI: 0000000b EDI: 00000000 EBP: 00000010 ESP: e6d43bb8
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process mount.cifs (pid: 4759, ti=e6d42000 task=df996130
task.ti=e6d42000)
Stack: 00000000 00000000 e6d4432e 00000000 0000000b e6d4432d df9f2300 f106038f 
       f0d7adc0 e6d43c38 00000010 00000001 00000001 00000000 e6d1c000 e639d240 
       e4d98300 e6d4432e c015cfd0 e6d495c0 44ac3674 8576505f 6a921331 47b2bed6 
Call Trace:
 [<f106038f>] CIFS_SessSetup+0x4ae/0x727 [cifs]
 [<c015cfd0>] mempool_free+0x6a/0x6f
 [<f104ceb1>] cifs_setup_session+0x11f/0xb3f [cifs]
 [<f104ffaf>] cifs_mount+0x191c/0x1f2c [cifs]
 [<c01ded58>] free_layer+0x11/0x29
 [<c01df17a>] idr_get_new+0xa/0x26
 [<c018a0a2>] get_filesystem+0xf/0x29
 [<f104361b>] cifs_get_sb+0xa2/0x18f [cifs]
 [<c017a101>] vfs_kern_mount+0x7f/0xf6
 [<c017a1c1>] do_kern_mount+0x35/0xbb
 [<c018ba0e>] do_mount+0x5d8/0x63a
 [<c0168068>] handle_mm_fault+0x252/0x685
 [<c018a5cc>] copy_mount_options+0x90/0x109
 [<c011bf41>] do_page_fault+0x1f7/0x592
 [<c016a1dd>] vma_adjust+0x323/0x39e
 [<c02bdd4a>] error_code+0x72/0x78
 [<c02b00d8>] unix_detach_fds+0x1f/0x36
 [<c018a5cc>] copy_mount_options+0x90/0x109
 [<c018bae7>] sys_mount+0x77/0xae
 [<c0103e5e>] sysenter_past_esp+0x6b/0xa1
 =======================
Code: b9 06 00 00 00 ff 56 08 85 c0 7e 04 01 c3 eb 07 8b 04 24 43 c6 00 3f 47 3b 7c 24 04 7d 0d 8b 54 24 08 66 8b 04 7a 66 85 c0 75 c7 <c6> 44 1d 00 00 89 d8 83 c4 0c 5b 5e 5f 5d c3 55 31 ed 57 89 cf 
EIP: [<f105d21c>] cifs_strfromUCS_le+0x50/0x5f [cifs] SS:ESP 0068:e6d43bb8
---[ end trace 00cb9090446d1e5d ]---

Hope this helps.

Best regards

-- Package-specific info:
** Version:
Linux version 2.6.24-1-686 (Debian 2.6.24-5) ([email-masked]) (gcc version 4.1.3 20080308 (prerelease) (Debian 4.1.2-21)) #1 SMP Thu Mar 27 17:45:04 UTC 2008

** Command line:
root=/dev/sda1 ro noapic 

** Tainted: G (128)

** Kernel log:
tuner 1-0061: type set to Philips (SECAM+PAL_
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: registered device radio0
bttv0: PLL: 28636363 => 35468950 .. ok
bt878: AUDIO driver version 0.0.0 loaded
Adding 1534136k swap on /dev/sda5.  Priority:-1 extents:1 across:1534136k
EXT3 FS on sda1, internal journal
loop: module loaded
smsc47m1: Found SMSC LPC47M10x/LPC47M112/LPC47M13x
smsc47m1 smsc47m1.2048: Device not configured, will not use
fuse init (API version 7.9)
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on dm-0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
ReiserFS: dm-3: found reiserfs format "3.6" with standard journal
ReiserFS: dm-3: using ordered data mode
ReiserFS: dm-3: journal params: device dm-3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: dm-3: checking transaction log (dm-3)
ReiserFS: dm-3: Using r5 hash to sort names
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
eth0: CSR0 01a08000
0000:00:06.0: tulip_stop_rxtx() failed (CSR5 0xfc664010 CSR6 0xff972113)
eth0: Setting full-duplex based on MII#1 link partner capability of 45e1.
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
IA-32 Microcode Update Driver: v1.14a <[email-masked]>
eth0: no IPv6 routers present
lp0: using parport0 (interrupt-driven).
ppdev: user-space parallel port driver
Installing knfsd (copyright (C) 1996 [email-masked]).
NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
NFSD: starting 90-second grace period
[drm] Initialized drm 1.1.0 20060810
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
[drm] Initialized radeon 1.28.0 20060524 on minor 0
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
[drm] Setting GART location based on new memory map
[drm] Loading R200 Microcode
[drm] writeback test succeeded in 1 usecs
 CIFS VFS: bad security option: lanman
 CIFS VFS: cifs_mount failed w/return code = -22
BUG: unable to handle kernel NULL pointer dereference at virtual address 00000010
printing eip: f105d21c *pde = 00000000 
Oops: 0002 [#1] SMP 
Modules linked in: nls_iso8859_1 cifs binfmt_misc radeon drm nfsd auth_rpcgss exportfs ppdev lp ac battery microcode nfs lockd nfs_acl sunrpc ipv6 rfcomm l2cap bluetooth reiserfs dm_crypt fuse smsc47m1 eeprom firewire_sbp2 loop bt878 tuner tea5767 tda8290 tuner_simple mt20xx tea5761 tvaudio msp3400 bttv parport_pc parport firmware_class ir_common psmouse compat_ioctl32 i2c_algo_bit serio_raw pcspkr videobuf_dma_sg videobuf_core btcx_risc rtc tveeprom videodev v4l2_common v4l1_compat snd_bt87x snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_pcm snd_mixer_oss usblp snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device container snd soundcore snd_page_alloc button i2c_sis96x i2c_core shpchp pci_hotplug sis_agp agpgart evdev usbhid hid ext3 jbd mbcache dm_mirror dm_snapshot dm_mod sg sr_mod cdrom sd_mod sis5513 generic ide_core floppy ehci_hcd firewire_ohci ohci_hcd pata_sis ata_generic firewire_core crc_itu_t tulip usbcore libata scsi_mod thermal processor fan

Pid: 4759, comm: mount.cifs Not tainted (2.6.24-1-686 #1)
EIP: 0060:[<f105d21c>] EFLAGS: 00010246 CPU: 0
EIP is at cifs_strfromUCS_le+0x50/0x5f [cifs]
EAX: 00000010 EBX: 00000000 ECX: 00000000 EDX: e6d4432e
ESI: 0000000b EDI: 00000000 EBP: 00000010 ESP: e6d43bb8
 DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process mount.cifs (pid: 4759, ti=e6d42000 task=df996130 task.ti=e6d42000)
Stack: 00000000 00000000 e6d4432e 00000000 0000000b e6d4432d df9f2300 f106038f 
       f0d7adc0 e6d43c38 00000010 00000001 00000001 00000000 e6d1c000 e639d240 
       e4d98300 e6d4432e c015cfd0 e6d495c0 44ac3674 8576505f 6a921331 47b2bed6 
Call Trace:
 [<f106038f>] CIFS_SessSetup+0x4ae/0x727 [cifs]
 [<c015cfd0>] mempool_free+0x6a/0x6f
 [<f104ceb1>] cifs_setup_session+0x11f/0xb3f [cifs]
 [<f104ffaf>] cifs_mount+0x191c/0x1f2c [cifs]
 [<c01ded58>] free_layer+0x11/0x29
 [<c01df17a>] idr_get_new+0xa/0x26
 [<c018a0a2>] get_filesystem+0xf/0x29
 [<f104361b>] cifs_get_sb+0xa2/0x18f [cifs]
 [<c017a101>] vfs_kern_mount+0x7f/0xf6
 [<c017a1c1>] do_kern_mount+0x35/0xbb
 [<c018ba0e>] do_mount+0x5d8/0x63a
 [<c0168068>] handle_mm_fault+0x252/0x685
 [<c018a5cc>] copy_mount_options+0x90/0x109
 [<c011bf41>] do_page_fault+0x1f7/0x592
 [<c016a1dd>] vma_adjust+0x323/0x39e
 [<c02bdd4a>] error_code+0x72/0x78
 [<c02b00d8>] unix_detach_fds+0x1f/0x36
 [<c018a5cc>] copy_mount_options+0x90/0x109
 [<c018bae7>] sys_mount+0x77/0xae
 [<c0103e5e>] sysenter_past_esp+0x6b/0xa1
 =======================
Code: b9 06 00 00 00 ff 56 08 85 c0 7e 04 01 c3 eb 07 8b 04 24 43 c6 00 3f 47 3b 7c 24 04 7d 0d 8b 54 24 08 66 8b 04 7a 66 85 c0 75 c7 <c6> 44 1d 00 00 89 d8 83 c4 0c 5b 5e 5f 5d c3 55 31 ed 57 89 cf 
EIP: [<f105d21c>] cifs_strfromUCS_le+0x50/0x5f [cifs] SS:ESP 0068:e6d43bb8
---[ end trace 00cb9090446d1e5d ]---

** Loaded modules:
Module                  Size  Used by
nls_iso8859_1           4128  1 
cifs                  210132  2 
binfmt_misc            11240  1 
radeon                112096  2 
drm                    74132  3 radeon
nfsd                  203984  13 
auth_rpcgss            39744  1 nfsd
exportfs                4736  1 nfsd
ppdev                   8804  0 
lp                     11076  0 
ac                      6116  0 
battery                13572  0 
microcode              10956  0 
nfs                   228168  0 
lockd                  60744  3 nfsd,nfs
nfs_acl                 3520  2 nfsd,nfs
sunrpc                170780  11 nfsd,auth_rpcgss,nfs,lockd,nfs_acl
ipv6                  240836  33 
rfcomm                 36784  2 
l2cap                  22880  9 rfcomm
bluetooth              53636  4 rfcomm,l2cap
reiserfs              210976  1 
dm_crypt               13220  0 
fuse                   45204  1 
smsc47m1                9540  0 
eeprom                  7184  0 
firewire_sbp2          14252  0 
loop                   16804  0 
bt878                  10488  0 
tuner                  39008  0 
tea5767                 5764  1 tuner
tda8290                11172  1 tuner
tuner_simple            8040  1 tuner
mt20xx                 11624  1 tuner
tea5761                 4932  1 tuner
tvaudio                22396  0 
msp3400                28736  0 
bttv                  164692  1 bt878
parport_pc             33668  1 
parport                34280  3 ppdev,lp,parport_pc
firmware_class          9312  2 microcode,bttv
ir_common              35012  1 bttv
psmouse                36464  0 
compat_ioctl32          1408  1 bttv
i2c_algo_bit            5956  1 bttv
serio_raw               6660  0 
pcspkr                  3200  0 
videobuf_dma_sg        13380  1 bttv
videobuf_core          16740  2 bttv,videobuf_dma_sg
btcx_risc               4808  1 bttv
rtc                    13052  0 
tveeprom               14960  1 bttv
videodev               26304  1 bttv
v4l2_common            16608  5 tuner,tvaudio,msp3400,bttv,videodev
v4l1_compat            13220  2 bttv,videodev
snd_bt87x              14948  0 
snd_intel8x0           32028  1 
snd_ac97_codec         92932  1 snd_intel8x0
ac97_bus                2176  1 snd_ac97_codec
snd_pcm_oss            38272  0 
snd_pcm                71780  4 snd_bt87x,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_mixer_oss          15296  1 snd_pcm_oss
usblp                  14016  0 
snd_seq_dummy           3780  0 
snd_seq_oss            29472  0 
snd_seq_midi            8160  0 
snd_rawmidi            22624  1 snd_seq_midi
snd_seq_midi_event      6976  2 snd_seq_oss,snd_seq_midi
snd_seq                46544  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              21092  2 snd_pcm,snd_seq
snd_seq_device          7820  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
container               4864  0 
snd                    48612  13 snd_bt87x,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               7552  1 snd
snd_page_alloc         10056  3 snd_bt87x,snd_intel8x0,snd_pcm
button                  8432  0 
i2c_sis96x              5092  0 
i2c_core               22432  13 eeprom,tuner,tea5767,tda8290,tuner_simple,mt20xx,tea5761,tvaudio,msp3400,bttv,i2c_algo_bit,tveeprom,i2c_sis96x
shpchp                 31028  0 
pci_hotplug            27712  1 shpchp
sis_agp                 9060  1 
agpgart                31688  2 drm,sis_agp
evdev                  11104  5 
usbhid                 28096  0 
hid                    34272  1 usbhid
ext3                  122888  4 
jbd                    43732  1 ext3
mbcache                 8288  1 ext3
dm_mirror              21600  0 
dm_snapshot            16964  0 
dm_mod                 55812  12 dm_crypt,dm_mirror,dm_snapshot
sg                     33264  0 
sr_mod                 16708  0 
cdrom                  32512  1 sr_mod
sd_mod                 27200  4 
sis5513                 7556  0 [permanent]
generic                 4388  0 [permanent]
ide_core              108292  2 sis5513,generic
floppy                 54628  0 
ehci_hcd               32524  0 
firewire_ohci          17760  0 
ohci_hcd               21988  0 
pata_sis               13860  4 
ata_generic             7428  0 
firewire_core          39232  2 firewire_sbp2,firewire_ohci
crc_itu_t               2176  1 firewire_core
tulip                  49600  0 
usbcore               132940  5 usblp,usbhid,ehci_hcd,ohci_hcd
libata                144464  2 pata_sis,ata_generic
scsi_mod              141164  5 firewire_sbp2,sg,sr_mod,sd_mod,libata
thermal                16028  0 
processor              36520  1 thermal
fan                     4772  0 

** PCI devices:
00:00.0 Host bridge [0600]: Silicon Integrated Systems [SiS] SiS645DX Host & Memory & AGP Controller [1039:0646]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
	Latency: 64
	Region 0: Memory at ec000000 (32-bit, non-prefetchable) [size=64M]
	Capabilities: <access denied>
	Kernel driver in use: agpgart-sis
	Kernel modules: sis-agp

00:01.0 PCI bridge [0604]: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP) [1039:0001] (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=70
	I/O behind bridge: 00009000-00009fff
	Memory behind bridge: f0100000-f01fffff
	Prefetchable memory behind bridge: f4000000-fbffffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA+ MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Kernel modules: shpchp

00:02.0 ISA bridge [0601]: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] [1039:0962] (rev 04)
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0

00:02.1 SMBus [0c05]: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller [1039:0016]
	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin B routed to IRQ 0
	Region 4: I/O ports at 8100 [size=32]
	Kernel driver in use: sis96x_smbus
	Kernel modules: i2c-sis96x

00:02.5 IDE interface [0101]: Silicon Integrated Systems [SiS] 5513 [IDE] [1039:5513] (prog-if 80 [Master])
	Subsystem: Silicon Integrated Systems [SiS] SiS5513 EIDE Controller (A,B step) [1039:5513]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 128
	Interrupt: pin ? routed to IRQ 11
	Region 0: [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
	Region 1: [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
	Region 2: [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
	Region 3: [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
	Region 4: I/O ports at 2000 [size=16]
	Kernel driver in use: pata_sis
	Kernel modules: pata_sis, sis5513

00:02.7 Multimedia audio controller [0401]: Silicon Integrated Systems [SiS] AC'97 Sound Controller [1039:7012] (rev a0)
	Subsystem: Fujitsu Siemens Computer GmbH Unknown device [1734:1010]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 173 (13000ns min, 2750ns max)
	Interrupt: pin C routed to IRQ 5
	Region 0: I/O ports at 1400 [size=256]
	Region 1: I/O ports at 1000 [size=128]
	Capabilities: <access denied>
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0

00:03.0 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f) (prog-if 10 [OHCI])
	Subsystem: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (20000ns max)
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at f0000000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd
	Kernel modules: ohci-hcd

00:03.1 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f) (prog-if 10 [OHCI])
	Subsystem: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR+ INTx-
	Latency: 64 (20000ns max)
	Interrupt: pin B routed to IRQ 11
	Region 0: Memory at f0001000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd
	Kernel modules: ohci-hcd

00:03.2 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001] (rev 0f) (prog-if 10 [OHCI])
	Subsystem: Silicon Integrated Systems [SiS] USB 1.1 Controller [1039:7001]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (20000ns max)
	Interrupt: pin C routed to IRQ 10
	Region 0: Memory at f0002000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd
	Kernel modules: ohci-hcd

00:03.3 USB Controller [0c03]: Silicon Integrated Systems [SiS] USB 2.0 Controller [1039:7002] (prog-if 20 [EHCI])
	Subsystem: Silicon Integrated Systems [SiS] USB 2.0 Controller [1039:7002]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (20000ns max)
	Interrupt: pin D routed to IRQ 9
	Region 0: Memory at f0003000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: ehci_hcd
	Kernel modules: ehci-hcd

00:06.0 Ethernet controller [0200]: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 [1317:0985] (rev 11)
	Subsystem: Fujitsu Siemens Computer GmbH Scenic N300 ADMtek AN983 10/100 Mbps PCI Adapter [1734:100c]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (16000ns min, 32000ns max), Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 5
	Region 0: I/O ports at 1800 [size=256]
	Region 1: Memory at f0004800 (32-bit, non-prefetchable) [size=1K]
	[virtual] Expansion ROM at 40000000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: tulip
	Kernel modules: tulip

00:0e.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. IEEE 1394 Host Controller [1106:3044] (rev 46) (prog-if 10 [OHCI])
	Subsystem: VIA Technologies, Inc. IEEE 1394 Host Controller [1106:3044]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (8000ns max), Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 5
	Region 0: Memory at f0004000 (32-bit, non-prefetchable) [size=2K]
	Region 1: I/O ports at 1c00 [size=128]
	Capabilities: <access denied>
	Kernel driver in use: firewire_ohci
	Kernel modules: firewire-ohci

00:12.0 Multimedia video controller [0400]: Brooktree Corporation Bt878 Video Capture [109e:036e] (rev 11)
	Subsystem: Hauppauge computer works Inc. WinTV Series [0070:13eb]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 132 (4000ns min, 10000ns max)
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at f0005000 (32-bit, prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: bttv
	Kernel modules: bttv

00:12.1 Multimedia controller [0480]: Brooktree Corporation Bt878 Audio Capture [109e:0878] (rev 11)
	Subsystem: Hauppauge computer works Inc. WinTV Series [0070:13eb]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (1000ns min, 63750ns max)
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at f0006000 (32-bit, prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: Bt87x
	Kernel modules: bt878, snd-bt87x

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon RV250 If [Radeon 9000] [1002:4966] (rev 01) (prog-if 00 [VGA controller])
	Subsystem: PC Partner Limited Unknown device [174b:7197]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B+ DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 66 (2000ns min), Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 11
	Region 0: Memory at f4000000 (32-bit, prefetchable) [size=64M]
	Region 1: I/O ports at 9000 [size=256]
	Region 2: Memory at f0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at f0120000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel modules: radeonfb

01:00.1 Display controller [0380]: ATI Technologies Inc Radeon RV250 [Radeon 9000] (Secondary) [1002:496e] (rev 01)
	Subsystem: PC Partner Limited Unknown device [174b:7196]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B+ DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 66 (2000ns min), Cache Line Size: 16 bytes
	Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Region 1: Memory at f0110000 (32-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.24-1-686 depends on:
ii  debconf [debconf-2.0]        1.5.20      Debian configuration management sy
ii  initramfs-tools [linux-initr 0.91e       tools for generating an initramfs
ii  module-init-tools            3.3-pre11-4 tools for managing Linux kernel mo

Versions of packages linux-image-2.6.24-1-686 recommends:
ii  libc6-i686                    2.7-10     GNU C Library: Shared libraries [i

-- debconf information:
  linux-image-2.6.24-1-686/preinst/overwriting-modules-2.6.24-1-686: true
  linux-image-2.6.24-1-686/postinst/bootloader-error-2.6.24-1-686:
  linux-image-2.6.24-1-686/postinst/create-kimage-link-2.6.24-1-686: true
  linux-image-2.6.24-1-686/prerm/would-invalidate-boot-loader-2.6.24-1-686: true
  linux-image-2.6.24-1-686/preinst/initrd-2.6.24-1-686:
  linux-image-2.6.24-1-686/preinst/lilo-has-ramdisk:
  linux-image-2.6.24-1-686/preinst/abort-install-2.6.24-1-686:
  linux-image-2.6.24-1-686/prerm/removing-running-kernel-2.6.24-1-686: true
  linux-image-2.6.24-1-686/preinst/abort-overwrite-2.6.24-1-686:
  linux-image-2.6.24-1-686/postinst/bootloader-test-error-2.6.24-1-686:
  linux-image-2.6.24-1-686/preinst/lilo-initrd-2.6.24-1-686: true
  shared/kernel-image/really-run-bootloader: true
  linux-image-2.6.24-1-686/postinst/old-system-map-link-2.6.24-1-686: true
  linux-image-2.6.24-1-686/preinst/failed-to-move-modules-2.6.24-1-686:
  linux-image-2.6.24-1-686/postinst/depmod-error-initrd-2.6.24-1-686: false
  linux-image-2.6.24-1-686/preinst/bootloader-initrd-2.6.24-1-686: true
  linux-image-2.6.24-1-686/postinst/old-initrd-link-2.6.24-1-686: true
  linux-image-2.6.24-1-686/postinst/old-dir-initrd-link-2.6.24-1-686: true
  linux-image-2.6.24-1-686/postinst/depmod-error-2.6.24-1-686: false
  linux-image-2.6.24-1-686/preinst/elilo-initrd-2.6.24-1-686: true
  linux-image-2.6.24-1-686/postinst/kimage-is-a-directory:

---

From: Olivier Berger <[email-masked]>
Date: Sun, 13 Apr 2008 19:38:58 +0200

> printing eip: f105d21c *pde = 00000000 

SNIP

FYI, it works with 2.6.22-3-686 (testing) by issueing :

# modprobe cifs
# echo 0 > /proc/fs/cifs/LinuxExtensionsEnabled
(this is needed for this device which does not handle unix extensions)

then :
# mount -t cifs //nasiomega/PUBLIC /mnt/iomega -v -o user=guest,pass=public,domain=WORKGROUP

However, these commands lead to the oops on 2.6.24.

Will try and recompile a kernel with the
git://git.kernel.org/pub/scm/linux/kernel/git/sfrench/cifs-2.6.git
contents for the cifs driver, to see if it has been solved.

Best regards,

-- 
Olivier BERGER 
(OpenPGP: 1024D/B4C5F37F)
http://www.olivierberger.com/weblog/

---

From: Olivier Berger <[email-masked]>
Date: Sun, 13 Apr 2008 20:29:43 +0200

> contents for the cifs driver, to see if it has been solved.

Unfortunately it evolved in a way which prevents replacing directly the
cifs driver source dir into the 2.6.24 kernel sources and rebuild.

Instead, I tried and test with 2.6.25-rc8-686 package from
http://kernel-archive.buildserver.net/debian-kernel.

Unfortunately, it still fails :

[  183.990770] BUG: unable to handle kernel NULL pointer dereference at 00000010
[  183.990770] IP: [<f0fd99f8>] :cifs:cifs_strfromUCS_le+0x50/0x5f
[  183.990770] *pde = 00000000 
[  183.990770] Oops: 0002 [#1] SMP 
[  183.990770] Modules linked in: nls_utf8 cifs nls_base binfmt_misc radeon drm nfsd auth_rpcgss exportfs ppdev lp ac battery microcode firmware_class nfs lockd nfs_acl sunrpc ipv6 rfcomm l2cap bluetooth reiserfs dm_crypt crypto_blkcipher fuse smsc47m1 eeprom firewire_sbp2 loop evdev joydev usbhid hid ff_memless usblp parport_pc parport snd_intel8x0 snd_ac97_codec ac97_bus psmouse snd_bt87x pcspkr serio_raw snd_pcm_oss snd_mixer_oss rtc snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event container snd_seq snd_timer snd_seq_device snd button i2c_sis96x soundcore snd_page_alloc i2c_core sis_agp agpgart shpchp pci_hotplug ext3 jbd mbcache dm_mirror dm_snapshot dm_mod sg sr_mod cdrom sd_mod sis5513 ide_pci_generic ide_core floppy ehci_hcd firewire_ohci firewire_core crc_itu_t ohci_hcd tulip pata_sis ata_generic usbcore libata scsi_mod dock thermal processor fan
[  183.990770] 
[  183.990770] Pid: 4322, comm: mount.cifs Not tainted (2.6.25-rc8-686 #1)
[  183.990770] EIP: 0060:[<f0fd99f8>] EFLAGS: 00210246 CPU: 0
[  183.990770] EIP is at cifs_strfromUCS_le+0x50/0x5f [cifs]
[  183.990770] EAX: 00000010 EBX: 00000000 ECX: 00000000 EDX: dfb7132e
[  183.990770] ESI: 0000000b EDI: 00000000 EBP: 00000010 ESP: dfb4dccc
[  183.990770]  DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
[  183.990770] Process mount.cifs (pid: 4322, ti=dfb4c000 task=dfb1b310 task.ti=dfb4c000)
[  183.990770] Stack: dfb765c0 00000000 dfb7132e 00000000 0000000b dfb7132d dfacfe80 f0fdc914 
[  183.990770]        f0cdd4c0 00000001 00000000 00000000 ef992800 f0fd712a 00000000 dfb7132e 
[  183.990770]        df9aebc0 dfb58300 44ac3674 8576505f 6a921331 47b2bed6 5fbcea37 6c58df6b 
[  183.990770] Call Trace:
[  183.990770]  [<f0fdc914>] CIFS_SessSetup+0x4c8/0x728 [cifs]
[  183.990770]  [<f0fd712a>] SendReceive+0x3bf/0x3d2 [cifs]
[  183.990770]  [<f0fca5a4>] cifs_setup_session+0x124/0xaec [cifs]
[  183.990770]  [<c01db711>] sprintf+0x1d/0x20
[  183.990770]  [<f0fcd871>] cifs_mount+0x1841/0x1e92 [cifs]
[  183.990770]  [<f0fcd8f4>] cifs_mount+0x18c4/0x1e92 [cifs]
[  183.990770]  [<c01599b3>] get_page_from_freelist+0x2fe/0x37b
[  183.990770]  [<c01da7c2>] strlcpy+0x10/0x3a
[  183.990770]  [<f0fc1589>] cifs_get_sb+0x94/0x166 [cifs]
[  183.990770]  [<c0174154>] vfs_kern_mount+0x7b/0xed
[  183.990770]  [<c0174204>] do_kern_mount+0x2f/0xb4
[  183.990770]  [<c0185999>] do_new_mount+0x55/0x89
[  183.990770]  [<c0185b66>] do_mount+0x199/0x1b8
[  183.990770]  [<c0183fc2>] copy_mount_options+0x26/0x109
[  183.990770]  [<c0185bf2>] sys_mount+0x6d/0xa7
[  183.990770]  [<c01048cc>] sysenter_past_esp+0x6d/0xa5
[  183.990770]  [<c02a0000>] tpacket_rcv+0x369/0x3b4
[  183.990770]  =======================
[  183.990770] Code: b9 06 00 00 00 ff 56 08 85 c0 7e 04 01 c3 eb 07 8b 04 24 43 c6 00 3f 47 3b 7c 24 04 7d 0d 8b 54 24 08 66 8b 04 7a 66 85 c0 75 c7 <c6> 44 1d 00 00 89 d8 83 c4 0c 5b 5e 5f 5d c3 55 31 ed 57 89 cf 
[  183.990770] EIP: [<f0fd99f8>] cifs_strfromUCS_le+0x50/0x5f [cifs] SS:ESP 0068:dfb4dccc
[  183.990770] ---[ end trace c210fe14b4e416ce ]---

Hope this helps.

Best regards,

---

From: maximilian attems <[email-masked]>
Date: Sun, 13 Apr 2008 23:34:16 +0200

> Unfortunately, it still fails :

please file a bug report upstream on bugzilla.kernel.org
and let us know the bug number.

thanks

-- 
maks

---

From: Olivier Berger <[email-masked]>
Date: Mon, 14 Apr 2008 08:11:35 +0200

> and let us know the bug number.

Done : http://bugzilla.kernel.org/show_bug.cgi?id=10451 (and tagged
with forwarded).

Regards,

---

From: Olivier Berger <[email-masked]>
Date: Fri, 23 May 2008 23:17:05 +0200

found 463402 2.6.25-2-686
thanks

SNIP

FYI, I also tested with 2.6.25-2-686 and I still get :

[   72.757622] BUG: unable to handle kernel NULL pointer dereference at 00000010
[   72.757622] IP: [<f0e139e8>] :cifs:cifs_strfromUCS_le+0x50/0x5f
[   72.757622] *pde = 00000000 
[   72.757622] Oops: 0002 [#1] SMP 
[   72.757622] Modules linked in: nls_utf8 cifs nls_base microcode firmware_class nfs lockd nfs_acl sunrpc ipv6 rfcomm l2cap bluetooth reiserfs dm_crypt crypto_blkcipher fuse smsc47m1 eeprom firewire_sbp2 loop evdev parport_pc parport psmouse serio_raw pcspkr rtc snd_bt87x usblp snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_pcm snd_mixer_oss snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi container snd_seq_midi_event snd_seq snd_timer snd_seq_device button snd soundcore snd_page_alloc i2c_sis96x i2c_core shpchp pci_hotplug sis_agp agpgart usbhid hid ff_memless ext3 jbd mbcache dm_mirror dm_snapshot dm_mod sg sr_mod cdrom sd_mod sis5513 ide_pci_generic ide_core floppy firewire_ohci firewire_core crc_itu_t tulip ehci_hcd ohci_hcd pata_sis ata_generic usbcore libata scsi_mod dock thermal processor fan
[   72.757622] 
[   72.757622] Pid: 2488, comm: mount.cifs Not tainted (2.6.25-2-686 #1)
[   72.757622] EIP: 0060:[<f0e139e8>] EFLAGS: 00010246 CPU: 0
[   72.757622] EIP is at cifs_strfromUCS_le+0x50/0x5f [cifs]
[   72.757622] EAX: 00000010 EBX: 00000000 ECX: 00000000 EDX: edc6072e
[   72.757622] ESI: 0000000b EDI: 00000000 EBP: 00000010 ESP: ef37fccc
[   72.757622]  DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
[   72.757622] Process mount.cifs (pid: 2488, ti=ef37e000 task=edf6b8b0 task.ti=ef37e000)
[   72.757622] Stack: ef371440 00000000 edc6072e 00000000 0000000b edc6072d edddc480 f0e16904 
[   72.757622]        f0be04c0 00000001 00000000 00000000 edc4f800 f0e1111a 00000000 edc6072e 
[   72.757622]        eeb3f580 ef9b0300 44ac3674 8576505f 6a921331 47b2bed6 5fbcea37 6c58df6b 
[   72.757622] Call Trace:
[   72.757622]  [<f0e16904>] CIFS_SessSetup+0x4c8/0x728 [cifs]
[   72.757622]  [<f0e1111a>] SendReceive+0x3bf/0x3d2 [cifs]
[   72.757622]  [<f0e045a0>] cifs_setup_session+0x124/0xaec [cifs]
[   72.757622]  [<c01de9dd>] sprintf+0x1d/0x20
[   72.757622]  [<f0e0786d>] cifs_mount+0x1841/0x1e92 [cifs]
[   72.757622]  [<f0e078f0>] cifs_mount+0x18c4/0x1e92 [cifs]
[   72.757622]  [<c02b4334>] schedule_timeout+0x13/0x86
[   72.757622]  [<c015cabf>] get_page_from_freelist+0x2fe/0x37b
[   72.757622]  [<c01dda8e>] strlcpy+0x10/0x3a
[   72.757622]  [<f0dfb589>] cifs_get_sb+0x94/0x166 [cifs]
[   72.757622]  [<c0177264>] vfs_kern_mount+0x7b/0xed
[   72.757622]  [<c0177314>] do_kern_mount+0x2f/0xb4
[   72.757622]  [<c0188b21>] do_new_mount+0x55/0x89
[   72.757622]  [<c0188cee>] do_mount+0x199/0x1b8
[   72.757622]  [<c018714a>] copy_mount_options+0x26/0x109
[   72.757622]  [<c0188d7a>] sys_mount+0x6d/0xa7
[   72.757622]  [<c01077e4>] sysenter_past_esp+0x6d/0xa5
[   72.757622]  [<c02b0000>] init_amd+0x4a6/0x66e
[   72.757622]  =======================
[   72.757622] Code: b9 06 00 00 00 ff 56 08 85 c0 7e 04 01 c3 eb 07 8b 04 24 43 c6 00 3f 47 3b 7c 24 04 7d 0d 8b 54 24 08 66 8b 04 7a 66 85 c0 75 c7 <c6> 44 1d 00 00 89 d8 83 c4 0c 5b 5e 5f 5d c3 55 31 ed 57 89 cf 
[   72.757622] EIP: [<f0e139e8>] cifs_strfromUCS_le+0x50/0x5f [cifs] SS:ESP 0068:ef37fccc
[   72.757626] ---[ end trace 973b2141f513d726 ]---

Best regards,