Subject: Reproduced

From: Linux Luser <[email-masked]>
Date: Thu, 13 Nov 2014 23:58:30 +0000

Package: heimdal-kdc
Version: 1.6~rc2+dfsg-8
Tags: jessie

I can confirm that there is at least some difficulty with glob patterns. I
can only get the proper privs when I type out the entire name of each
principal in the kadmind.acl file, like so:

host/[email-masked] list,get,change-password

On the remote machine I can get:

$ kadmin -p host/hostname privs
host/[email-masked]'s Password:
change-password, list, get

Any attempt at glob patterns fails me:

host/[email-masked] list,get,change-password
host/[email-masked] list,get,change-password
host/[email-masked] list,get,change-password
*/[email-masked] list,get,change-password
[email-masked] list,get,change-password
host/[email-masked] list,get,change-password

All of the above example return 'none' when I issue the 'privs' command
from a remote machine.

---

From: "A. Lewenberg" <[email-masked]>
Date: Sun, 11 Aug 2019 05:52:17 -0700

Submitted bug report at the upstream GitHub project: 
https://github.com/heimdal/heimdal/issues/617

---

From: Adam Lewenberg <[email-masked]>
Date: Sun, 11 Aug 2019 05:51:37 -0700