Subject: Bug#505733: [alsa-base] Input source not correctly set on boot sequence (fujitsu pi1505, ALC861 Analog, HDA intel)

From: Jean-Louis Biasini <[email-masked]>
Date: Fri, 14 Nov 2008 19:47:47 +0100

Package: alsa-base
Version: 1.0.17.dfsg-4
Severity: important
Tags: patch

--- Please enter the report below this line. ---
Hello and thanks for your work,

I've just made a new install of lenny had I had since a long time
a problem with the input source selection as the system was just started.
In fact it seems that the input sources is not correctly set. The result
is that although the microphone works (I can hear my voice on the high 
speakers if I set the volume to do so) it is not possible to record sound.
It take me a lot of time to understand the cause of this. As setting
manually the input source on CD and then back to microphone solved the
problem, the following command launched at the end of the booting
process solved the problem:

amixer cset iface=MIXER,name='Mic Playback Switch' off,off
amixer cset iface=MIXER,name='Input Source' 1 # select CD as input
amixer cset iface=MIXER,name='Capture Switch' on,on
amixer cset iface=MIXER,name='Input Source' 0 # reselect mike

I suggest whether to add them to the booting sequence or to search
the real cause of the setting's failure.

Regards

Jean-Louis Biasini
  
--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.26-8-fbtoi

Debian Release: lenny/sid
  988 testing         security.debian.org 
  987 testing         www.debian-multimedia.org 
  986 testing         ftp.tugraz.at 
  985 stable          debian.ens-cachan.fr 
   98 unstable        ftp.tugraz.at 
  500 unstable        jeandamiendurand.free.fr 
  500 unstable        ftp.berlios.de 
  500 testing         download.tuxfamily.org 
  500 stable          tobias.rautenkranz.ch 

--- Package information. ---
Depends                (Version) | Installed
================================-+-===========
lsof                   (>= 4.64) | 4.78.dfsg.1-4
module-init-tools     (>= 3.2.1) | 3.4-1
linux-sound-base                 | 1.0.17.dfsg-4

--- Output from package bug script ---

---

From: Elimar Riesebieter <[email-masked]>
Date: Fri, 14 Nov 2008 20:53:16 +0100

tags 505733 -patch
severity 505733 normal
reassign 505733 alsa-utils

thanks

* Jean-Louis Biasini [081114 20:10 +0100]
> Tags: patch

Didn't find one

> amixer cset iface=MIXER,name='Input Source' 0 # reselect mike

This is bit confused:
'Input Source' 1 or 0 ???
Mic Playback Switch sounds unreasonabele?

Please tell us which soundcard you use.

Thanks
Elimnar

-- 
  Do you smell something burning or ist it me?