Subject: #517892 solution known

From: Ola Lundqvist <[email-masked]>
Date: Wed, 23 Sep 2009 22:03:05 +0200

Hi Maximilian

One other bug that seems to be solved now. That is
#517892. The solution is to add the following parameter
to the build configuration for openvz.

CONFIG_SYSFS_DEPRECATED_V2=y

Patch:
echo CONFIG_SYSFS_DEPRECATED_V2=y >> debian/config/featureset-openvz/config

I do not know if that is an ABI breaker though.

Would that be possible to fix in stable?

Best regards,

// Ola

On Wed, Sep 23, 2009 at 06:37:37PM +0200, maximilian attems wrote:
> On Sun, 13 Sep 2009, Ola Lundqvist wrote:
> 
> > Hi Maximilian
> > 
> > Do you plan to add this fix to the Lenny tree? Or should I forward
> > this bug upstream?
> > 
> > Best regards,
> > 
> > // Ola
> > 
> 
> yes i added that patch above to the abi breaking branch.
> see it in linux-2.6-abi in lenny repo branch
> 
> no idea when the next abi bump is scheduled for lenny,
> but we will probably discuss this today.
> 

-- 
 --- Inguza Technology AB --- MSc in Information Technology ----
/  [email-masked]                    Annebergsslingan 37        \
|  [email-masked]                   654 65 KARLSTAD            |
|  http://inguza.com/                Mobile: +46 (0)70-332 1551 |
\  gpg/f.p.: 7090 A92B 18FE 7994 0C36 4FE4 18A1 B1CF 0FE5 3DD9  /
 ---------------------------------------------------------------

---

From: maximilian attems <[email-masked]>
Date: Wed, 23 Sep 2009 22:50:34 +0200

> Would that be possible to fix in stable?

if not a abi breaker easiest, will buildtest later. :)

---

From: Ola Lundqvist <[email-masked]>
Date: Thu, 24 Sep 2009 05:35:26 +0200

On Wed, Sep 23, 2009 at 10:50:34PM +0200, maximilian attems wrote:
...
> if not a abi breaker easiest, will buildtest later. :)

Great!

// Ola

---

From: maximilian attems <[email-masked]>
Date: Thu, 24 Sep 2009 06:36:47 +0200

> > if not a abi breaker easiest, will buildtest later. :)

python debian/bin/abicheck.py debian/build/build_amd64_openvz_amd64
amd64 openvz amd64
No ABI changes.

added to latest lenny branch :)

---

From: "Ola Lundqvist" <[email-masked]>
Date: Thu, 24 Sep 2009 11:42:01 +0200

Good news!

// Ola