Subject: Bug#524142: linux-image-2.6.29-1-686: CIFS VFS ignores port mount option

From: Nicholas Perez <[email-masked]>
Date: Wed, 15 Apr 2009 00:01:45 -0500

Package: linux-image-2.6.29-1-686
Version: 2.6.29-2
Severity: normal

When passing the port option to mount.cifs (so that I may redirect my
mount to use the SSH tunnel for example), it is ignored. The option is
properly parsed, but it has no effect what so ever in the code. See the
following for my little bit of research into this:

First setup netcat to listen locally for the CIFS connection:
nicholas@eeepc:~$ sudo netcat -l -p 445

Then attempt a mount with the port option set completely differently:
nicholas@eeepc:~$ sudo mount -t cifs -o port=65100 //localhost/external
/home/nicholas/test --verbose
parsing options: rw,port=65100
Password:

mount.cifs kernel mount options
unc=//localhost\external,user=root,pass=,ver=1,rw,port=65100
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

See the output from netcat:
MBr��+LM1.2X002LANMAN2.1NT LM 0.12POSIX 2

As you can see, the connection happened to the default port of 445
rather than the 65100 port that was specified. If I supply an IP address
the same thing happens.

-- Package-specific info:
** Version:
Linux version 2.6.29-1-686 (Debian 2.6.29-2) ([email-masked]) (gcc version 4.3.3 (Debian 4.3.3-5) ) #1 SMP Sat Apr 4 17:36:29 UTC 2009

** Command line:
root=/dev/sda1 ro quiet

** Not tainted

** Kernel log:
[23772.404071]  CIFS VFS: No response for cmd 114 mid 1
[23772.404121]  CIFS VFS: cifs_mount failed w/return code = -112

** Loaded modules:
Module                  Size  Used by
nls_utf8                1472  0 
cifs                  254752  0 
nls_base                6508  2 nls_utf8,cifs
i915                  129464  2 
drm                   133260  3 i915
i2c_algo_bit            4888  1 i915
ppdev                   6224  0 
parport_pc             22020  0 
lp                      7872  0 
parport                30868  3 ppdev,parport_pc,lp
xt_DSCP                 2636  3 
xt_limit                1768  1 
xt_recent               7784  2 
xt_tcpudp               2492  6 
xt_state                1752  3 
iptable_nat             5040  0 
nf_nat                 16120  1 iptable_nat
nf_conntrack_ipv4      11568  6 iptable_nat,nf_nat
nf_conntrack           58228  4 xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
nf_defrag_ipv4          1648  1 nf_conntrack_ipv4
iptable_mangle          3252  1 
iptable_filter          2944  1 
ip_tables               9892  3 iptable_nat,iptable_mangle,iptable_filter
x_tables               13672  7 xt_DSCP,xt_limit,xt_recent,xt_tcpudp,xt_state,iptable_nat,ip_tables
ipv6                  232468  34 
hid_gaff                2900  0 
hid_pl                  2996  0 
hid_cypress             2340  0 
hid_zpff                2652  0 
hid_gyration            2196  0 
hid_sony                2568  0 
hid_ntrig               1744  0 
hid_samsung             2112  0 
hid_microsoft           3200  0 
hid_tmff                3460  0 
hid_monterey            2132  0 
hid_ezkey               1832  0 
hid_apple               5704  0 
hid_a4tech              2500  0 
hid_logitech            6656  0 
usbhid                 29132  5 hid_gaff,hid_pl,hid_zpff,hid_tmff,hid_logitech
ff_memless              4264  5 hid_gaff,hid_pl,hid_zpff,hid_tmff,hid_logitech
hid_cherry              2100  0 
hid_sunplus             1972  0 
hid_petalynx            2468  0 
hid_belkin              2284  0 
hid_chicony             2004  0 
hid                    34260  21 hid_gaff,hid_pl,hid_cypress,hid_zpff,hid_gyration,hid_sony,hid_ntrig,hid_samsung,hid_microsoft,hid_tmff,hid_monterey,hid_ezkey,hid_apple,hid_a4tech,hid_logitech,usbhid,hid_cherry,hid_sunplus,hid_petalynx,hid_belkin,hid_chicony
joydev                  8560  0 
snd_hda_codec_realtek   173504  1 
snd_hda_intel          22092  0 
snd_hda_codec          58808  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6000  1 snd_hda_codec
snd_pcm_oss            31708  0 
snd_mixer_oss          12000  1 snd_pcm_oss
snd_pcm                62708  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
arc4                    1544  2 
ecb                     2352  2 
snd_seq_dummy           2368  0 
snd_seq_oss            24756  0 
snd_seq_midi            5448  0 
snd_rawmidi            18544  1 snd_seq_midi
serio_raw               4544  0 
snd_seq_midi_event      6072  2 snd_seq_oss,snd_seq_midi
i2c_i801                8104  0 
ath5k                  96892  0 
snd_seq                42120  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
pcspkr                  2092  0 
psmouse                36628  0 
evdev                   8160  16 
i2c_core               20828  4 i915,drm,i2c_algo_bit,i2c_i801
mac80211              135592  1 ath5k
snd_timer              17808  2 snd_pcm,snd_seq
led_class               3668  1 ath5k
snd_seq_device          6108  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
rng_core                3644  0 
cfg80211               32996  2 ath5k,mac80211
atl2                   23032  0 
snd                    48420  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               6204  1 snd
snd_page_alloc          8036  2 snd_hda_intel,snd_pcm
video                  16348  0 
output                  2504  1 video
eeepc_laptop           10120  0 
battery                 5832  0 
ac                      2872  0 
rfkill                  9576  2 eeepc_laptop
button                  5672  0 
ext3                  107180  1 
jbd                    42500  1 ext3
mbcache                 7180  1 ext3
sd_mod                 28252  2 
crc_t10dif              1616  1 sd_mod
ata_generic             4316  0 
ide_pci_generic         3408  0 
ide_core               91820  1 ide_pci_generic
usb_storage            83460  0 
ahci                   27568  0 
ata_piix               20092  1 
libata                148892  3 ata_generic,ahci,ata_piix
ehci_hcd               29936  0 
scsi_mod              132076  3 sd_mod,usb_storage,libata
usbcore               124912  5 hid_sony,usbhid,usb_storage,ehci_hcd
intel_agp              22548  1 
agpgart                30624  3 drm,intel_agp
thermal                15092  2 
processor              39540  1 thermal
fan                     4104  0 
thermal_sys            10272  4 video,thermal,processor,fan

** PCI devices:
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
	Latency: 0
	Capabilities: <access denied>
	Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f7f00000 (32-bit, non-prefetchable) [size=512K]
	Region 1: I/O ports at ec00 [size=8]
	Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 3: Memory at f7ec0000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>

00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at f7f80000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: <access denied>

00:1b.0 Audio device [0403]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller [8086:2668] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82a1]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 27
	Region 0: Memory at f7eb8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel

00:1c.0 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 [8086:2660] (rev 04) (prog-if 00 [Normal decode])
	Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport-driver

00:1c.1 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 [8086:2662] (rev 04) (prog-if 00 [Normal decode])
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	Memory behind bridge: fbf00000-fbffffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport-driver

00:1c.2 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 [8086:2664] (rev 04) (prog-if 00 [Normal decode])
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Bus: primary=00, secondary=01, subordinate=02, sec-latency=0
	Memory behind bridge: f8000000-fbefffff
	Prefetchable memory behind bridge: 00000000f0000000-00000000f6ffffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport-driver

00:1d.0 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 [8086:2658] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 3
	Region 4: I/O ports at e400 [size=32]

00:1d.1 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 [8086:2659] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 7
	Region 4: I/O ports at e480 [size=32]

00:1d.2 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 [8086:265a] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin C routed to IRQ 10
	Region 4: I/O ports at e800 [size=32]

00:1d.3 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 [8086:265b] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin D routed to IRQ 5
	Region 4: I/O ports at e880 [size=32]

00:1d.7 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller [8086:265c] (rev 04) (prog-if 20 [EHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 23
	Region 0: Memory at f7eb7c00 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev d4) (prog-if 01 [Subtractive decode])
	Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
	Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>

00:1f.0 ISA bridge [0601]: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge [8086:2641] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0

00:1f.2 IDE interface [0101]: Intel Corporation 82801FBM (ICH6M) SATA Controller [8086:2653] (rev 04) (prog-if 80 [Master])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 19
	Region 0: I/O ports at 01f0 [size=8]
	Region 1: I/O ports at 03f4 [size=1]
	Region 2: I/O ports at 0170 [size=8]
	Region 3: I/O ports at 0374 [size=1]
	Region 4: I/O ports at ffa0 [size=16]
	Capabilities: <access denied>
	Kernel driver in use: ata_piix

00:1f.3 SMBus [0c05]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller [8086:266a] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin B routed to IRQ 19
	Region 4: I/O ports at 0400 [size=32]
	Kernel driver in use: i801_smbus

01:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)
	Subsystem: Device [1a3b:1026]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at fbef0000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: ath5k

03:00.0 Ethernet controller [0200]: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter [1969:2048] (rev a0)
	Subsystem: ASUSTeK Computer Inc. Device [1043:8233]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 28
	Region 0: Memory at fbfc0000 (64-bit, non-prefetchable) [size=256K]
	Expansion ROM at fbfa0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: atl2

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-1-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.29-1-686 depends on:
ii  debconf [debconf-2.0]         1.5.26     Debian configuration management sy
ii  initramfs-tools [linux-initra 0.93.2     tools for generating an initramfs
ii  module-init-tools             3.7-pre9-1 tools for managing Linux kernel mo

Versions of packages linux-image-2.6.29-1-686 recommends:
ii  libc6-i686                    2.9-7      GNU C Library: Shared libraries [i

Versions of packages linux-image-2.6.29-1-686 suggests:
ii  grub                          0.97-53    GRand Unified Bootloader (Legacy v
pn  linux-doc-2.6.29              <none>     (no description available)

-- debconf information:
  linux-image-2.6.29-1-686/preinst/abort-overwrite-2.6.29-1-686:
  shared/kernel-image/really-run-bootloader: true
  linux-image-2.6.29-1-686/preinst/overwriting-modules-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/elilo-initrd-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/initrd-2.6.29-1-686:
  linux-image-2.6.29-1-686/preinst/bootloader-initrd-2.6.29-1-686: true
  linux-image-2.6.29-1-686/postinst/bootloader-test-error-2.6.29-1-686:
  linux-image-2.6.29-1-686/postinst/depmod-error-initrd-2.6.29-1-686: false
  linux-image-2.6.29-1-686/prerm/removing-running-kernel-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/lilo-has-ramdisk:
  linux-image-2.6.29-1-686/postinst/old-system-map-link-2.6.29-1-686: true
  linux-image-2.6.29-1-686/postinst/kimage-is-a-directory:
  linux-image-2.6.29-1-686/postinst/old-dir-initrd-link-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/lilo-initrd-2.6.29-1-686: true
  linux-image-2.6.29-1-686/postinst/depmod-error-2.6.29-1-686: false
  linux-image-2.6.29-1-686/postinst/bootloader-error-2.6.29-1-686:
  linux-image-2.6.29-1-686/preinst/failed-to-move-modules-2.6.29-1-686:
  linux-image-2.6.29-1-686/postinst/create-kimage-link-2.6.29-1-686: true
  linux-image-2.6.29-1-686/prerm/would-invalidate-boot-loader-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/abort-install-2.6.29-1-686:
  linux-image-2.6.29-1-686/postinst/old-initrd-link-2.6.29-1-686: true

---

From: Moritz Muehlenhoff <[email-masked]>
Date: Sat, 12 Sep 2009 20:45:14 +0200

On Wed, Apr 15, 2009 at 12:01:45AM -0500, Nicholas Perez wrote:
> MBr??????+LM1.2X002LANMAN2.1NT LM 0.12POSIX 2
> 
> 

Sorry for the late response.

This was fixed in 2.6.31, which will be uploaded soon.

Cheers,
        Moritz

---

From: [email-masked] (Debian Bug Tracking System)
Date: Mon, 05 Oct 2009 18:00:50 +0000

This is an automatic notification regarding your Bug report
which was filed against the linux-2.6 package:

#524142: linux-image-2.6.29-1-686: CIFS VFS ignores port mount option

It has been closed by maximilian attems <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact maximilian attems <[email-masked]> by
replying to this email.

-- 
524142: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=524142
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Bug#524142: fixed in linux-2.6 2.6.31-1~experimental.1
From: maximilian attems <[email-masked]>
To: [email-masked]
Date: Mon, 05 Oct 2009 17:43:36 +0000

Source: linux-2.6
Source-Version: 2.6.31-1~experimental.1

We believe that the bug you reported is fixed in the latest version of
linux-2.6, which is due to be installed in the Debian FTP archive:

firmware-linux-free_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/firmware-linux-free_2.6.31-1~experimental.1_all.deb
linux-2.6_2.6.31-1~experimental.1.diff.gz
  to pool/main/l/linux-2.6/linux-2.6_2.6.31-1~experimental.1.diff.gz
linux-2.6_2.6.31-1~experimental.1.dsc
  to pool/main/l/linux-2.6/linux-2.6_2.6.31-1~experimental.1.dsc
linux-2.6_2.6.31.orig.tar.gz
  to pool/main/l/linux-2.6/linux-2.6_2.6.31.orig.tar.gz
linux-doc-2.6.31_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/linux-doc-2.6.31_2.6.31-1~experimental.1_all.deb
linux-headers-2.6.31-trunk-all-amd64_2.6.31-1~experimental.1_amd64.deb
  to pool/main/l/linux-2.6/linux-headers-2.6.31-trunk-all-amd64_2.6.31-1~experimental.1_amd64.deb
linux-headers-2.6.31-trunk-all_2.6.31-1~experimental.1_amd64.deb
  to pool/main/l/linux-2.6/linux-headers-2.6.31-trunk-all_2.6.31-1~experimental.1_amd64.deb
linux-headers-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
  to pool/main/l/linux-2.6/linux-headers-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
linux-headers-2.6.31-trunk-common_2.6.31-1~experimental.1_amd64.deb
  to pool/main/l/linux-2.6/linux-headers-2.6.31-trunk-common_2.6.31-1~experimental.1_amd64.deb
linux-image-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
  to pool/main/l/linux-2.6/linux-image-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
linux-libc-dev_2.6.31-1~experimental.1_amd64.deb
  to pool/main/l/linux-2.6/linux-libc-dev_2.6.31-1~experimental.1_amd64.deb
linux-manual-2.6.31_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/linux-manual-2.6.31_2.6.31-1~experimental.1_all.deb
linux-patch-debian-2.6.31_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/linux-patch-debian-2.6.31_2.6.31-1~experimental.1_all.deb
linux-source-2.6.31_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/linux-source-2.6.31_2.6.31-1~experimental.1_all.deb
linux-support-2.6.31-trunk_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/linux-support-2.6.31-trunk_2.6.31-1~experimental.1_all.deb
linux-tree-2.6.31_2.6.31-1~experimental.1_all.deb
  to pool/main/l/linux-2.6/linux-tree-2.6.31_2.6.31-1~experimental.1_all.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
maximilian attems <[email-masked]> (supplier of updated linux-2.6 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Sun, 04 Oct 2009 20:27:05 +0200
Source: linux-2.6
Binary: linux-source-2.6.31 linux-doc-2.6.31 linux-manual-2.6.31 linux-patch-debian-2.6.31 firmware-linux-free linux-tree-2.6.31 linux-support-2.6.31-trunk linux-libc-dev linux-headers-2.6.31-trunk-all linux-headers-2.6.31-trunk-all-alpha linux-headers-2.6.31-trunk-common linux-image-2.6.31-trunk-alpha-generic linux-headers-2.6.31-trunk-alpha-generic linux-image-2.6.31-trunk-alpha-smp linux-headers-2.6.31-trunk-alpha-smp linux-image-2.6.31-trunk-alpha-legacy linux-headers-2.6.31-trunk-alpha-legacy linux-headers-2.6.31-trunk-all-amd64 linux-image-2.6.31-trunk-amd64 linux-headers-2.6.31-trunk-amd64 linux-headers-2.6.31-trunk-all-armel linux-image-2.6.31-trunk-iop32x linux-headers-2.6.31-trunk-iop32x linux-image-2.6.31-trunk-ixp4xx linux-headers-2.6.31-trunk-ixp4xx linux-image-2.6.31-trunk-kirkwood linux-headers-2.6.31-trunk-kirkwood linux-image-2.6.31-trunk-orion5x linux-headers-2.6.31-trunk-orion5x linux-image-2.6.31-trunk-versatile linux-headers-2.6.31-trunk-versatile linux-headers-2.6.31-trunk-all-hppa linux-image-2.6.31-trunk-parisc linux-headers-2.6.31-trunk-parisc linux-image-2.6.31-trunk-parisc-smp linux-headers-2.6.31-trunk-parisc-smp linux-image-2.6.31-trunk-parisc64 linux-headers-2.6.31-trunk-parisc64 linux-image-2.6.31-trunk-parisc64-smp linux-headers-2.6.31-trunk-parisc64-smp linux-headers-2.6.31-trunk-all-i386 linux-image-2.6.31-trunk-486 linux-headers-2.6.31-trunk-486 linux-image-2.6.31-trunk-686 linux-headers-2.6.31-trunk-686 linux-image-2.6.31-trunk-686-bigmem linux-headers-2.6.31-trunk-686-bigmem linux-headers-2.6.31-trunk-all-ia64 linux-image-2.6.31-trunk-itanium linux-headers-2.6.31-trunk-itanium linux-image-2.6.31-trunk-mckinley linux-headers-2.6.31-trunk-mckinley linux-headers-2.6.31-trunk-all-m68k linux-image-2.6.31-trunk-amiga linux-headers-2.6.31-trunk-amiga linux-image-2.6.31-trunk-atari linux-headers-2.6.31-trunk-atari linux-image-2.6.31-trunk-bvme6000 linux-headers-2.6.31-trunk-bvme6000 linux-image-2.6.31-trunk-mac linux-headers-2.6.31-trunk-mac linux-image-2.6.31-trunk-mvme147 linux-headers-2.6.31-trunk-mvme147 linux-image-2.6.31-trunk-mvme16x linux-headers-2.6.31-trunk-mvme16x linux-headers-2.6.31-trunk-all-mips linux-image-2.6.31-trunk-r4k-ip22 linux-headers-2.6.31-trunk-r4k-ip22 linux-image-2.6.31-trunk-r5k-ip32 linux-headers-2.6.31-trunk-r5k-ip32 linux-image-2.6.31-trunk-sb1-bcm91250a linux-headers-2.6.31-trunk-sb1-bcm91250a linux-image-2.6.31-trunk-sb1a-bcm91480b linux-headers-2.6.31-trunk-sb1a-bcm91480b linux-image-2.6.31-trunk-4kc-malta linux-headers-2.6.31-trunk-4kc-malta linux-image-2.6.31-trunk-5kc-malta linux-headers-2.6.31-trunk-5kc-malta linux-headers-2.6.31-trunk-all-mipsel linux-image-2.6.31-trunk-r5k-cobalt linux-headers-2.6.31-trunk-r5k-cobalt linux-headers-2.6.31-trunk-all-powerpc linux-image-2.6.31-trunk-powerpc linux-headers-2.6.31-trunk-powerpc linux-image-2.6.31-trunk-powerpc-smp linux-headers-2.6.31-trunk-powerpc-smp linux-image-2.6.31-trunk-powerpc64 linux-headers-2.6.31-trunk-powerpc64 linux-headers-2.6.31-trunk-all-s390 linux-image-2.6.31-trunk-s390x linux-headers-2.6.31-trunk-s390x linux-image-2.6.31-trunk-s390x-tape linux-headers-2.6.31-trunk-all-sparc linux-image-2.6.31-trunk-sparc64 linux-headers-2.6.31-trunk-sparc64 linux-image-2.6.31-trunk-sparc64-smp linux-headers-2.6.31-trunk-sparc64-smp
Architecture: source all amd64
Version: 2.6.31-1~experimental.1
Distribution: experimental
Urgency: low
Maintainer: Debian Kernel Team <[email-masked]>
Changed-By: maximilian attems <[email-masked]>
Description: 
 firmware-linux-free - Binary firmware for various drivers in the Linux kernel
 linux-doc-2.6.31 - Linux kernel specific documentation for version 2.6.31
 linux-headers-2.6.31-trunk-486 - Header files for Linux 2.6.31-trunk-486
 linux-headers-2.6.31-trunk-4kc-malta - Header files for Linux 2.6.31-trunk-4kc-malta
 linux-headers-2.6.31-trunk-5kc-malta - Header files for Linux 2.6.31-trunk-5kc-malta
 linux-headers-2.6.31-trunk-686 - Header files for Linux 2.6.31-trunk-686
 linux-headers-2.6.31-trunk-686-bigmem - Header files for Linux 2.6.31-trunk-686-bigmem
 linux-headers-2.6.31-trunk-all - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-alpha - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-amd64 - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-armel - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-hppa - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-i386 - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-ia64 - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-m68k - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-mips - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-mipsel - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-powerpc - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-s390 - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-all-sparc - All header files for Linux 2.6.31
 linux-headers-2.6.31-trunk-alpha-generic - Header files for Linux 2.6.31-trunk-alpha-generic
 linux-headers-2.6.31-trunk-alpha-legacy - Header files for Linux 2.6.31-trunk-alpha-legacy
 linux-headers-2.6.31-trunk-alpha-smp - Header files for Linux 2.6.31-trunk-alpha-smp
 linux-headers-2.6.31-trunk-amd64 - Header files for Linux 2.6.31-trunk-amd64
 linux-headers-2.6.31-trunk-amiga - Header files for Linux 2.6.31-trunk-amiga
 linux-headers-2.6.31-trunk-atari - Header files for Linux 2.6.31-trunk-atari
 linux-headers-2.6.31-trunk-bvme6000 - Header files for Linux 2.6.31-trunk-bvme6000
 linux-headers-2.6.31-trunk-common - Common header files for Linux 2.6.31-trunk
 linux-headers-2.6.31-trunk-iop32x - Header files for Linux 2.6.31-trunk-iop32x
 linux-headers-2.6.31-trunk-itanium - Header files for Linux 2.6.31-trunk-itanium
 linux-headers-2.6.31-trunk-ixp4xx - Header files for Linux 2.6.31-trunk-ixp4xx
 linux-headers-2.6.31-trunk-kirkwood - Header files for Linux 2.6.31-trunk-kirkwood
 linux-headers-2.6.31-trunk-mac - Header files for Linux 2.6.31-trunk-mac
 linux-headers-2.6.31-trunk-mckinley - Header files for Linux 2.6.31-trunk-mckinley
 linux-headers-2.6.31-trunk-mvme147 - Header files for Linux 2.6.31-trunk-mvme147
 linux-headers-2.6.31-trunk-mvme16x - Header files for Linux 2.6.31-trunk-mvme16x
 linux-headers-2.6.31-trunk-orion5x - Header files for Linux 2.6.31-trunk-orion5x
 linux-headers-2.6.31-trunk-parisc - Header files for Linux 2.6.31-trunk-parisc
 linux-headers-2.6.31-trunk-parisc-smp - Header files for Linux 2.6.31-trunk-parisc-smp
 linux-headers-2.6.31-trunk-parisc64 - Header files for Linux 2.6.31-trunk-parisc64
 linux-headers-2.6.31-trunk-parisc64-smp - Header files for Linux 2.6.31-trunk-parisc64-smp
 linux-headers-2.6.31-trunk-powerpc - Header files for Linux 2.6.31-trunk-powerpc
 linux-headers-2.6.31-trunk-powerpc-smp - Header files for Linux 2.6.31-trunk-powerpc-smp
 linux-headers-2.6.31-trunk-powerpc64 - Header files for Linux 2.6.31-trunk-powerpc64
 linux-headers-2.6.31-trunk-r4k-ip22 - Header files for Linux 2.6.31-trunk-r4k-ip22
 linux-headers-2.6.31-trunk-r5k-cobalt - Header files for Linux 2.6.31-trunk-r5k-cobalt
 linux-headers-2.6.31-trunk-r5k-ip32 - Header files for Linux 2.6.31-trunk-r5k-ip32
 linux-headers-2.6.31-trunk-s390x - Header files for Linux 2.6.31-trunk-s390x
 linux-headers-2.6.31-trunk-sb1-bcm91250a - Header files for Linux 2.6.31-trunk-sb1-bcm91250a
 linux-headers-2.6.31-trunk-sb1a-bcm91480b - Header files for Linux 2.6.31-trunk-sb1a-bcm91480b
 linux-headers-2.6.31-trunk-sparc64 - Header files for Linux 2.6.31-trunk-sparc64
 linux-headers-2.6.31-trunk-sparc64-smp - Header files for Linux 2.6.31-trunk-sparc64-smp
 linux-headers-2.6.31-trunk-versatile - Header files for Linux 2.6.31-trunk-versatile
 linux-image-2.6.31-trunk-486 - Linux 2.6.31 image on x86
 linux-image-2.6.31-trunk-4kc-malta - Linux 2.6.31 image on MIPS Malta
 linux-image-2.6.31-trunk-5kc-malta - Linux 2.6.31 image on MIPS Malta (64-bit)
 linux-image-2.6.31-trunk-686 - Linux 2.6.31 image on PPro/Celeron/PII/PIII/P4
 linux-image-2.6.31-trunk-686-bigmem - Linux 2.6.31 image on PPro/Celeron/PII/PIII/P4
 linux-image-2.6.31-trunk-alpha-generic - Linux 2.6.31 image on Alpha
 linux-image-2.6.31-trunk-alpha-legacy - Linux 2.6.31 image on Alpha Legacy
 linux-image-2.6.31-trunk-alpha-smp - Linux 2.6.31 image on Alpha SMP
 linux-image-2.6.31-trunk-amd64 - Linux 2.6.31 image on AMD64
 linux-image-2.6.31-trunk-amiga - Linux 2.6.31 image on Amiga
 linux-image-2.6.31-trunk-atari - Linux 2.6.31 image on Atari
 linux-image-2.6.31-trunk-bvme6000 - Linux 2.6.31 image on BVM BVME4000 and BVME6000
 linux-image-2.6.31-trunk-iop32x - Linux 2.6.31 image on IOP32x
 linux-image-2.6.31-trunk-itanium - Linux 2.6.31 image on Itanium
 linux-image-2.6.31-trunk-ixp4xx - Linux 2.6.31 image on IXP4xx
 linux-image-2.6.31-trunk-kirkwood - Linux 2.6.31 image on Marvell Kirkwood
 linux-image-2.6.31-trunk-mac - Linux 2.6.31 image on Macintosh
 linux-image-2.6.31-trunk-mckinley - Linux 2.6.31 image on Itanium II
 linux-image-2.6.31-trunk-mvme147 - Linux 2.6.31 image on Motorola MVME147
 linux-image-2.6.31-trunk-mvme16x - Linux 2.6.31 image on Motorola MVME162/6/7, MVME172/7
 linux-image-2.6.31-trunk-orion5x - Linux 2.6.31 image on Marvell Orion
 linux-image-2.6.31-trunk-parisc - Linux 2.6.31 image on 32-bit PA-RISC
 linux-image-2.6.31-trunk-parisc-smp - Linux 2.6.31 image on multiprocessor 32-bit PA-RISC
 linux-image-2.6.31-trunk-parisc64 - Linux 2.6.31 image on 64-bit PA-RISC
 linux-image-2.6.31-trunk-parisc64-smp - Linux 2.6.31 image on multiprocessor 64-bit PA-RISC
 linux-image-2.6.31-trunk-powerpc - Linux 2.6.31 image on uniprocessor 32-bit PowerPC
 linux-image-2.6.31-trunk-powerpc-smp - Linux 2.6.31 image on multiprocessor 32-bit PowerPC
 linux-image-2.6.31-trunk-powerpc64 - Linux 2.6.31 image on 64-bit PowerPC
 linux-image-2.6.31-trunk-r4k-ip22 - Linux 2.6.31 image on SGI IP22
 linux-image-2.6.31-trunk-r5k-cobalt - Linux 2.6.31 image on Cobalt
 linux-image-2.6.31-trunk-r5k-ip32 - Linux 2.6.31 image on SGI IP32
 linux-image-2.6.31-trunk-s390x - Linux 2.6.31 image on IBM zSeries
 linux-image-2.6.31-trunk-s390x-tape - Linux 2.6.31 image on IBM zSeries, IPL from tape
 linux-image-2.6.31-trunk-sb1-bcm91250a - Linux 2.6.31 image on BCM91250A
 linux-image-2.6.31-trunk-sb1a-bcm91480b - Linux 2.6.31 image on BCM91480B
 linux-image-2.6.31-trunk-sparc64 - Linux 2.6.31 image on uniprocessor 64-bit UltraSPARC
 linux-image-2.6.31-trunk-sparc64-smp - Linux 2.6.31 image on multiprocessor 64-bit UltraSPARC
 linux-image-2.6.31-trunk-versatile - Linux 2.6.31 image on Versatile
 linux-libc-dev - Linux support headers for userspace development
 linux-manual-2.6.31 - Linux kernel API manual pages for version 2.6.31
 linux-patch-debian-2.6.31 - Debian patches to version 2.6.31 of the Linux kernel
 linux-source-2.6.31 - Linux kernel source for version 2.6.31 with Debian patches
 linux-support-2.6.31-trunk - Support files for Linux 2.6.31
 linux-tree-2.6.31 - Linux kernel source tree for building Debian kernel images
Closes: 278729 400825 464197 471495 494119 497230 507557 510279 515982 518710 522358 524142 525625 525958 527517 528694 530620 533357 535646 536333 536455 538159 538410 539176 539215 539369 539378 540486 541307 541630 541702 542470 542551 543244 545229 545377 545981 546041
Changes: 
 linux-2.6 (2.6.31-1~experimental.1) experimental; urgency=low
 .
   * New upstream release.
     - Support for W83627DHG-P (closes: #535646).
     - Restore MAC address and MTU change operations on Orinoco and others
       (Closes: #536455)
     - Remove incorrect ACPI blacklisting of ASUS P4B266 mainboards
       (Closes: #525625)
     - atl1c fixes for Eee PC model 1005HA-H. (closes: #538410)
     - parisc64-smp boot fix on J5600. (closes: #539369)
     - parisc: Fix GOT overflow during module load on 64bit kernel
       (closes: #539378)
     - xfs: fix freeing of inodes not yet added to the inode cache
       (Closes: #527517)
     - IPv6: add "disable" module parameter support to ipv6.ko.
       (closes: #542470)
     - IPv6: avoid wraparound for expired preferred lifetime
       (Closes: #518710)
     - Fixes lockups with older dual-CPU machines (Closes: #542551)
     - x86, pat: Allow ISA memory range uncacheable mapping requests
       (Closes: #538159)
     - drm/i915: Hook connector to encoder during load detection
       (Closes: #522358)
     - module: workaround duplicate section names (Closes: #545229)
     - b43: Add fw capabilities (Closes: #533357)
     - procfs: Fix idle time in uptime (Closes: #545981)
     - e1000, e1000e, igb, ixgb, ixgbe: Fix initial link state
       (Closes: #546041)
     - CIFS: Handle port= mount option correctly (Closes: #524142)
     - i915: Prevent screen flickering in X11 (Closes: #545377)
     - hppa: Ensure broadcast tlb purge runs single threaded
       (Closes: #539215)
 .
   [ maximilian attems ]
   * [powerpc64] Enable modular RTC_DRV_PS3, PS3_VRAM.
     (Closes: #528694)
   * Set new NETFILTER_XT_MATCH_OSF, FIREWIRE_NET, SND_CTXFI, USB_XHCI_HCD,
     IEEE802154, CAN_DEV, EEPROM_MAX6875, DM_LOG_USERSPACE, DM_MULTIPATH_QL,
     DM_MULTIPATH_ST, LIBERTAS_SPI, CAN_SJA1000, CAN_SJA1000_PLATFORM,
     CAN_EMS_PCI, CAN_KVASER_PCI, CB710_CORE, CNIC, RT2800USB,
     USB_NET_INT51X1, SND_LX6464ES, BLK_DEV_OSD, SCSI_BNX2_ISCSI, IWM,
     IEEE802154_DRIVERS, TOUCHSCREEN_EETI, TOUCHSCREEN_W90X900,
     BATTERY_MAX17040, SENSORS_TMP401, REGULATOR_USERSPACE_CONSUMER,
     REGULATOR_MAX1586, REGULATOR_LP3971, MEDIA_SUPPORT, CUSE,
     WL12XX, PPS, AB3100_CORE, SND_HDA_INPUT_JACK,MMC_SDHCI_PLTFM,
     MMC_CB710, MMC_VIA_SDMMC, LEDS_LP3944, RTC_DRV_RX8025,
     SMARTJOYPLUS_FF, USB_CDC_PHONET, USB_GSPCA_SN9C20X, MOUSE_SYNAPTICS_I2C,
     PCIEAER_INJECT.
   * Disable v4l1 ov511 and quickcam_messenger drivers.
   * [x86_64] Enable HW_RANDOM_VIA.
   * [x86] Keep divers staging stuff enabled.
   * [x86] Enable RT3070, COMEDI_PCMCIA_DRIVERS, ACERHDF, EDAC_AMD64,
     XEN_DEV_EVTCHN, XEN_SYS_HYPERVISOR, PERF_COUNTERS,
     CC_STACKPROTECTOR, DEFAULT_MMAP_MIN_ADDR=65536.
   * rtl8192su: remove firmware and disable.
   * Newer Standards-Version 3.8.2 without changes.
   * Allow install in chroot without do_initrd check for piuparts.
   * Cleanup Maintainer scripts from ancient pre linux-2.6 assumptions.
     (Also closes: #536333)
   * Disable DEVKMEM.
   * [ppc, sparc] Enable EFI_PARTITION. (closes: #540486)
   * Disable old USB_DEVICE_CLASS. (Closes: #510279)
   * Drop yaird initramfs generator support.
   * Add stable release 2.6.31.1.
   * Enable PREEMPT_VOLUNTARY.
 .
   [ Ben Hutchings ]
   * mga: remove unnecessary change from firmware-loading patch
   * cxgb3: remove PHY firmware and use request_firmware() to load it
   * Add firmware-linux-free package containing DFSG-free firmware
   * av7110: include firmware source and binary
   * snd-cs46xx: reenable using external firmware (closes: #464197,
     but note that Debian cannot currently distribute the firmware),
     thanks to Kalle Olavi Niemitalo <[email-masked]>
   * ib_ipath: remove firmware for QLogic IBA7220 and use
     request_firmware() to load it
   * dvb-usb-af9005: remove initialisation script derived from Windows
     driver and use request_firmware() to extract it at run-time
     (closes: #494119)
   * Add warning on upgrade to a new upstream version where the system
     appears to be missing necessary firmware files (closes: #541702)
   * qla1280: Release spinlock when requesting firmware (closes: #543244)
   * r128: Add test for initialisation to all ioctls that require it
     (closes: #541630)
   * rt{2860,2870,3070}sta: Use existing CCITT CRC implementation on
     firmware rather than adding an equivalent variant of ITU-T CRC
   * rd: Build as a module since we do not require initrd support
   * x86: Fix crash in text_poke_early() on 486-class processors
     (Closes: #515982)
   * intel-agp: Fix cache flushing on i8xx chipsets, avoiding graphics
     corruption and GPU lock-ups (Closes: #541307)
   * Generate architecture-qualified package relations as needed for
     flavours that exist for multiple architectures (Closes: #278729)
   * Prompt bug reporters to run the kernel version they're reporting on
     or otherwise record boot messages
   * Include PCI device list in bug reports even if the running kernel
     doesn't match
 .
   [ Martin Michlmayr ]
   * [armel/orion5x, armel/kirkwood] Set GPIO_SYSFS=y since these
     platforms have been converted to GPIOLIB.
   * [armel/orion5x, armel/kirkwood] Disable MARVELL_PHY since it may
     lead to conflicts with the built-in Ethernet.
   * Add features from 2.6.32:
     - crypto: mv_cesa - Add support for Orion5X crypto engine
   * [armel/orion5x] Enable CRYPTO_DEV_MV_CESA.
   * Disable SYS_HAS_EARLY_PRINTK on SGI IP22 to work around a hang
     during bootup (Closes: #507557)
   * [armel] Enable BPQETHER (on the request of Iain Young) and some
     other AX25 drivers.
 .
   [ Bastian Blank ]
   * Disable staging drivers by default.
   * Force all bugs against images to be reported to linux-2.6.
     (closes: #539176)
   * [arm] Remove old arm architecture.
   * Use kernel architecture for libc-dev build.
 .
   [ Moritz Muehlenhoff ]
   * Fix Linus' name in copyright file (Closes: #530620)
   * More verbose explanation on difference between Alpha flavour
     (Closes: #497230)
   * Add Vcs-Svn and Vcs-Browser stanzas pointing to the SVN branch
     used for development in unstable. There are other branches
     used for experimental (trunk), oldstable and stable, but Vcs-*
     doesn't yet provide the ability to distinguish branches in a
     more fine-grained manner. (Closes: #471495)
   * Update Standards-Version to 3.8.3, no changes needed
   * Disable PROM console support (Closes: #525958)
   * Make the description of linux-support a little more verbose
     (Closes: #400825)
   * This upload fixes the following security issues:
     - CVE-2009-3290 (2.6.31)
     - CVE-2009-3288 (2.6.31.1)
     - CVE-2009-3280 (2.6.31.1)
     - CVE-2009-3234 (2.6.31.1)
     - CVE-2009-3043 (2.6.31)
     - CVE-2009-3002 (2.6.31)
     - CVE-2009-3001 (2.6.31)
     - CVE-2009-2844 (2.6.31)
     - CVE-2009-2695 (2.6.31)
     - CVE-2009-2691 (2.6.31)
 .
   [ dann frazier ]
   * n_tty: Fix echo race
   * [ia64] Stop disabling CONFIG_HOTPLUG_CPU, which was blocking
     CONFIG_KEXEC from being enabled
   * [hppa] Disable CONFIG_AB3100_CORE, it fails to build
Checksums-Sha1: 
 a62576fb625b2255377ab31f5aa440bbeaefd55c 4926 linux-2.6_2.6.31-1~experimental.1.dsc
 8162b6b6d14a00a742e68480809ad4059602540a 78201361 linux-2.6_2.6.31.orig.tar.gz
 0566b3d85b23fe8e6e53aaed71926235faab7b14 359181 linux-2.6_2.6.31-1~experimental.1.diff.gz
 4016bb9b07d542d76a6dc4b8fb4404e3d47ad46f 5527578 linux-doc-2.6.31_2.6.31-1~experimental.1_all.deb
 8ef629e7f8f4b5c7550bd3e841c7929adbd57c5d 2069102 linux-manual-2.6.31_2.6.31-1~experimental.1_all.deb
 7de7e08b354541bb7c261347b6852e9da541e64b 205634 linux-patch-debian-2.6.31_2.6.31-1~experimental.1_all.deb
 34cb9674caaf70f3146a07307c1fe700f8b12cf8 60645174 linux-source-2.6.31_2.6.31-1~experimental.1_all.deb
 3330e9b64c8265575dbdf939b06835b85323ae53 129858 linux-support-2.6.31-trunk_2.6.31-1~experimental.1_all.deb
 b2e3db0b2eb062fbc7662a7228338e24ab2c1722 114522 linux-tree-2.6.31_2.6.31-1~experimental.1_all.deb
 520784598ae429403e7cfaeeeeaadb5962a332df 117434 firmware-linux-free_2.6.31-1~experimental.1_all.deb
 44ff8a5b9dae94906ffa2e44738491a0cd54d00d 27147072 linux-image-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
 de5b36e99966536808c603609d86813e333c091c 439606 linux-headers-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
 ab8bbfc9ff35d508e38e905f96e3883c789a8891 3739804 linux-headers-2.6.31-trunk-common_2.6.31-1~experimental.1_amd64.deb
 e3409acdfba5bccd00d77c276b670c0474b12162 114174 linux-headers-2.6.31-trunk-all_2.6.31-1~experimental.1_amd64.deb
 28646a34bb0702d1ae849d7c276a8e12d56a43af 114176 linux-headers-2.6.31-trunk-all-amd64_2.6.31-1~experimental.1_amd64.deb
 9f155540962cc155789651fae7aa5fb1a19338c3 869558 linux-libc-dev_2.6.31-1~experimental.1_amd64.deb
Checksums-Sha256: 
 9d56404c5a8746f96b8aaeb18c84876580e4f414f1b6bf880bf8f87932c6e89f 4926 linux-2.6_2.6.31-1~experimental.1.dsc
 334f348894f8c55d6337418a6894e1bbc13bb06ed7b02ab4ec7b47de6249f390 78201361 linux-2.6_2.6.31.orig.tar.gz
 f0a642cd6f97b46538d86235f3d821a1b337a66a4a1dca143420e5aa79cbda01 359181 linux-2.6_2.6.31-1~experimental.1.diff.gz
 1f667a83a122c43419a19d43a9b4fd824009938a57b204999cd8a5caa4b4b963 5527578 linux-doc-2.6.31_2.6.31-1~experimental.1_all.deb
 dd96101f656857d0fcfc058cdc33eb533d41323ecca77bc2c1ee8c9d2c0012f1 2069102 linux-manual-2.6.31_2.6.31-1~experimental.1_all.deb
 abe4a34454ceaaf1e91498577aacf5f9210e773f35622d8b637914a49250bbd1 205634 linux-patch-debian-2.6.31_2.6.31-1~experimental.1_all.deb
 1a1af10bac4b422beb24fdf3383bb8a9c7c32f38ef6a989ea192e4769c6c75cf 60645174 linux-source-2.6.31_2.6.31-1~experimental.1_all.deb
 8a1f28bd9f827adc4306af776e31df83555a467178b53519501dffc7acbc1206 129858 linux-support-2.6.31-trunk_2.6.31-1~experimental.1_all.deb
 b250ba7c2c478658397557e2099355329128a629e51a2e702839a2f9eb9ab518 114522 linux-tree-2.6.31_2.6.31-1~experimental.1_all.deb
 d714a832abe2e987f904e6064a7687f894ffbc5a2f6229c2dca2dbf6473cc51c 117434 firmware-linux-free_2.6.31-1~experimental.1_all.deb
 0f1b9e640ba628bfded635186d7d6a624455cd3e023f3e075db99fbd2ad86671 27147072 linux-image-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
 f6d4ad5cc0542280a3c55917c01af02d425c3b014d21836b2b0aaa808a2e8a4d 439606 linux-headers-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
 bdb0dc2100547c8f335921c8e05b6ea245243671061674e20352e91dbb2116d0 3739804 linux-headers-2.6.31-trunk-common_2.6.31-1~experimental.1_amd64.deb
 d53ba0a06a232e2dd7594188a2aa7727b8c15f62c3c497fbf29a7b8a865becea 114174 linux-headers-2.6.31-trunk-all_2.6.31-1~experimental.1_amd64.deb
 c747a3888b36fed1fdf551ad5bf35670b334d1af100e2a47508b4dc86d4190d4 114176 linux-headers-2.6.31-trunk-all-amd64_2.6.31-1~experimental.1_amd64.deb
 5c698722ee90a95d2315e3cde6c9731998c3c129ceeb3ceba3fe5066f27ca6fa 869558 linux-libc-dev_2.6.31-1~experimental.1_amd64.deb
Files: 
 6685669a5b9d6bd0f0ba8c1d3af68de0 4926 kernel optional linux-2.6_2.6.31-1~experimental.1.dsc
 5afda6957e06654a981df24cee38d802 78201361 kernel optional linux-2.6_2.6.31.orig.tar.gz
 1bf7384d84204ef2edee9f2ac5a3c0a6 359181 kernel optional linux-2.6_2.6.31-1~experimental.1.diff.gz
 f0d2def4ae700ca2d0105658c18fbffa 5527578 doc optional linux-doc-2.6.31_2.6.31-1~experimental.1_all.deb
 61da3d4d61654fd01d4969014c8d70e0 2069102 doc optional linux-manual-2.6.31_2.6.31-1~experimental.1_all.deb
 84bd11ed7d53670a7988d817e1ca0916 205634 kernel optional linux-patch-debian-2.6.31_2.6.31-1~experimental.1_all.deb
 2fb0a90d947e086eb61d8480ea097b19 60645174 kernel optional linux-source-2.6.31_2.6.31-1~experimental.1_all.deb
 c762c78004467d443297ef23d96b5ba1 129858 devel optional linux-support-2.6.31-trunk_2.6.31-1~experimental.1_all.deb
 9f5f92ea64141e486a2733f0e7bc6d65 114522 devel optional linux-tree-2.6.31_2.6.31-1~experimental.1_all.deb
 ad1b80057d971f8dd7e92107a8205689 117434 kernel optional firmware-linux-free_2.6.31-1~experimental.1_all.deb
 9758113de609e09ec1ba3641687d30b7 27147072 kernel optional linux-image-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
 b79fc1a1a52d7589ed44a0005c1ebb77 439606 kernel optional linux-headers-2.6.31-trunk-amd64_2.6.31-1~experimental.1_amd64.deb
 7d94ef022004c7ada9466c375e2bc26a 3739804 kernel optional linux-headers-2.6.31-trunk-common_2.6.31-1~experimental.1_amd64.deb
 2fd468405f99a6516cfafedb9db6c4fa 114174 kernel optional linux-headers-2.6.31-trunk-all_2.6.31-1~experimental.1_amd64.deb
 0a328e902506efb1e564e0b2428f3530 114176 kernel optional linux-headers-2.6.31-trunk-all-amd64_2.6.31-1~experimental.1_amd64.deb
 3c869616302efbfaf34cf83d9aafae78 869558 devel optional linux-libc-dev_2.6.31-1~experimental.1_amd64.deb

Subject: linux-image-2.6.29-1-686: CIFS VFS ignores port mount option
From: Nicholas Perez <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Wed, 15 Apr 2009 00:01:45 -0500

** Command line:
root=/dev/sda1 ro quiet

** Not tainted

** Kernel log:

** Loaded modules:
Module                  Size  Used by
nls_utf8                1472  0 
cifs                  254752  0 

** PCI devices:

-- System Information:

-- debconf information: