Subject: linux-image-2.6.29-1-686: CIFS VFS ignores port mount option

From: Nicholas Perez <[email-masked]>
Date: Wed, 15 Apr 2009 00:01:45 -0500

Package: linux-image-2.6.29-1-686
Version: 2.6.29-2
Severity: normal

When passing the port option to mount.cifs (so that I may redirect my
mount to use the SSH tunnel for example), it is ignored. The option is
properly parsed, but it has no effect what so ever in the code. See the
following for my little bit of research into this:

First setup netcat to listen locally for the CIFS connection:
nicholas@eeepc:~$ sudo netcat -l -p 445

Then attempt a mount with the port option set completely differently:
nicholas@eeepc:~$ sudo mount -t cifs -o port=65100 //localhost/external
/home/nicholas/test --verbose
parsing options: rw,port=65100
Password:

mount.cifs kernel mount options
unc=//localhost\external,user=root,pass=,ver=1,rw,port=65100
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

See the output from netcat:
MBr��+LM1.2X002LANMAN2.1NT LM 0.12POSIX 2

As you can see, the connection happened to the default port of 445
rather than the 65100 port that was specified. If I supply an IP address
the same thing happens.

-- Package-specific info:
** Version:
Linux version 2.6.29-1-686 (Debian 2.6.29-2) ([email-masked]) (gcc version 4.3.3 (Debian 4.3.3-5) ) #1 SMP Sat Apr 4 17:36:29 UTC 2009

** Command line:
root=/dev/sda1 ro quiet

** Not tainted

** Kernel log:
[23772.404071]  CIFS VFS: No response for cmd 114 mid 1
[23772.404121]  CIFS VFS: cifs_mount failed w/return code = -112

** Loaded modules:
Module                  Size  Used by
nls_utf8                1472  0 
cifs                  254752  0 
nls_base                6508  2 nls_utf8,cifs
i915                  129464  2 
drm                   133260  3 i915
i2c_algo_bit            4888  1 i915
ppdev                   6224  0 
parport_pc             22020  0 
lp                      7872  0 
parport                30868  3 ppdev,parport_pc,lp
xt_DSCP                 2636  3 
xt_limit                1768  1 
xt_recent               7784  2 
xt_tcpudp               2492  6 
xt_state                1752  3 
iptable_nat             5040  0 
nf_nat                 16120  1 iptable_nat
nf_conntrack_ipv4      11568  6 iptable_nat,nf_nat
nf_conntrack           58228  4 xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
nf_defrag_ipv4          1648  1 nf_conntrack_ipv4
iptable_mangle          3252  1 
iptable_filter          2944  1 
ip_tables               9892  3 iptable_nat,iptable_mangle,iptable_filter
x_tables               13672  7 xt_DSCP,xt_limit,xt_recent,xt_tcpudp,xt_state,iptable_nat,ip_tables
ipv6                  232468  34 
hid_gaff                2900  0 
hid_pl                  2996  0 
hid_cypress             2340  0 
hid_zpff                2652  0 
hid_gyration            2196  0 
hid_sony                2568  0 
hid_ntrig               1744  0 
hid_samsung             2112  0 
hid_microsoft           3200  0 
hid_tmff                3460  0 
hid_monterey            2132  0 
hid_ezkey               1832  0 
hid_apple               5704  0 
hid_a4tech              2500  0 
hid_logitech            6656  0 
usbhid                 29132  5 hid_gaff,hid_pl,hid_zpff,hid_tmff,hid_logitech
ff_memless              4264  5 hid_gaff,hid_pl,hid_zpff,hid_tmff,hid_logitech
hid_cherry              2100  0 
hid_sunplus             1972  0 
hid_petalynx            2468  0 
hid_belkin              2284  0 
hid_chicony             2004  0 
hid                    34260  21 hid_gaff,hid_pl,hid_cypress,hid_zpff,hid_gyration,hid_sony,hid_ntrig,hid_samsung,hid_microsoft,hid_tmff,hid_monterey,hid_ezkey,hid_apple,hid_a4tech,hid_logitech,usbhid,hid_cherry,hid_sunplus,hid_petalynx,hid_belkin,hid_chicony
joydev                  8560  0 
snd_hda_codec_realtek   173504  1 
snd_hda_intel          22092  0 
snd_hda_codec          58808  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               6000  1 snd_hda_codec
snd_pcm_oss            31708  0 
snd_mixer_oss          12000  1 snd_pcm_oss
snd_pcm                62708  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
arc4                    1544  2 
ecb                     2352  2 
snd_seq_dummy           2368  0 
snd_seq_oss            24756  0 
snd_seq_midi            5448  0 
snd_rawmidi            18544  1 snd_seq_midi
serio_raw               4544  0 
snd_seq_midi_event      6072  2 snd_seq_oss,snd_seq_midi
i2c_i801                8104  0 
ath5k                  96892  0 
snd_seq                42120  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
pcspkr                  2092  0 
psmouse                36628  0 
evdev                   8160  16 
i2c_core               20828  4 i915,drm,i2c_algo_bit,i2c_i801
mac80211              135592  1 ath5k
snd_timer              17808  2 snd_pcm,snd_seq
led_class               3668  1 ath5k
snd_seq_device          6108  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
rng_core                3644  0 
cfg80211               32996  2 ath5k,mac80211
atl2                   23032  0 
snd                    48420  12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               6204  1 snd
snd_page_alloc          8036  2 snd_hda_intel,snd_pcm
video                  16348  0 
output                  2504  1 video
eeepc_laptop           10120  0 
battery                 5832  0 
ac                      2872  0 
rfkill                  9576  2 eeepc_laptop
button                  5672  0 
ext3                  107180  1 
jbd                    42500  1 ext3
mbcache                 7180  1 ext3
sd_mod                 28252  2 
crc_t10dif              1616  1 sd_mod
ata_generic             4316  0 
ide_pci_generic         3408  0 
ide_core               91820  1 ide_pci_generic
usb_storage            83460  0 
ahci                   27568  0 
ata_piix               20092  1 
libata                148892  3 ata_generic,ahci,ata_piix
ehci_hcd               29936  0 
scsi_mod              132076  3 sd_mod,usb_storage,libata
usbcore               124912  5 hid_sony,usbhid,usb_storage,ehci_hcd
intel_agp              22548  1 
agpgart                30624  3 drm,intel_agp
thermal                15092  2 
processor              39540  1 thermal
fan                     4104  0 
thermal_sys            10272  4 video,thermal,processor,fan

** PCI devices:
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
	Latency: 0
	Capabilities: <access denied>
	Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f7f00000 (32-bit, non-prefetchable) [size=512K]
	Region 1: I/O ports at ec00 [size=8]
	Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 3: Memory at f7ec0000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>

00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at f7f80000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: <access denied>

00:1b.0 Audio device [0403]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller [8086:2668] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82a1]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 27
	Region 0: Memory at f7eb8000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel

00:1c.0 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 [8086:2660] (rev 04) (prog-if 00 [Normal decode])
	Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport-driver

00:1c.1 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 [8086:2662] (rev 04) (prog-if 00 [Normal decode])
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	Memory behind bridge: fbf00000-fbffffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport-driver

00:1c.2 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 [8086:2664] (rev 04) (prog-if 00 [Normal decode])
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Bus: primary=00, secondary=01, subordinate=02, sec-latency=0
	Memory behind bridge: f8000000-fbefffff
	Prefetchable memory behind bridge: 00000000f0000000-00000000f6ffffff
	Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>
	Kernel driver in use: pcieport-driver

00:1d.0 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 [8086:2658] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 3
	Region 4: I/O ports at e400 [size=32]

00:1d.1 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 [8086:2659] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 7
	Region 4: I/O ports at e480 [size=32]

00:1d.2 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 [8086:265a] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin C routed to IRQ 10
	Region 4: I/O ports at e800 [size=32]

00:1d.3 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 [8086:265b] (rev 04) (prog-if 00 [UHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin D routed to IRQ 5
	Region 4: I/O ports at e880 [size=32]

00:1d.7 USB Controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller [8086:265c] (rev 04) (prog-if 20 [EHCI])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 23
	Region 0: Memory at f7eb7c00 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev d4) (prog-if 01 [Subtractive decode])
	Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
	Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
	Capabilities: <access denied>

00:1f.0 ISA bridge [0601]: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge [8086:2641] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0

00:1f.2 IDE interface [0101]: Intel Corporation 82801FBM (ICH6M) SATA Controller [8086:2653] (rev 04) (prog-if 80 [Master])
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 19
	Region 0: I/O ports at 01f0 [size=8]
	Region 1: I/O ports at 03f4 [size=1]
	Region 2: I/O ports at 0170 [size=8]
	Region 3: I/O ports at 0374 [size=1]
	Region 4: I/O ports at ffa0 [size=16]
	Capabilities: <access denied>
	Kernel driver in use: ata_piix

00:1f.3 SMBus [0c05]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller [8086:266a] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:82d8]
	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin B routed to IRQ 19
	Region 4: I/O ports at 0400 [size=32]
	Kernel driver in use: i801_smbus

01:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter [168c:001c] (rev 01)
	Subsystem: Device [1a3b:1026]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 18
	Region 0: Memory at fbef0000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: ath5k

03:00.0 Ethernet controller [0200]: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter [1969:2048] (rev a0)
	Subsystem: ASUSTeK Computer Inc. Device [1043:8233]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 28
	Region 0: Memory at fbfc0000 (64-bit, non-prefetchable) [size=256K]
	Expansion ROM at fbfa0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: atl2

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-1-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.29-1-686 depends on:
ii  debconf [debconf-2.0]         1.5.26     Debian configuration management sy
ii  initramfs-tools [linux-initra 0.93.2     tools for generating an initramfs
ii  module-init-tools             3.7-pre9-1 tools for managing Linux kernel mo

Versions of packages linux-image-2.6.29-1-686 recommends:
ii  libc6-i686                    2.9-7      GNU C Library: Shared libraries [i

Versions of packages linux-image-2.6.29-1-686 suggests:
ii  grub                          0.97-53    GRand Unified Bootloader (Legacy v
pn  linux-doc-2.6.29              <none>     (no description available)

-- debconf information:
  linux-image-2.6.29-1-686/preinst/abort-overwrite-2.6.29-1-686:
  shared/kernel-image/really-run-bootloader: true
  linux-image-2.6.29-1-686/preinst/overwriting-modules-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/elilo-initrd-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/initrd-2.6.29-1-686:
  linux-image-2.6.29-1-686/preinst/bootloader-initrd-2.6.29-1-686: true
  linux-image-2.6.29-1-686/postinst/bootloader-test-error-2.6.29-1-686:
  linux-image-2.6.29-1-686/postinst/depmod-error-initrd-2.6.29-1-686: false
  linux-image-2.6.29-1-686/prerm/removing-running-kernel-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/lilo-has-ramdisk:
  linux-image-2.6.29-1-686/postinst/old-system-map-link-2.6.29-1-686: true
  linux-image-2.6.29-1-686/postinst/kimage-is-a-directory:
  linux-image-2.6.29-1-686/postinst/old-dir-initrd-link-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/lilo-initrd-2.6.29-1-686: true
  linux-image-2.6.29-1-686/postinst/depmod-error-2.6.29-1-686: false
  linux-image-2.6.29-1-686/postinst/bootloader-error-2.6.29-1-686:
  linux-image-2.6.29-1-686/preinst/failed-to-move-modules-2.6.29-1-686:
  linux-image-2.6.29-1-686/postinst/create-kimage-link-2.6.29-1-686: true
  linux-image-2.6.29-1-686/prerm/would-invalidate-boot-loader-2.6.29-1-686: true
  linux-image-2.6.29-1-686/preinst/abort-install-2.6.29-1-686:
  linux-image-2.6.29-1-686/postinst/old-initrd-link-2.6.29-1-686: true

---

From: Moritz Muehlenhoff <[email-masked]>
Date: Sat, 12 Sep 2009 20:45:14 +0200

On Wed, Apr 15, 2009 at 12:01:45AM -0500, Nicholas Perez wrote:
> MBr??????+LM1.2X002LANMAN2.1NT LM 0.12POSIX 2
> 
> 

Sorry for the late response.

This was fixed in 2.6.31, which will be uploaded soon.

Cheers,
        Moritz