Subject: Bug#527074: [alsa-utils] same thing on Powermac Burgundy

From: Gunther Furtado <[email-masked]>
Date: Thu, 27 Aug 2009 07:23:17 -0300

2009/8/27, Elimar Riesebieter <[email-masked]>:
> * Gunther Furtado <[email-masked]> [090827 00:37]:
>> Hi,
>>
>> 2009/8/26, Elimar Riesebieter <[email-masked]>:
> [...]
>> > And if you really have the same problem, fire up alsamixer, set
>> > channels , mixers etc, unmute master and pcm and test again.
>> >
>>
>> Did that and when I reboot the system, master is mute again.
>>
>> the output of the following command could be of interest:
>>
>> # /etc/init.d/alsa-utils restart
>> Shutting down ALSA...amixer: Invalid command!
>> done.
>> Setting up ALSA...done.
>
> What tells:
> # lsmod | grep snd
> # alsactl init
> ?
>

~# lsmod | grep snd
snd_powermac           49548  4
snd_pcm_oss            45784  0
snd_mixer_oss          21040  1 snd_pcm_oss
snd_pcm                80484  2 snd_powermac,snd_pcm_oss
snd_seq_midi           10576  0
snd_rawmidi            27180  1 snd_seq_midi
snd_seq_midi_event     10576  1 snd_seq_midi
snd_seq                59096  2 snd_seq_midi,snd_seq_midi_event
snd_timer              25828  2 snd_pcm,snd_seq
snd_seq_device         11044  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    66880  16
snd_powermac,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              10324  1 snd
snd_page_alloc         13252  1 snd_pcm

~# alsactl init
Unknown hardware: "PMac Burgundy" "PowerMac Burgundy" "" "" ""
Hardware is initialized using a guess method

Cheers,

-- 

Gunther Furtado
Curitiba - Paraná - Brasil
[email-masked]

"...agora, só nos sobrou o futuro...", visto em www.manuchao.net

---

From: Elimar Riesebieter <[email-masked]>
Date: Thu, 27 Aug 2009 13:45:35 +0200

> snd_page_alloc         13252  1 snd_pcm

Burgundy is supported by snd-powermac since ages...

> Hardware is initialized using a guess method
Well known, there is no database for powerpc hardware.

I guess you were using kmix or somethig like that to set up your
mixer. Alsa doesn't know these settings so it refused
/var/lib/alsa/asound.state. Please delete
/var/lib/alsa/asound.state, set your mixer with alsamixer, run
`alsactl store && invoke-rc.d alsa-utils restart` and check your
mixersetings again.

Elimar

-- 
  BOFH excuse #30:
  positron router malfunction

---

From: Gunther Furtado <[email-masked]>
Date: Thu, 27 Aug 2009 09:32:24 -0300

> `alsactl store && invoke-rc.d alsa-utils restart` and check your

Thanks,

I'll try that when I get home.

cheers,

---

From: Gunther Furtado <[email-masked]>
Date: Thu, 27 Aug 2009 09:43:42 -0300

Hi,

I think I didn't explain properly why I added the info on this bug
report. First of all I understood you were looking for reports of
cards that presented the same pattern so I sent you my case.

I thought I was helping because it is a *new* behavior and the closest
thing I found on BTS was this.

Sorry to bother you,

---

From: Gunther Furtado <[email-masked]>
Date: Fri, 28 Aug 2009 14:28:42 -0300

Hi,

> `alsactl store && invoke-rc.d alsa-utils restart` and check your

They are mute again.

Let me tell something odd that is happening here that may help you (I
don't know). What has been troubling me is that, as I already told
you, when I reboot the system the master is mute and the volume is set
to 0%.

What is odd is if I close the kde session *and* restart the X11 the
mixer is not muted but the volume is set back to 0%.

I am telling you this because there may be two different causes to the behavior.

Gunther,