Subject: Bug#527074: /etc/init.d/alsa-utils: `/etc/init.d/alsa-utils stop` triggers amixer error

From: Piotr Lewandowski <[email-masked]>
Date: Tue, 5 May 2009 16:03:25 +0200

Package: alsa-utils
Version: 1.0.19-2
Severity: minor
File: /etc/init.d/alsa-utils

#v+
$ sudo /etc/init.d/alsa-utils stop
Shutting down ALSA...amixer: Invalid command!
done.
#v-

It is caused by `mute_and_zero_level` function in /etc/init.d/alsa-utils 
which invokes: `amixer -c 0 -q set Mic 0% mute`.

Additional output from lspci:
#v+
$ lspci -v | sed -ne '/Audio/,/^$/p'
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High 
Definition Audio Controller (rev 01)
         Subsystem: Hewlett-Packard Company Device 30a2
         Flags: bus master, fast devsel, latency 0, IRQ 16
         Memory at f4580000 (64-bit, non-prefetchable) [size=16K]
         Capabilities: <access denied>
         Kernel driver in use: HDA Intel

#v-

-- System Information:
Debian Release: squeeze/sid
   APT prefers unstable
   APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-1-686 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=pl_PL.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages alsa-utils depends on:
ii  dialog                    1.1-20080819-1 Displays user-friendly dialog boxe
ii  libasound2                1.0.19-1       shared library for ALSA applicatio
ii  libc6                     2.9-9          GNU C Library: Shared libraries
ii  libncurses5               5.7+20090502-1 shared libraries for terminal hand
ii  linux-sound-base          1.0.19.dfsg-3  base package for ALSA and OSS soun
ii  lsb-base                  3.2-22         Linux Standard Base 3.2 init scrip
ii  module-init-tools         3.7-pre9-1     tools for managing Linux kernel mo

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.19.dfsg-3 ALSA driver configuration files
ii  pciutils                   1:3.1.2-3     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

-- 
Piotr Lewandowski

---

From: Elimar Riesebieter <[email-masked]>
Date: Wed, 6 May 2009 06:54:48 +0200

severity 52707 normal
merge 526872 52707
thanks

* Piotr Lewandowski [090505 16:03 +0200]
> which invokes: `amixer -c 0 -q set Mic 0% mute`.

Are you using kde? If so, set all audio settings to default and play
around with audioßettings in kmix, reboot and test again.

Elimar

-- 
  Numeric stability is probably not all that 
  important when you're guessing;-)

---

From: Piotr Lewandowski <[email-masked]>
Date: Wed, 6 May 2009 09:58:25 +0200

>around with audioßettings in kmix, reboot and test again.

I'm not using KDE. Most of the boots I do not use X at all - just 
staying at ttys.

Extra information about my soundcard:

#v+
$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.18a.

$ cat /proc/asound/cards
  0 [Intel          ]: HDA-Intel - HDA Intel
                       HDA Intel at 0xf4580000 irq 16
$ lsmod | grep snd
snd_hda_codec_si3054     3920  1
snd_hda_codec_analog    53708  1
snd_hda_intel           22092  0
snd_hda_codec           58808  3 snd_hda_codec_si3054,snd_hda_codec_analog,snd_hda_intel
snd_hwdep                6000  1 snd_hda_codec
snd_pcm                 62708  3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec
snd_seq                 42120  0
snd_timer               17808  2 snd_pcm,snd_seq
snd_seq_device           6108  1 snd_seq
snd                     48420  9 snd_hda_codec_si3054,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore                6204  1 snd
snd_page_alloc           8036  2 snd_hda_intel,snd_pcm
#v-

-- 
Piotr Lewandowski

---

From: [email-masked] (Debian Bug Tracking System)
Date: Thu, 17 Sep 2009 17:39:36 +0000

This is an automatic notification regarding your Bug report
which was filed against the alsa-utils package:

#527074: /etc/init.d/alsa-utils: `/etc/init.d/alsa-utils stop` triggers amixer error

It has been closed by Jordi Mallach <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Jordi Mallach <[email-masked]> by
replying to this email.

-- 
527074: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=527074
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Bug#527074: fixed in alsa-utils 1.0.21-1
From: Jordi Mallach <[email-masked]>
To: [email-masked]
Date: Thu, 17 Sep 2009 17:17:07 +0000

Source: alsa-utils
Source-Version: 1.0.21-1

We believe that the bug you reported is fixed in the latest version of
alsa-utils, which is due to be installed in the Debian FTP archive:

alsa-utils_1.0.21-1.diff.gz
  to pool/main/a/alsa-utils/alsa-utils_1.0.21-1.diff.gz
alsa-utils_1.0.21-1.dsc
  to pool/main/a/alsa-utils/alsa-utils_1.0.21-1.dsc
alsa-utils_1.0.21-1_i386.deb
  to pool/main/a/alsa-utils/alsa-utils_1.0.21-1_i386.deb
alsa-utils_1.0.21.orig.tar.gz
  to pool/main/a/alsa-utils/alsa-utils_1.0.21.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jordi Mallach <[email-masked]> (supplier of updated alsa-utils package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Thu, 17 Sep 2009 18:47:21 +0200
Source: alsa-utils
Binary: alsa-utils
Architecture: source i386
Version: 1.0.21-1
Distribution: unstable
Urgency: low
Maintainer: Jordi Mallach <[email-masked]>
Changed-By: Jordi Mallach <[email-masked]>
Description: 
 alsa-utils - ALSA utilities
Closes: 445802 523091 527074 540254 544495 544607
Changes: 
 alsa-utils (1.0.21-1) unstable; urgency=low
 .
   * New upstream release
    + mentions help key in alsamixer. (closes: #544495)
 .
   [ Elimar Riesebieter ]
   * /usr/share/alsa/init/default:52: missing closing brace for format. Fixed by
     a patch. Should be merged upstream for next version.
     (closes: #523091, #527074, #540254, #544607)
   * alsamixer/README isn't present anymore, so doesn't need to install.
   * Build-Depends: replace libncurses5-dev with libncursesw5-dev.
     (closes: #445802)
Checksums-Sha1: 
 bc6708a1aedbe62e54e7054889153f865d59adda 1495 alsa-utils_1.0.21-1.dsc
 86ca3cb0af0ee5fce0b5a92bd56e9b32ee9adaec 1343561 alsa-utils_1.0.21.orig.tar.gz
 d464c17170fff16fa2f1e9f3ba3f558100e02882 37041 alsa-utils_1.0.21-1.diff.gz
 25a6128e83bf07c6b9609baea0db3c5537b49993 1096902 alsa-utils_1.0.21-1_i386.deb
Checksums-Sha256: 
 1bd2508eb0c7cacb549268db76b4fd0d4551f8cd725de60277eca81e2fdd1581 1495 alsa-utils_1.0.21-1.dsc
 14273d9f807acc2751303547100d59bb6fe5156b3a31c788a39b3279a0c5d0a4 1343561 alsa-utils_1.0.21.orig.tar.gz
 3168296fa844c5cdd2b7ce67631a327b0442a28ce88babfc5e143d07f1794611 37041 alsa-utils_1.0.21-1.diff.gz
 08207adba87ce4c94a307ed1180e9f0be57f353941e8cb5f942b444d96d66e13 1096902 alsa-utils_1.0.21-1_i386.deb
Files: 
 ea8a4940570474a537d018365b9fef6c 1495 sound optional alsa-utils_1.0.21-1.dsc
 1a08297fc0883ecbfdf0d1c289f294fe 1343561 sound optional alsa-utils_1.0.21.orig.tar.gz
 3a7010dec2909cb33e539cfb349683af 37041 sound optional alsa-utils_1.0.21-1.diff.gz
 7dbca60b2b9783710cd1433d817d1ae8 1096902 sound optional alsa-utils_1.0.21-1_i386.deb

Subject: /etc/init.d/alsa-utils: `/etc/init.d/alsa-utils stop` triggers amixer error
From: Piotr Lewandowski <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Tue, 5 May 2009 16:03:25 +0200

Package: alsa-utils
Version: 1.0.19-2
Severity: minor

#v+

#v-

-- System Information:

-- 
Piotr Lewandowski