Subject: /etc/init.d/alsa-utils: `/etc/init.d/alsa-utils stop` triggers amixer error

From: Piotr Lewandowski <[email-masked]>
Date: Tue, 5 May 2009 16:03:25 +0200

Package: alsa-utils
Version: 1.0.19-2
Severity: minor
File: /etc/init.d/alsa-utils

#v+
$ sudo /etc/init.d/alsa-utils stop
Shutting down ALSA...amixer: Invalid command!
done.
#v-

It is caused by `mute_and_zero_level` function in /etc/init.d/alsa-utils 
which invokes: `amixer -c 0 -q set Mic 0% mute`.

Additional output from lspci:
#v+
$ lspci -v | sed -ne '/Audio/,/^$/p'
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High 
Definition Audio Controller (rev 01)
         Subsystem: Hewlett-Packard Company Device 30a2
         Flags: bus master, fast devsel, latency 0, IRQ 16
         Memory at f4580000 (64-bit, non-prefetchable) [size=16K]
         Capabilities: <access denied>
         Kernel driver in use: HDA Intel

#v-

-- System Information:
Debian Release: squeeze/sid
   APT prefers unstable
   APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-1-686 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=pl_PL.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages alsa-utils depends on:
ii  dialog                    1.1-20080819-1 Displays user-friendly dialog boxe
ii  libasound2                1.0.19-1       shared library for ALSA applicatio
ii  libc6                     2.9-9          GNU C Library: Shared libraries
ii  libncurses5               5.7+20090502-1 shared libraries for terminal hand
ii  linux-sound-base          1.0.19.dfsg-3  base package for ALSA and OSS soun
ii  lsb-base                  3.2-22         Linux Standard Base 3.2 init scrip
ii  module-init-tools         3.7-pre9-1     tools for managing Linux kernel mo

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.19.dfsg-3 ALSA driver configuration files
ii  pciutils                   1:3.1.2-3     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

-- 
Piotr Lewandowski

---

From: Elimar Riesebieter <[email-masked]>
Date: Wed, 6 May 2009 06:54:48 +0200

severity 52707 normal
merge 526872 52707
thanks

* Piotr Lewandowski [090505 16:03 +0200]
> which invokes: `amixer -c 0 -q set Mic 0% mute`.

Are you using kde? If so, set all audio settings to default and play
around with audioßettings in kmix, reboot and test again.

Elimar

-- 
  Numeric stability is probably not all that 
  important when you're guessing;-)

---

From: Piotr Lewandowski <[email-masked]>
Date: Wed, 6 May 2009 09:58:25 +0200

>around with audioßettings in kmix, reboot and test again.

I'm not using KDE. Most of the boots I do not use X at all - just 
staying at ttys.

Extra information about my soundcard:

#v+
$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.18a.

$ cat /proc/asound/cards
  0 [Intel          ]: HDA-Intel - HDA Intel
                       HDA Intel at 0xf4580000 irq 16
$ lsmod | grep snd
snd_hda_codec_si3054     3920  1
snd_hda_codec_analog    53708  1
snd_hda_intel           22092  0
snd_hda_codec           58808  3 snd_hda_codec_si3054,snd_hda_codec_analog,snd_hda_intel
snd_hwdep                6000  1 snd_hda_codec
snd_pcm                 62708  3 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec
snd_seq                 42120  0
snd_timer               17808  2 snd_pcm,snd_seq
snd_seq_device           6108  1 snd_seq
snd                     48420  9 snd_hda_codec_si3054,snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore                6204  1 snd
snd_page_alloc           8036  2 snd_hda_intel,snd_pcm
#v-

-- 
Piotr Lewandowski