Subject: slim: doesn't stop daemon on uninstall

From: Matthew Palmer <[email-masked]>
Date: Sun, 31 May 2009 13:51:32 +1000

Package: slim
Version: 1.3.0-1+lenny1

I just uninstalled slim, and no attempt was made to stop the daemon in the
maintainer scripts.  This is somewhat untidy.

- Matt

---

From: Mike Massonnet <[email-masked]>
Date: Mon, 8 Jun 2009 16:11:58 +0200

tags 531248 wontfix
kthxbye

No, it is the right behavior. Slim must not be stopped while/after it
is being uninstalled for a simple reason: the process apt-get remove
started through a terminal emulator must not be killed or crap will
happen. And I doubt you had like you X session to be taken down for
uninstall a software.

Mike