Subject: alsa-utils: Master channel muted after each boot

From: Julien Valroff <[email-masked]>
Date: Sun, 02 Aug 2009 08:09:21 +0200

Package: alsa-utils
Version: 1.0.20-2
Severity: normal

Hi,

The master channel is muted after each boot and its level is set to 0.

I have edited the init script to remove all calls to mute_and_zero_levels()
and things work ok now.
I am not sure this is the best thing to do.

I have an HDA intel card.

Not sure what other information would be useful, please do not hesitate to
ask for futher details.

Cheers,
Julien

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (150, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages alsa-utils depends on:
ii  dialog                    1.1-20080819-1 Displays user-friendly dialog boxe
ii  libasound2                1.0.20-3       shared library for ALSA applicatio
ii  libc6                     2.9-23         GNU C Library: Shared libraries
ii  libncurses5               5.7+20090613-1 shared libraries for terminal hand
ii  linux-sound-base          1.0.20+dfsg-1  base package for ALSA and OSS soun
ii  lsb-base                  3.2-23         Linux Standard Base 3.2 init scrip
ii  module-init-tools         3.9-2          tools for managing Linux kernel mo
ii  whiptail                  0.52.10-4      Displays user-friendly dialog boxe

Versions of packages alsa-utils recommends:
ii  alsa-base                  1.0.20+dfsg-1 ALSA driver configuration files
ii  pciutils                   1:3.1.3-1     Linux PCI Utilities

alsa-utils suggests no packages.

-- no debconf information

---

From: Elimar Riesebieter <[email-masked]>
Date: Thu, 6 Aug 2009 19:38:36 +0200

* Julien Valroff [090802 08:09 +0200]
> Not sure what other information would be useful, please do not hesitate to

How are the settings after

# /etc/init.d/alsa-utils reset
# alsactl store
# /etc/init.d/alsa-utils restart

?

Elimar
-- 
  You cannot propel yourself forward by
  patting yourself on the back.

---

From: Julien Valroff <[email-masked]>
Date: Fri, 07 Aug 2009 21:40:00 +0200

Hi Elimar,

> # /etc/init.d/alsa-utils reset
The output is set to 30% (according to gnome-volume-control-applet

> # /etc/init.d/alsa-utils restart

When stopped, the channel is muted, and is reset to 30%

After reboot, the output is again set to 0%

Note this is a freshly instelled system (same sound hardware, just
changed the harddisk).

Cheers,
Julien

---

From: Elimar Riesebieter <[email-masked]>
Date: Sat, 8 Aug 2009 16:22:09 +0200

* Julien Valroff [090807 21:40 +0200]
> Note this is a freshly instelled system (same sound hardware, just

Maybe pulseaudio is setting the main level at boottime? Check your
gnome sound setiings.

Elimar

-- 
  Learned men are the cisterns of knowledge, 
  not the fountainheads ;-)

---

From: Julien Valroff <[email-masked]>
Date: Sat, 08 Aug 2009 18:11:21 +0200

> Maybe pulseaudio is setting the main level at boottime? Check your

I don't think so, as there is no such option in pulseaudio I am aware
of.
More over, if I remove all calls to mute_and_zero_levels() in alsa-utils
init script, sound level is ok after boot. The same happens if I
uninstall alsa-utils completely (I must say I do not really need it but
I do not understand what causes this odd behaviour)

Cheers,
Julien

---

From: Julien Valroff <[email-masked]>
Date: Fri, 28 Aug 2009 22:21:59 +0200

reassign 539579 gnome-media
thanks

Hi Elimar,

> I do not understand what causes this odd behaviour)

It seems you were right, as removing pulseaudio and using esound lead to
"solving" my issue.

I reassign this bug to gnome-media.

To gnome-media maintainer : when gnome-volume-control-applet is launched
on session start, my main volume channel is muted and its level set at
0%.
It does not happen when using "pure" esound (ie. removing pulseaudio
packages, which results in not starting the applet).
It also does not happen if I remove calls to mute_and_zero_levels() in
alsa-utils init script (which made me think the issue was in
alsa-utils).

It happens to different users (if you read French, see discussion on
[email-masked] at
http://lists.debian.org/debian-user-french/2009/08/msg00707.html)

I wasn't sure if this bug should be re-assigned to pulseaudio or not,
but as I think the issue is with gnome-volume-control-applet, you might
be the best person to help me understand the issue).

Cheers,
Julien